ubuntu/+source/yelp:ubuntu/bionic-proposed

Last commit made on 2018-04-13
Get this branch:
git clone -b ubuntu/bionic-proposed https://git.launchpad.net/ubuntu/+source/yelp
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/bionic-proposed
Repository:
lp:ubuntu/+source/yelp

Recent commits

b99ebf0... by Jeremy Bicha on 2018-04-13

Import patches-unapplied version 3.26.0-1ubuntu2 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: b98ffc1747c952f7546047a8b502d5df89d81aca

New changelog entries:
  * Cherry-pick appstream.patch from yelp 3.28 to add AppStream metadata
  * Build-Depend on appstream-util
  * Install new AppStream metadata

b98ffc1... by Jeremy Bicha on 2017-10-11

Import patches-unapplied version 3.26.0-1ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 57b6503acab60b6944aeccc3d50a82d9526fbad1

New changelog entries:
  * Merge with Debian (LP: #1722797). Remaining changes:
    - debian/control:
      + Don't recommend fonts-dejavu, Ubuntu uses other fonts
    - debian/source_yelp.py, debian/yelp.install:
      + Install apport hook
    - debian/patches/07_disable_package_search.patch:
      + Remove "Search for packages" feature since it doesn't work with
        Ubuntu's default install.

57b6503... by Laurent Bigonville on 2017-10-04

Import patches-unapplied version 3.26.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9c70b506d0adede9472cde5ea474c7f6a2356a52

New changelog entries:
  [ Jeremy Bicha ]
  * New upstream release
  * debian/control.in:
    - Bump minimum libwebkit2gtk-4.0-dev to 2.15.1
    - Don't recommend gnome-user-docs since yelp is used in other desktops
  [ Laurent Bigonville ]
  * debian/control.in: Bump Standards-Version to 4.1.1 (no further changes)

9c70b50... by Michael Biebl on 2016-09-20

Import patches-unapplied version 3.22.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 42a51f2406b223e97323176348009963fd671001

New changelog entries:
  * New upstream release.
  * Bump debhelper compat level to 10.

42a51f2... by Michael Biebl on 2016-09-06

Import patches-unapplied version 3.21.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 40c17d0f18e25eff24b54fcdc140ac1b6b592069

New changelog entries:
  [ Jeremy Bicha ]
  * Convert from cdbs to dh
  * Bump dh compat to 9
  * Convert to multiarch
  * Enable all hardening flags
  * Add debian/docs to explicitly include NEWS and README
  * Re-enable building gtk-doc since bug 803104 was fixed in webkit2gtk
  [ Michael Biebl ]
  * New upstream release.

40c17d0... by Michael Biebl on 2016-04-18

Import patches-unapplied version 3.20.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f51ecff841ce4bd9c7ff1a6b6e9422c18f38b336

New changelog entries:
  * New upstream release.
  * The private libyelpcommon library has been removed again upstream, update
    debian/libyelp0.install accordingly.
  * Update debian/libyelp0.symbols with new additions. Drop the optional
    libyelpcommon symbols, which no longer exist.
  * Temporarily disable building the gtk-oc documentation and ship the
    pre-generated files. The gtk-doc scanner currently segfaults if $DISPLAY
    is not available.
  * Bump Standards-Version to 3.9.8.

f51ecff... by Michael Biebl on 2015-10-24

Import patches-unapplied version 3.18.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cde03265557a94fc993cc237f3a08256898f01ca

New changelog entries:
  [ Josselin Mouette ]
  * Remove Debian menu entry.
  [ Andreas Henriksson ]
  * New upstream release.
  * Update (build-)dependencies according to configure.ac changes:
    - switch from libwebkitgtk-3.0-dev to libwebkit2gtk-4.0-dev (>= 2.7.1)
  [ Michael Biebl ]
  * Fix typo in debian/copyright.
  * Override the lintian error source-is-missing for data/mathjax/*. The
    non-minified files are shipped in data/mathjax/unpacked/.
  * Drop debian/patches/03_info_crasher.patch, fixed upstream with a different
    approach.
  * Parts of libyelp moved into a new package-private libyelpcommon library.
    Install that new library along with the new web extension as part of
    libyelp0. Make sure to exclude those shared libraries from dh_makeshlibs.
    Update the symbols file for libyelp0 accordingly and remove all those
    symbols which are now private and part of libyelpcommon.
  * There are still a few symbols left which are private and not part of the
    public API. Mark them as (conditional). See also bgo#756658.

cde0326... by Michael Biebl on 2015-05-19

Import patches-unapplied version 3.16.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 70284e8ebe69c9efd667b0b31f50d3b23bc35edc

New changelog entries:
  * New upstream release.
  * Bump Build-Depends on libglib2.0-dev to (>= 2.38.0).
  * Bump Depends on yelp-xsl to (>= 3.12.0).
  * Update symbols files. A few private symbols were dropped. This should be
    fine since yelp has a strictly versioned dependency on libyelp0.
  * Update debian/copyright and convert it to the machine-readable copyright
    format 1.0.

70284e8... by Michael Biebl on 2014-10-14

Import patches-unapplied version 3.14.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7d5d2cde6149f6d2752c2e65e7e5a82bd84828fc

New changelog entries:
  * New upstream release.
  * Update Homepage URL.
  * Drop the versioned Breaks against yelp << 3.13 from libyelp0. The yelp
    package has a strictly versioned dependendency on libyelp0, so the
    packages can't get out of sync.
  * Bump Standards-Version to 3.9.6. No further changes.
  * Refresh patches.

7d5d2cd... by Andreas Henriksson on 2014-09-23

Import patches-unapplied version 3.14.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0918229ae32539db8ef04fdba726203a36b9cfa2

New changelog entries:
  * libyelp0: Bump Breaks on yelp to << 3.13 to prevent half-upgraded
    broken state because of removed symbols (which is unused outside
    of src:yelp).
  * New upstream release.
  * Upload to unstable.