ubuntu/+source/xkeyboard-config:ubuntu/precise-updates

Last commit made on 2013-11-05
Get this branch:
git clone -b ubuntu/precise-updates https://git.launchpad.net/ubuntu/+source/xkeyboard-config
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/precise-updates
Repository:
lp:ubuntu/+source/xkeyboard-config

Recent commits

b7f9129... by James M. Leddy on 2013-05-31

Import patches-unapplied version 2.5-1ubuntu1.5 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 024cd036e4a45e1e48256ee2363bc188f13acfb2

New changelog entries:
  * Revert last commit due to a SRU verification failure.
  * Add patch 115_add_XF86AudioMicMute.patch. This maps F20 to the new
    XF86AudioMicMute keysym. Cherrypick from upstream. (LP: #408903)

024cd03... by Bryce Harrington on 2012-09-24

Import patches-unapplied version 2.5-1ubuntu1.4 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: aceaf73ac3c0a6f7ccb3d401d5d211d416e4ef9a

New changelog entries:
  * Add patch 114_shift_f10.patch. Don't let Ctrl+Alt consume Shift, else
    it causes Shift-F10 to be treated as F10. This can result in popup
    menus opening when they shouldn't.
    (LP: #937822)

aceaf73... by Bryce Harrington on 2012-06-26

Import patches-unapplied version 2.5-1ubuntu1.3 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: f1d7d0e31ab41c953a89a468061c8d3fdf781371

New changelog entries:
  * Add 113_ossmath_is_five_levels.patch: Some keymaps like fr(oss) fail to
    load because they include ossmath (via keypad(oss)) which
    misconfigures the keypad as 4-level when it should be 5-level. This
    patch from upstream bugzilla fixes this by adding the 5th level to the
    ossmath definition.
    (LP: #985065)
  * Drop 109_fr_oss_space_char.patch change; the fix causes behavioral
    changes for right control which a fr(oss) user did not like.
    (LP: #1013881)

f1d7d0e... by Bryce Harrington on 2012-06-05

Import patches-unapplied version 2.5-1ubuntu1.2 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 4a4700be429cef8114f26ccfdfd82c475c0576cb

New changelog entries:
  * Add 111_cz_ssharp.patch: Fix mapping of 4th level of the AC11 key to
    ssharp rather than quotedbl for the Czech layout. Cherrypick of
    patch from upstream.
    (LP: #953477)
  * Add 112_dk_dvorak_tilde.patch: Fix tilde key in the Danish Dvorak
    layout. It's not the same as Norwegian as has been assumed previously.
    (LP: #989626)

4a4700b... by Bryce Harrington on 2012-05-17

Import patches-unapplied version 2.5-1ubuntu1.1 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 53e5bb411221ea77a57c2209bfd5af46b1770be6

New changelog entries:
  * Add 109_fr_oss_space_char.patch: Fix problems using space bar in various
    applications when using the fr(oss) keymap.
    (LP: #221112)
  * Add 110_dead_hook_horn.patch: Add two deadkeys on level 3 and 4 of the
    j key for the latin keymap.
    (LP: #825624)

53e5bb4... by Timo Aaltonen on 2012-01-23

Import patches-unapplied version 2.5-1ubuntu1 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 20d864051af60d4322b8c2c3342a1ad530ba8bab

New changelog entries:
  * Merge from Debian experimental. Remaining Ubuntu changes:
    + rules, xkb-data-i18n.install, xkb-data.install: Split out
      xkb-data-i18n to be used by console-setup.
    + 105_intelligent_keyboard.patch: Add support for the Intelligent
      Keyboard K04
    + 108_fix_intltool_make_check.diff: Fix make check in the presence
      of the quilt patch system.
    + xkb-data.postinst.in: Migrate console-setup/keyboard-configuration
      settings from dvorak-intl to dvorak-alt-intl to match rename in
      xkeyboard-config 1.9. (LP: 742683)
  * xkb-data.install: Add missing directories (man, pkgconfig).
  * xkb-data.postinst: Remove the xkb cache to make sure it gets regenerated.

20d8640... by Cyril Brulebois on 2012-01-20

Import patches-unapplied version 2.5-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 88f92ad262af34ef717585ba8790f7abd3b81ba0

New changelog entries:
  * New upstream release, including:
    - Hide ClearGrab/CloseGrabs actions behind an option.
  * To get those actions back, use the grab:break_actions option. At
    the moment, the corresponding actionve has been disabled on the
    server side as a hot fix for CVE-2012-0064 (Closes: #656500).
  * Since there's a workaround on the server side already, do not use
    a high urgency, so that this new upstream release and its various
    changes can be tested for a while in unstable.
  * Update URL in watch file.
  * Add xsltproc, xutils-dev build-deps.
  * Keep /usr/share/man out of the udeb, due to a newly-added manpage.

88f92ad... by Cyril Brulebois on 2011-12-21

Import patches-unapplied version 2.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 272b1961bf7a78347ed15f1b2e364542023306dd

New changelog entries:
  * Upload to unstable, for GNOME3 (Closes: #652871).
  * Adapt dh_autoreconf override since its behaviour changed.

272b196... by Cyril Brulebois on 2011-06-03

Import patches-unapplied version 2.3-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 6c7b12a34d71a43fd5235c87b7fb0a07e5a8cfc9

New changelog entries:
  * New upstream release:
    - Since 2.1 is still supposed to be the best for GNOME2, and since
      GNOME3 is still being prepared in experimental, target that suite
      rather than unstable.
  * Add intltool build-dep.

6c7b12a... by Cyril Brulebois on 2011-04-06

Import patches-unapplied version 2.2.1-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: edbff9a32fa09f2d9e692d18417fb33f7d019e95

New changelog entries:
  * New upstream release:
    - Big rewrite for GNOME3.
  * By default, run-time dependencies are checked at build-time:
    - Pass --disable-runtime-deps to disable that check since there's no
      point in doing so for Debian packages.
    - Break earlier versions of libx11-6.
  * Get rid of old maintainer scripts to upgrade from 1.6 since squeeze
    has 1.8.
  * Refresh patches.
  * Switch to dh:
    - Bump debhelper build-dep/compat to 8.
    - Use dh-autoreconf.
    - Rewrite debian/rules accordingly.
    - Build out-of-tree.
  * Remove debian/xsfbs/, no longer needed.
  * Remove debian/patches/quiltrc, not really needed.