ubuntu/+source/vte:ubuntu/karmic-security

Last commit made on 2010-07-15
Get this branch:
git clone -b ubuntu/karmic-security https://git.launchpad.net/ubuntu/+source/vte
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/karmic-security
Repository:
lp:ubuntu/+source/vte

Recent commits

b6c33a8... by Kees Cook on 2010-07-14

Import patches-unapplied version 1:0.22.2-0ubuntu2.1 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 0278cdb68b6e9ceabbdb0240fc187c282342a3ae

New changelog entries:
  * SECURITY UPDATE: arbitrary command injection via ESC codes.
    - debian/patches/94_refix_dangerous_esc.patch: revert to static replies.
    - CVE-2010-2713

0278cdb... by Michael Vogt on 2009-09-29

Import patches-unapplied version 1:0.22.2-0ubuntu2 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 580f69ac2bba9b5b7d600a296c885c54cef62f53

New changelog entries:

  * debian/patches/10_fix_pyenv.patch:
    - fix environment passing in python to fork_command(), see
      https://bugzilla.gnome.org/show_bug.cgi?id=587894
    - This fixes gdebi-gtk and it can install packages again
      (LP: #438266)
  [ Michael Vogt ]
  * new upstream version:
   - Fix crash on terminal reset
    - Fix build on Solaris
    - Bugs fixed in this release:
        Bug 596365 - libvte crashes when issueing 'reset' in a terminal
        Bug 588033 - background tabs may lose lines off the bottom of
                     the scrollback
        Bug 596163 - Doesn't display expected background color in ncurses apps
        Bug 596011 - Problem compiling vte 0.22.0 on Solaris
  [ Luke Yelavich ]
  * new upstream version, 0.22.2:
    - Fix crash introduced in previous release
    - Fix a11y assertion failure LP: #435646
    - Improve selection at the end of row
    - Bugs fixed in this release:
        Bug 596444 - word-select includes \n when the word ends at the edge of
                     the terminal
        Bug 596460 - 0.22.1 kills vte based apps
  * debian/patches/90_autoreconf.patch: refreshed

580f69a... by Didier Roche on 2009-09-22

Import patches-unapplied version 1:0.22.0-0ubuntu1 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: a1c08a732fb3a5532b628169706f8d835641ec35

New changelog entries:
  * New upstream version (LP: #434563)
    - Fix tab and wide-char handling
    - Another rewrite of the ring. Stores ring data on tmp files on disk now.
      Please report any regressions.
  * Update DEB_DH_MAKESHLIBS_ARGS_ALL in debian/rules
  * refresh debian/patches/90_autoreconf.patch

a1c08a7... by Didier Roche on 2009-09-22

Import patches-unapplied version 1:0.21.5-0ubuntu1 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 58d30485cb1ffe52ede58c12e84154a2fdc082bb

New changelog entries:
  * New upstream version (LP: #419808)
    - Finish ring rewrite. Scrollback buffer consumes ten times less
      memory now, and better, doesn't allocate from the heap, so closing
      tabs actually releases memory.
    - Remove another stale assert()
    - Oops, use the right map decoding function is iso2022 code
    - Really fix the ring this time
    - Enable g_assert(). May trigger some bogus ones now. Please report.
    - gnome terminal crashes with glibc detected
    - Redesigning the vte buffer ring is going on. Please report any misbehavior
    - gnome-terminal crashed with SIGSEGV after hiting ctrl+o (LP: #408745)
    - text mode program rendering is strange in cjk locale.
    - bashisms in shell scripts
  * Update DEB_DH_MAKESHLIBS_ARGS_ALL in debian/rules
  * debian/patches:
    - remove 01_bashisms.patch: taken upstream
    - refresh 90_autoreconf.patch

58d3048... by Chris Coulson on 2009-06-16

Import patches-unapplied version 1:0.20.5-1ubuntu1 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 4c2e7ab93c6e94d1e00c9713559e0f64e03a2d1a

New changelog entries:
  * Merge from debian unstable (LP: #388046), remaining changes:
    - debian/control{.in}:
      + Build-depend on python-all-dbg.
      + Build-depend on libgtk-directfb-2.0-0 2.15.4-0ubuntu4, to
        correct a wrong dependency in libvte9-udeb.
      + Add Vcs-Bzr info.
      + Add python-vte-dbg package.
    - debian/python-vte.install:
      + Make it build against python 2.6 new FS layout
    - debian/rules:
      + Build a python-vte-dbg package.
      + Clean .a and .la files from package to keep .install file easy
        to read.
    - debian/patches/91_keep_fds.patch:
      + Keep file descriptors open on vte_fork_pty().
    - debian/patches/93_add_alt_screen_scroll_toggle.patch:
      + Handle scrolling differently when using alternate screen
        or scrolling is restricted.
  * Closes LP: #314826 and LP: #369440.

4c2e7ab... by Sebastian Dröge on 2009-06-10

Import patches-unapplied version 1:0.20.5-1 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 8c576608584f7cd339bbc611f858cf6b0ac7e9ce

New changelog entries:
  * New upstream bugfix release, undoing the unintended
    soname bump (Closes: #532552):
    + debian/control.in,
      debian/*.install:
      - Undo package rename.
    + debian/patches/90_autoreconf.patch:
      - Updated for the new version.
  [ Josselin Mouette ]
  * Add libglib2.0-doc, libgtk2.0-doc and libatk1.0-doc to b-d-i to
    ensure proper xrefs.
  * 01_bashisms.patch: fix bashims in provided scripts. Closes: #530123.
  [ Sebastian Dröge ]
  * New upstream bugfix releases:
    + debian/rules:
      - Update shlibs version to >= 0.20.4 for API additions.
    + debian/control.in,
      debian/*.install:
      - Update for the new soname.
    + debian/patches/90_autoreconf.patch:
      - Regenerated for the new version.

8c57660... by Josselin Mouette <email address hidden> on 2009-04-22

Import patches-unapplied version 1:0.20.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6c7f0f89ca4104df28e06ff3ccd39c04ccf068a9

New changelog entries:
  [ Luca Bruno ]
  * New upstream release.
  * debian/patches/20_make_ft2_optional.patch:
    - Removed as ft2 files have been removed upstream.
  * debian/patches/12_python_reaper.patch,
    debian/patches/25_optional-ncurses.patch,
    debian/patches/90_autoreconf.patch:
    - Updated to apply cleanly.
  * debian/patches/30_fix_build_no_pty_helper.patch,
    debian/patches/04_dsp_non_alias.patch,
    debian/patches/92_full_bold_fonts.patch:
    - Removed as applied upstream.
  * debian/control.in:
    - General dependencies changes:
      + Removed libxt, libxft, libfontconfig1, libxrenderer and libfreetype6
        as they are no more referenced in the upstream code since using
        pangocairo.
      + Bump libglib2.0-dev to 2.18.0.
      + Bump libgtk2.0-dev to 2.14.0.
      + Specify libpango1.0-dev version needed is 1.22.0.
    - Build-Depends:
      + Added libgladeui-1-dev.
    - libvte-dev Depends:
      + Removed libatk1.0-dev, libsm-dev, libice-dev, zlib1g-dev and
        libx11-dev.
    - Update Standards-Version to 3.8.1, no additional changes needed.
  * debian/rules:
    - Removed xft2, ft, pangox, glX and x configure options.
    - Add -DX_DISPLAY_MISSING to udeb CFLAGS.
    - Add --enable-glade-catalogue to DEB_CONFIGURE_EXTRA_FLAGS to install
      gladeui files.
  * debian/libvte-common.install:
    - Install gladeui files under /usr/share/glade3.
  [ Josselin Mouette ]
  * New upstream release.
  * Install the Python development files in libvte-dev and make this
    package provide python-vte-dev, just in case.
  * Fix dh_pysupport invocation.
  * Bump shlibs to version 1:0.19.4.
  * Remove libvte-dev dependency on ncurses.
  * Remove incorrect Provides: in python-vte.
  * Switch to quilt to manage patches.
  * 90_autoreconf.patch: updated for the new version.

6c7f0f8... by Josselin Mouette <email address hidden> on 2009-03-04

Import patches-unapplied version 1:0.17.4-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4456075fab5f160163f9d637809818b29b517269

New changelog entries:
  * Upload to unstable.
  * New upstream release:
    + debian/control.in:
      - Update build-depends.
      - Update Standards-Version to 3.8.0, no additional changes needed.
    + debian/rules:
      - Update shlibs version to reflect API additions.
    + debian/patches/29_add_am_prog_cc_c_o_for_buffer_c.patch,
      debian/patches/01_anjuta_hang.patch:
      - Dropped, merged upstream.
    + debian/patches/20_make_ft2_optional.patch,
      debian/patches/90_autoreconf.patch:
      - Updated to apply cleanly again.
    + debian/patches/92_full_bold_fonts.patch:
      - Patch from the Ubuntu package to first check if a bold variant
        of a font exists before using "pseudo-bolding".
    + debian/python-vte.examples:
      - Add some more examples, taken from the Ubuntu package.
  * debian/watch:
    + Updated for new versions.

4456075... by Josselin Mouette <email address hidden> on 2008-10-24

Import patches-unapplied version 1:0.16.14-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 529fc2216ad88cd81fb8f8f66fe897dca3dcdc68

New changelog entries:
  [ Josselin Mouette ]
  * libvte-doc.links: add a link in /usr/share/doc to the documentation.
    Closes: #495356.
  [ Loic Minier ]
  * Don't overwrite DEB_FIXPERMS_EXCLUDE and DEB_DH_MAKESHLIBS_ARGS_ALL.
  [ Josselin Mouette ]
  * 01_anjuta_hang.patch: new patch, stolen from upstream. Fix hangs in
    Geany and Anjuta. Closes: #498295.

529fc22... by Loïc Minier on 2008-08-04

Import patches-unapplied version 1:0.16.14-3 to debian/lenny

Imported using git-ubuntu import.