ubuntu/+source/vte:applied/ubuntu/edgy

Last commit made on 2006-10-02
Get this branch:
git clone -b applied/ubuntu/edgy https://git.launchpad.net/ubuntu/+source/vte
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/edgy
Repository:
lp:ubuntu/+source/vte

Recent commits

df1bda2... by Sebastien Bacher on 2006-10-02

Import patches-applied version 1:0.14.1-0ubuntu1 to applied/ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 5569ec01a7cb7400cb99da0a3e723558efefb6c0
Unapplied parent: 1c7093a10543663e5b60facf905abb1d591d8ac9

New changelog entries:
  * New upstream version:
    - autoscroll only works one way in fullscreen [PATCH]
    - font setting cleanup
    - libvte broken with new autotools
    - Suppress multiple warnings for missing control sequence handlers
    - vte-0.14.0: undefined C code
    - Define G_LOG_DOMAIN=Vte.

1c7093a... by Sebastien Bacher on 2006-10-02

Import patches-unapplied version 1:0.14.1-0ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: cf62d4bd31f0389d91f04471bb0cf63328a340c1

New changelog entries:
  * New upstream version:
    - autoscroll only works one way in fullscreen [PATCH]
    - font setting cleanup
    - libvte broken with new autotools
    - Suppress multiple warnings for missing control sequence handlers
    - vte-0.14.0: undefined C code
    - Define G_LOG_DOMAIN=Vte.

5569ec0... by Daniel Holbach on 2006-09-05

Import patches-applied version 1:0.14.0-0ubuntu1 to applied/ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 4bb88cdbf27efa2274209b8c40c78fa11810e29c
Unapplied parent: cf62d4bd31f0389d91f04471bb0cf63328a340c1

New changelog entries:
  * New upstream release:
    - Minor doc syntax update.
    - Fix bug causing empty lines to not being copied.
  * Resynchronized with Debian, only Ubuntu changes are:
    - debian/patches/91_keep_fds.patch: Distro fix.
    - debian/pyversions: "2.3-" -> "2"
    - debian/python-vte.install: simplify installation rules (and don't ship
      python2.3 which we don't have).
  * New upstream development release; no API change.
  * New upstream development release; no API change.
  * Merge 1:0.12.2-3.
  * New upstream development releases, with API changes.
    - Target at experimental.
    - Rename livte4 to libvte9 for the new SONAME.
    - Bump shlibs to >= 1:0.13.3.
    - Drop 08_set_backspace_to_utf8 patch, merged upstream.
    - Drop 09_multiscreen_safe, fixed upstream.
    - Drop 70_relibtoolize, I'm too lazy to update it for dev releases.
    - Bump up libglib2.0-dev build-dep to > 2.9.0.
  * Drop useless DEB_PYTHON_SYSTEM=pysupport.
  * Rework package build completely to follow pyversions --requested.
  * Set pyversions to "2.3-".
  * Urgency medium since this fixes a FTBFS.
  [ Loic Minier ]
  * Remove versions in Conflicts/Replaces with python2.X-vte.
  [ Josselin Mouette ]
  * 12_python_reaper.patch: patch from Michael Vogt to add a python
    binding for the reaper object (closes: #364383, #381143).
  [ Loic Minier ]
  * Add ${misc:Depends}.
  [ Loic Minier ]
  * New upstream release.
    - Relibtoolize.
      [debian/patches/70_relibtoolize.patch]
  * Fix watch file.
  [ Gustavo Franco ]
  * Python New Policy Transition. (Closes: #373405)
    - debian/control:
      - python-vte now provides Python 2.3 and 2.4 vte Python bindings.
      - Add python-support as Build-Depends.
      - Fix python-vte package description.
    - debian/rules:
      - Add DEB_PYTHON_SYSTEM variable and set to pysupport.
      - Make the needed changes to provide Python 2.3 and 2.4 vte Python
        bindings in the same binary package (python-vte).
      - Remove dh_python call since it's no more needed.
      - Add dh_pysupport call in binary-install/python-vte target.
    - Remove debian/python{2.3,2.4}-vte.install
    - Add debian/python-vte.install
  * Set debhelper compatibility to 5.
  [ Josselin Mouette ]
  * Set fatalerror as the primary maintainer.
  * Make the package binNMU-safe.
    + Build-depend on dpkg-dev 1.13.19.
    + Use ${source:Version} and ${binary:Version}.
  [ Loic Minier ]
  * Stop shipping /usr/lib/*.la files in libvte-dev.
    [debian/libvte-dev.install]
  * New upstream release, with API additions.
    - Bump up libgtk2.0-dev build-dep to >= 2.6.0.
      [debian/control, debian/control.in]
    - Add a libglib2.0-dev build-dep (> 2.6.0).
      [debian/control, debian/control.in]
    - Bump shlibs to >= 1:0.12.1.
      [debian/rules]
    - Drop restricted region adjustment patch as upstream merged it and also
      fixed a couple of issues it had.
      [debian/patches/20_restricted_region_readjustment.patch]
    - Relibtoolize.
      [debian/patches/70_relibtoolize.patch]
  * Fix clenaup of /debian/tmp-2.3 instead of debian/tmp-2.3 introduced with
    Python 2.4 support.
    [debian/rules]
  * Bump up Standards-Version to 3.7.2.
    [debian/control, debian/control.in]
  * Drop references to libXcursor.la
  * New upstream release.
  * debian/patches/20_restricted_region_readjustment.patch:
    - patch from upstream CVS to fix the famous Blue Screen of
      Death with irssi running inside screen.
  * debian/copyright:
    - updated list of upstream authors
    - updated to use http://download.gnome.org/
  * debian/watch:
    - updated to use http://download.gnome.org/
  * Fix Python build-deps, thanks Jan Lübbe.
    [debian/control, debian/control.in]
  * Merge nice patch from Jan Lübbe to build vte's python bindings for python
    2.3 and 2.4. (Closes: #353434)
    [debian/control, debian/control.in, debian/python-vte.install,
    debian/python2.3-vte.install, debian/python2.4-vte.install, debian/rules]
  * Tune up the descriptions slightly.
    [debian/control, debian/control.in]
  * Let python2.3-vte replace previous versions of python-vte.
    [debian/control, debian/control.in]
  * New upstream release.
  * New upstream release.
    - Shift+Insert pasting works as in the past. (Closes: #354275)
  * New upstream release.
    - Drop double free() fix (merged upstream).
      [debian/patches/07_remove_doublefree.patch]
  * New upstream release.
    - This release backs out all changes made to the .pc file in
      debian/patches/30_pkg-config-private-fields.patch, and hence reopens
      #340406, but should include proper -I flags. (Closes: #346039)
    - New patch to move only the libfreetype link flags to Libs.private.
      [debian/patches/30_pkg-config-private-field-for-freetype.patch]
      (Closes: #340406)
    - Drop patch adding console sequesnces to save/restore cursor position
      (merged upstream).
      [debian/patches/05_cursor_position.patch]
    - Drop relibtoolizing patch as the person bootstrapping vte for GNOME was
      visibly running Debian. :)
      [debian/patches/70_relibtoolize.patch]
  * New upstream release.
    - Drop patch to use .private pkg-config pseudo-headers (included
      upstream).
      [debian/patches/30_pkg-config-private-fields.patch]
    - No need to "rm python/vte.c", this is not distributed upstream anymore.
      [debian/rules]
    - Drop patch to fix gdk warnings (included upstream).
      [debian/patches/20_gdk-warning.patch]
    - Relibtoolize.
      [debian/patches/70_relibtoolize.patch]
  * Build-depend on libfreetype6-dev (>= 2.0.2) to match the checks in
    configure.in. (Closes: #340412)
    [debian/control, debian/control.in]
  * Use pkg-config's Libs.private and Requires.private field for libraries and
    packages needed only for static linking instead of the Libs / Requires
    fields; you need to build-depend on pkg-config (>= 0.18) to use these
    fields. Based on a patch by Steve Langasek. (Closes: #340406)
    [debian/patches/30_pkg-config-private-fields.patch]
  * Force regeneration of the python bindings by removing python/vte.c.
    (Closes: #334001, #334668, #338090)
    [debian/rules]
  * Urgency high for RC bug fix.
  * Add libsm-dev, libice-dev, zlib1g-dev, libncurses5-dev | libncurses-dev,
    libx11-dev, and libfontconfig1-dev deps to vte-dev, according to its .pc
    file. (Closes: #259671) [debian/control, debian/control.in]
  [ Sebastien Bacher ]
  * debian/control.in:
    - use ${python:Depends}.
  * debian/python-vte.install:
    - don't use a specific python version.
  * debian/rules:
    - use dh_python.
  [ Loic Minier ]
  * New upstream releases.
    - Fix confusion between py_palette and item in
      _wrap_vte_terminal_set_colors(), doesn't segfault anymore in
      vte.Terminal.set_colors(). (Closes: #319987)
  * Add CDBS' utils.
  * Drop obsolete patches. [debian/patches/02_path_xtra.patch,
    debian/patches/03_path_xtra-2.patch,
    debian/patches/11_hide_pageup_behavior.patch]
  * Temporarily add libxt-dev build-dependency to let
    AC_PATH_X/AC_PATH_XTRA autodetect X development files, see
    <http://bugzilla.gnome.org/show_bug.cgi?id=314669>.
  * Update FSF address. [debian/copyright]
  * Urgency high for testing targetted RC bugfix.
  * Add dependencies to libvte-dev on libxft-dev, libfreetype6-dev,
    libatk1.0-dev, libpango1.0-dev, libglib2.0-dev to conform with libvte.la's
    dependency_libs. [debian/control, debian/control.in] (Closes: #259671)
  * Fix Gdk warnings with a patch from upstream. (Closes: #316940, #318549)
    [debian/patches/20_gdk-warning.patch]
  * Bump up Standards Version to 3.6.2.
  * Rebuild on an unstable box to avoid dependencies in experimental.
  * New upstream version
  * Added a new package that contains the documentation (Closes: #300742)
  * debian/patches:
    - 01_vtemodule.patch: applied
  * New upstream version. Lots of patches in Gnome's bugzilla have been
    applied.
  * debian/patches :
    - Merged patches :
        05_performance_boost.patch
        10_redraw_vte_screen.patch
        12_fix_display_corrption_in_utf8.patch
    - Splitted 02_path_xtra.patch into to patches :
        02_path_xtra.patch contains the configure.in patch
        03_path_xtra-2.patch contains the configure patch
    - Updated 07_remove_doublefree.patch as it's partially applied
  * Added patches from Emil Soleyman-Zomalan <email address hidden>.
  * debian/patches:
    - Balanced performance improvement (Closes: #197797)
        05_performance_boost.patch
        http://bugs.gnome.org/show_bug.cgi?id=143914
    - Resolve double free problem
        07_remove_doublefree.patch
        http://bugs.gnome.org/show_bug.cgi?id=161337
    - Set backspace behavior to utf8 (depends on utf8 locale)
        08_set_backspace_to_utf8.patch
        http://bugs.gnome.org/show_bug.cgi?id=158200
    - Make vte multi-screen safe
        09_multiscreen_safe.patch
        http://bugs.gnome.org/show_bug.cgi?id=160782
    - Redraw vte screen with correct background color
        10_redraw_vte_screen.patch
        http://bugs.gnome.org/show_bug.cgi?id=125364
    - Hide manifestation of PageUp behavior with less (Closes: #285143)
        11_hide_pageup_behavior.patch
        http://bugzilla.gnome.org/show_bug.cgi?id=115149
    - Fix utf8 display cooruption (Closes: #276316)
        12_fix_display_corrption_in_utf8.patch
        http://bugzilla.gnome.org/show_bug.cgi?id=154896
  * debian/patches:
    - Relibtoolized 02_path_xtra.patch (Closes: #259671)
    - Added an updated patch from http://bugs.gnome.org/show_bug.cgi?id=142640
    to display correctly fonts (Closes: #251355)

cf62d4b... by Daniel Holbach on 2006-09-05

Import patches-unapplied version 1:0.14.0-0ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: fef24093bb2d0fe16bf35ec62ec9ba2335d20893

New changelog entries:
  * New upstream release:
    - Minor doc syntax update.
    - Fix bug causing empty lines to not being copied.
  * Resynchronized with Debian, only Ubuntu changes are:
    - debian/patches/91_keep_fds.patch: Distro fix.
    - debian/pyversions: "2.3-" -> "2"
    - debian/python-vte.install: simplify installation rules (and don't ship
      python2.3 which we don't have).
  * New upstream development release; no API change.
  * New upstream development release; no API change.
  * Merge 1:0.12.2-3.
  * New upstream development releases, with API changes.
    - Target at experimental.
    - Rename livte4 to libvte9 for the new SONAME.
    - Bump shlibs to >= 1:0.13.3.
    - Drop 08_set_backspace_to_utf8 patch, merged upstream.
    - Drop 09_multiscreen_safe, fixed upstream.
    - Drop 70_relibtoolize, I'm too lazy to update it for dev releases.
    - Bump up libglib2.0-dev build-dep to > 2.9.0.
  * Drop useless DEB_PYTHON_SYSTEM=pysupport.
  * Rework package build completely to follow pyversions --requested.
  * Set pyversions to "2.3-".
  * Urgency medium since this fixes a FTBFS.
  [ Loic Minier ]
  * Remove versions in Conflicts/Replaces with python2.X-vte.
  [ Josselin Mouette ]
  * 12_python_reaper.patch: patch from Michael Vogt to add a python
    binding for the reaper object (closes: #364383, #381143).
  [ Loic Minier ]
  * Add ${misc:Depends}.
  [ Loic Minier ]
  * New upstream release.
    - Relibtoolize.
      [debian/patches/70_relibtoolize.patch]
  * Fix watch file.
  [ Gustavo Franco ]
  * Python New Policy Transition. (Closes: #373405)
    - debian/control:
      - python-vte now provides Python 2.3 and 2.4 vte Python bindings.
      - Add python-support as Build-Depends.
      - Fix python-vte package description.
    - debian/rules:
      - Add DEB_PYTHON_SYSTEM variable and set to pysupport.
      - Make the needed changes to provide Python 2.3 and 2.4 vte Python
        bindings in the same binary package (python-vte).
      - Remove dh_python call since it's no more needed.
      - Add dh_pysupport call in binary-install/python-vte target.
    - Remove debian/python{2.3,2.4}-vte.install
    - Add debian/python-vte.install
  * Set debhelper compatibility to 5.
  [ Josselin Mouette ]
  * Set fatalerror as the primary maintainer.
  * Make the package binNMU-safe.
    + Build-depend on dpkg-dev 1.13.19.
    + Use ${source:Version} and ${binary:Version}.
  [ Loic Minier ]
  * Stop shipping /usr/lib/*.la files in libvte-dev.
    [debian/libvte-dev.install]
  * New upstream release, with API additions.
    - Bump up libgtk2.0-dev build-dep to >= 2.6.0.
      [debian/control, debian/control.in]
    - Add a libglib2.0-dev build-dep (> 2.6.0).
      [debian/control, debian/control.in]
    - Bump shlibs to >= 1:0.12.1.
      [debian/rules]
    - Drop restricted region adjustment patch as upstream merged it and also
      fixed a couple of issues it had.
      [debian/patches/20_restricted_region_readjustment.patch]
    - Relibtoolize.
      [debian/patches/70_relibtoolize.patch]
  * Fix clenaup of /debian/tmp-2.3 instead of debian/tmp-2.3 introduced with
    Python 2.4 support.
    [debian/rules]
  * Bump up Standards-Version to 3.7.2.
    [debian/control, debian/control.in]
  * Drop references to libXcursor.la
  * New upstream release.
  * debian/patches/20_restricted_region_readjustment.patch:
    - patch from upstream CVS to fix the famous Blue Screen of
      Death with irssi running inside screen.
  * debian/copyright:
    - updated list of upstream authors
    - updated to use http://download.gnome.org/
  * debian/watch:
    - updated to use http://download.gnome.org/
  * Fix Python build-deps, thanks Jan Lübbe.
    [debian/control, debian/control.in]
  * Merge nice patch from Jan Lübbe to build vte's python bindings for python
    2.3 and 2.4. (Closes: #353434)
    [debian/control, debian/control.in, debian/python-vte.install,
    debian/python2.3-vte.install, debian/python2.4-vte.install, debian/rules]
  * Tune up the descriptions slightly.
    [debian/control, debian/control.in]
  * Let python2.3-vte replace previous versions of python-vte.
    [debian/control, debian/control.in]
  * New upstream release.
  * New upstream release.
    - Shift+Insert pasting works as in the past. (Closes: #354275)
  * New upstream release.
    - Drop double free() fix (merged upstream).
      [debian/patches/07_remove_doublefree.patch]
  * New upstream release.
    - This release backs out all changes made to the .pc file in
      debian/patches/30_pkg-config-private-fields.patch, and hence reopens
      #340406, but should include proper -I flags. (Closes: #346039)
    - New patch to move only the libfreetype link flags to Libs.private.
      [debian/patches/30_pkg-config-private-field-for-freetype.patch]
      (Closes: #340406)
    - Drop patch adding console sequesnces to save/restore cursor position
      (merged upstream).
      [debian/patches/05_cursor_position.patch]
    - Drop relibtoolizing patch as the person bootstrapping vte for GNOME was
      visibly running Debian. :)
      [debian/patches/70_relibtoolize.patch]
  * New upstream release.
    - Drop patch to use .private pkg-config pseudo-headers (included
      upstream).
      [debian/patches/30_pkg-config-private-fields.patch]
    - No need to "rm python/vte.c", this is not distributed upstream anymore.
      [debian/rules]
    - Drop patch to fix gdk warnings (included upstream).
      [debian/patches/20_gdk-warning.patch]
    - Relibtoolize.
      [debian/patches/70_relibtoolize.patch]
  * Build-depend on libfreetype6-dev (>= 2.0.2) to match the checks in
    configure.in. (Closes: #340412)
    [debian/control, debian/control.in]
  * Use pkg-config's Libs.private and Requires.private field for libraries and
    packages needed only for static linking instead of the Libs / Requires
    fields; you need to build-depend on pkg-config (>= 0.18) to use these
    fields. Based on a patch by Steve Langasek. (Closes: #340406)
    [debian/patches/30_pkg-config-private-fields.patch]
  * Force regeneration of the python bindings by removing python/vte.c.
    (Closes: #334001, #334668, #338090)
    [debian/rules]
  * Urgency high for RC bug fix.
  * Add libsm-dev, libice-dev, zlib1g-dev, libncurses5-dev | libncurses-dev,
    libx11-dev, and libfontconfig1-dev deps to vte-dev, according to its .pc
    file. (Closes: #259671) [debian/control, debian/control.in]
  [ Sebastien Bacher ]
  * debian/control.in:
    - use ${python:Depends}.
  * debian/python-vte.install:
    - don't use a specific python version.
  * debian/rules:
    - use dh_python.
  [ Loic Minier ]
  * New upstream releases.
    - Fix confusion between py_palette and item in
      _wrap_vte_terminal_set_colors(), doesn't segfault anymore in
      vte.Terminal.set_colors(). (Closes: #319987)
  * Add CDBS' utils.
  * Drop obsolete patches. [debian/patches/02_path_xtra.patch,
    debian/patches/03_path_xtra-2.patch,
    debian/patches/11_hide_pageup_behavior.patch]
  * Temporarily add libxt-dev build-dependency to let
    AC_PATH_X/AC_PATH_XTRA autodetect X development files, see
    <http://bugzilla.gnome.org/show_bug.cgi?id=314669>.
  * Update FSF address. [debian/copyright]
  * Urgency high for testing targetted RC bugfix.
  * Add dependencies to libvte-dev on libxft-dev, libfreetype6-dev,
    libatk1.0-dev, libpango1.0-dev, libglib2.0-dev to conform with libvte.la's
    dependency_libs. [debian/control, debian/control.in] (Closes: #259671)
  * Fix Gdk warnings with a patch from upstream. (Closes: #316940, #318549)
    [debian/patches/20_gdk-warning.patch]
  * Bump up Standards Version to 3.6.2.
  * Rebuild on an unstable box to avoid dependencies in experimental.
  * New upstream version
  * Added a new package that contains the documentation (Closes: #300742)
  * debian/patches:
    - 01_vtemodule.patch: applied
  * New upstream version. Lots of patches in Gnome's bugzilla have been
    applied.
  * debian/patches :
    - Merged patches :
        05_performance_boost.patch
        10_redraw_vte_screen.patch
        12_fix_display_corrption_in_utf8.patch
    - Splitted 02_path_xtra.patch into to patches :
        02_path_xtra.patch contains the configure.in patch
        03_path_xtra-2.patch contains the configure patch
    - Updated 07_remove_doublefree.patch as it's partially applied
  * Added patches from Emil Soleyman-Zomalan <email address hidden>.
  * debian/patches:
    - Balanced performance improvement (Closes: #197797)
        05_performance_boost.patch
        http://bugs.gnome.org/show_bug.cgi?id=143914
    - Resolve double free problem
        07_remove_doublefree.patch
        http://bugs.gnome.org/show_bug.cgi?id=161337
    - Set backspace behavior to utf8 (depends on utf8 locale)
        08_set_backspace_to_utf8.patch
        http://bugs.gnome.org/show_bug.cgi?id=158200
    - Make vte multi-screen safe
        09_multiscreen_safe.patch
        http://bugs.gnome.org/show_bug.cgi?id=160782
    - Redraw vte screen with correct background color
        10_redraw_vte_screen.patch
        http://bugs.gnome.org/show_bug.cgi?id=125364
    - Hide manifestation of PageUp behavior with less (Closes: #285143)
        11_hide_pageup_behavior.patch
        http://bugzilla.gnome.org/show_bug.cgi?id=115149
    - Fix utf8 display cooruption (Closes: #276316)
        12_fix_display_corrption_in_utf8.patch
        http://bugzilla.gnome.org/show_bug.cgi?id=154896
  * debian/patches:
    - Relibtoolized 02_path_xtra.patch (Closes: #259671)
    - Added an updated patch from http://bugs.gnome.org/show_bug.cgi?id=142640
    to display correctly fonts (Closes: #251355)

4bb88cd... by Jordi Mallach on 2004-06-20

Import patches-applied version 1:0.11.11-4 to applied/ubuntu/warty

Imported using git-ubuntu import.

Unapplied parent: fef24093bb2d0fe16bf35ec62ec9ba2335d20893

fef2409... by Jordi Mallach on 2004-06-20

Import patches-unapplied version 1:0.11.11-4 to ubuntu/warty

Imported using git-ubuntu import.