ubuntu/+source/vim:ubuntu/quantal

Last commit made on 2012-08-29
Get this branch:
git clone -b ubuntu/quantal https://git.launchpad.net/ubuntu/+source/vim
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/quantal
Repository:
lp:ubuntu/+source/vim

Recent commits

0e4ab56... by Michael Bienia on 2012-08-29

Import patches-unapplied version 2:7.3.547-4ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 0fe7c742c1647e7d91d2364ce35b7bf9d0f97892

New changelog entries:
  * Make vim-* installable again (lp: #1043035) by merging with Debian
    unstable:
    - debian/runtime/debian.vim.in:
      + Add Launchpad integration to the Help menu if launchpad-integration is
        installed.
    - debian/runtime/vimrc:
      + "syntax on" is a sane default for non-tiny vim
    - debian/patches/debian/ubuntu-grub-syntax.patch:
      + Add Ubuntu-specific "quiet" keyword.

0fe7c74... by James McCoy on 2012-07-24

Import patches-unapplied version 2:7.3.547-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 99c53e5414e631dc720cddfb4dbed8a6e21bf08a

New changelog entries:
  * Add remove-py_config.patch, removing the dependence on Python's config.c.
    (Closes: #681599)

99c53e5... by James McCoy on 2012-06-26

Import patches-unapplied version 2:7.3.547-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5c327d1e41d664583e1704bf2295365ae51c926c

New changelog entries:
  * Add netrw-syntax-fix.patch to fix a syntax error in NetRead's ftp
    handling. (Closes: #678513)

5c327d1... by James McCoy on 2012-06-22

Import patches-unapplied version 2:7.3.547-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9cf85efb5772e689b4b1ceaa5ff70a3c71625e03

New changelog entries:
  * Work around GCC 4.7 optimization bug, #678122, by explicitly using gcc-4.6

9cf85ef... by James McCoy on 2012-06-07

Import patches-unapplied version 2:7.3.547-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 894fd70b43352745fcc31c192c79ad1202ab27e1

New changelog entries:
  * Merge upstream tag v7-3-547
  * Change ruby(-dev) Build-Depends to use unversioned package names in order
    to build with the default ruby version.
  * Add spell-check support to Debian control syntax file.

894fd70... by James McCoy on 2012-05-25

Import patches-unapplied version 2:7.3.524-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 73d36dfaed0f2d85db8f0291c418b930d8aee289

New changelog entries:
  * Merge upstream tag v7-3-524
    + Recognize git commit files in submodules. (Closes: #663735)
    + Fix NetRW's munging of options when opening files. (Closes: #661720)
    + 7.3.485: Use environment's LDFLAGS when building xxd. (Closes: #663605)
    + Update recognized keywords for dircolors syntax. (Closes: #660632)
  * Exclude the tools directory from the install.
    + Stop shipping scripts which use Perl4 functionality. (Closes: #659431)
    + Remove lintian overrides for csh scripts.
    + Remove patch debian/awk-shebang.patch
  * Remove EOLed Lenny/Maverick releases, add Quantal release to runtime
    files.
  * Remove upstream/po-syntax-cpo.patch, merged upstream.
  * Remove upstream/debian-runtime-*.patch, merged upstream.
  * Remove upstream/fr-manpage-fixes.patch, merged upstream.
  * Remove upstream/xdefaults-syntax-define.patch, merged upstream.
  * Add lintian override for binaries-have-file-conflict. vim-runtime diverts
    vim-tiny's doc/help.txt and doc/tags.
  * Remove unused menu-icon-missing override.

73d36df... by James McCoy on 2012-02-11

Import patches-unapplied version 2:7.3.429-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1066ea12365f3de93b0fe764ae72fee57ee433d9

New changelog entries:
  * Ignore failures in test61 since it is highly sensitive to timing.
    Slow/heavily loaded systems will cause the test to fail.
  * Install bug scripts with correct permissions.
    + Use dh_bugfiles to simplify process
    + Bump debhelper B-D to >= 7.2.3~

1066ea1... by James McCoy on 2012-02-05

Import patches-unapplied version 2:7.3.429-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 33154e87fc65635279e9364e5798a5f817f3227d

New changelog entries:
  * Pull upstream tag v7-3-429
    + Updated sshconfig syntax file. (Closes: #594296)
    + 7.3.365: Fix crash when using a large Unicode character with syntax
      highlighting. (Closes: #657777)
  * Add new education and introspection sections to debcontrol syntax file.
    (Closes: #651381)
  * Update vim-common's mime information to handle only having vim-tiny
    installed. (Closes: #654674)
    + Add test -x /usr/bin/vim for the vim entries.
    + Add lower-priority vi entries.
  * Use new --enable-fail-if-missing flag to make configure fail if an
    interpreter is enabled but configure test fails.
  * Add bug script to show what binaries the vi/vim/gvim symlinks point to.
  * Only use /u/s/dpkg/default.mk when available.
    + Reduce versioned B-D on dpkg-dev
    + Manually set relevant makefile variables if file isn't present
  * Add alternate libncurses5-dev B-D to ease backporting.

33154e8... by James McCoy on 2011-12-01

Import patches-unapplied version 2:7.3.363-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5acf2417050783240cef6982f7628d105e12b0d3

New changelog entries:
  * Pull upstream tag v7-3-363
    + 7.3.358: Fix mouse handling since urxvt support. (Closes: #647055)
  * Set vim-lesstif's section to oldlibs, as suggested by
    transitional-package-should-be-oldlibs-extra.

5acf241... by James McCoy on 2011-10-21

Import patches-unapplied version 2:7.3.346-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: dade6ec80bbaa809932496d0933cbbcff0c538a2

New changelog entries:
  * Pull upstream tag v7-3-346
    + 7.3.337: Redraw the screen after resizing the terminal. (Closes:
      #644668)
    + 7.3.343: Add mouse support for urxvt.
    + 7.3.344: Use read()/write() instead of fputs()/fread() to detect when
      the child GUI process has started. (Closes: #644639)
  * Don't build vim-gnome on m68k, since the dependencies aren't available.
  * Update Debian runtime files for Precise Pangolin. (Closes: #644489)
  * Use correct DEB_VERSION_* make variable for update-orig target.
  * Also use CPPFLAGS and LDFLAGS from /u/s/dpkg/buildflags.mk
  * Change libncurses5-dev B-D to libtinfo-dev.
  * Remove patch de.po-lesen.patch, merged upstream.
  * Set DEB_BUILD_MAINT_OPTIONS=hardening=-fortify so we don't override
    upstream's handling.
  * Bump Standards-Version to 3.9.2, no changes needed.