ubuntu/+source/vim:debian/buster

Last commit made on 2019-06-15
Get this branch:
git clone -b debian/buster https://git.launchpad.net/ubuntu/+source/vim
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/buster
Repository:
lp:ubuntu/+source/vim

Recent commits

2699ce5... by James McCoy on 2019-06-15

Import patches-unapplied version 2:8.1.0875-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cf488e34ffdc1e9dceaa87e152f34e495985bdc0

New changelog entries:
  * gbp.conf: Set debian-tag to debian/%(version)s
  * Backport 'modelineexpr' patches to further restrict modelines
    + 8.1.1366: Using expressions in a modeline is unsafe
    + 8.1.1367: can set 'modelineexpr' in modeline
    + 8.1.1368: Modeline test fails with python but without pythonhome
    + 8.1.1382: Error when editing test file
    + 8.1.1401: misspelled mkspellmem as makespellmem (test fix)

cf488e3... by James McCoy on 2019-06-07

Import patches-unapplied version 2:8.1.0875-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0cc99e3fa45da107b64857cea00a3f1071a7154c

New changelog entries:
  * Backport 8.1.1046 and 8.1.1365 to fix CVE-2019-12735 (Closes: #930020)
    + 8.1.1365: source command doesn't check for the sandbox

0cc99e3... by James McCoy on 2019-05-06

Import patches-unapplied version 2:8.1.0875-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cb9eb18a1c1caf2e7077af1f2c5eb587211f5d7e

New changelog entries:
  * syntax/deb{changelog,sources}: Update release names for Debian/Ubuntu
    (Closes: #927167)

cb9eb18... by James McCoy on 2019-02-22

Import patches-unapplied version 2:8.1.0875-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0f6c22fef29fe7f6aaa061e6e7d98876195b72f4

New changelog entries:
  * Backport 8.1.0878 and 8.1.0884 to fix test failures on kFreeBSD.
  * Backport 8.1.0948 to avoid enabling filetype detection when the +eval
    feature isn't present. (Closes: #922106)

0f6c22f... by James McCoy on 2019-02-05

Import patches-unapplied version 2:8.1.0875-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: db397d122f2b55d889f641bf2fae21b63a87f718

New changelog entries:
  * Merge upstream patch v8.1.0875
    + "autocmd", "multi_byte", "virtualedit", and "visualextra" features are
      now always enabled.
    + New Blob type, for working with raw bytes.
    + Support a 3rd character for the "tab" setting in the 'listchars' option.
    + *.com files under /etc/apache2/sites-* are properly recognized as apache
       filetype. (Closes: #740387)
    + syntax/debchangelog.vim: Recognize "emergency" as a valid urgency.
      (Closes: #920522)
    + Support 64-bit offsets for xxd. (Closes: #771456)
  * rules:
    + Remove --enable-multibyte since it is always enabled
  * debian.vim:
    + Remove has('autocmd') checks since it is always enabled
  * gvimrc:
    + Adapt gui check to work for gtk2/gtk3

db397d1... by James McCoy on 2019-01-05

Import patches-unapplied version 2:8.1.0693-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a47677e9bc29d197a10f05d80832949be4f58c73

New changelog entries:
  * Separate /etc/vim and /usr/share/vim/vimfiles. The former should be for
    the sysadmin, while the latter is used by packages.
    + Make /usr/share/vim/vimfiles a directory, not a symlink to /etc/vim
    + Add /etc/vim to the default 'runtimepath'

a47677e... by James McCoy on 2019-01-05

Import patches-unapplied version 2:8.1.0693-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e721d811e6770b9cfc937d17c1a9dc5bf6155902

New changelog entries:
  * Merge upstream tag v8.1.0693
  * control:
    + Remove obsolete vim-gnome package
    + Remove ${shlibs:Depends} from vim-common, since it is Arch: all
    + Build-Depend on libtool-bin to run libterm tests
    + Replace libtinfo-dev Build-Depends with libncurses-dev
    + Change Homepage to https://www.vim.org/
  * Use debian/clean to cleanup files/directories
  * rules:
    + Rename stamp files so dh_clean deletes them automatically
    + Ensure helptags are generated before running tests
  * Declare compliance with Policy 4.3.0, no changes needed

e721d81... by James McCoy on 2018-11-28

Import patches-unapplied version 2:8.1.0549-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bcd48441380c8960033c06458e783c0635c523b6

New changelog entries:
  * Merge upstream tag v8.1.0549
    + Built-in support for performing diffs, via the libxdiff library, which
      allows setting the diff algorithm (:help 'diffopt').
    + Fix formatting of example output in translated xxd man pages. (Closes:
      #909217)
  * gitlab-ci.yml: Run build as non-root user
  * Mark vim-common Multi-Arch: foreign (Closes: #910732)

bcd4844... by James McCoy on 2018-08-22

Import patches-unapplied version 2:8.1.0320-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2e44fea003833fb059996a2f69567960f3a3e468

New changelog entries:
  * Merge upstream tag v8.1.0320
    - syntax/debcontrol.vim:
      + Recognize riscv64 as an architecture (Closes: #905435)
    - syntax/sh.vim:
      + Fix syntax highlighting of curly braces inside parameter expansion
        (Closes: #904875)
  * rules:
    + Stop using --dbgsym-migration
    + Stop overriding default dpkg-deb compression
  * Declare compliance with Policy 4.2.0, no changes needed
  * control: Add cscope to Build-Depends to test cscope integration

2e44fea... by James McCoy on 2018-08-03

Import patches-unapplied version 2:8.1.0229-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 60c2fc3448062640f5aed99459db5400c4102cad

New changelog entries:
  [ upstream ]
  * Unicode 11 support
  * New options ('vartabstop'/'varsofttabstop') to define variable width tab
    stops.
  * Danish translation
  [ James McCoy ]
  * Change "Compiled by" string to <email address hidden>
  * rules:
    + Only run scratch target, not distclean, in autoconf-stamp to avoid FTBFS
      with parallel builds.
    + Allow defining VARIANT from the environment. Thanks to Guillem Jover
      for the suggestion (Closes: #903927)
  * Change vim-python Provides to vim-python3. While Vim only supports py2 or
    py3, Neovim supports both so the change in provides allows
    python(3)-neovim to differentiate the supported Python version.