ubuntu/+source/vim:applied/ubuntu/xenial-security

Last commit made on 2020-10-14
Get this branch:
git clone -b applied/ubuntu/xenial-security https://git.launchpad.net/ubuntu/+source/vim
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/xenial-security
Repository:
lp:ubuntu/+source/vim

Recent commits

ba5d4c3... by Marc Deslauriers on 2020-10-13

2:7.4.1689-3ubuntu1.5 (patches applied)

Imported using git-ubuntu import.

a13d72d... by Marc Deslauriers on 2020-10-13

[PATCH] patch 8.1.0883: missing some changes for Ex commands

Gbp-Pq: CVE-2019-20807-2.patch.

743437c... by Marc Deslauriers on 2020-10-13

[PATCH] patch 8.1.0881: can execute shell commands in rvim through

Gbp-Pq: CVE-2019-20807-1.patch.

59f173c... by Marc Deslauriers on 2020-10-13

[PATCH] Update runtime files.

Gbp-Pq: CVE-2019-20807-pre2.patch.

3507368... by Marc Deslauriers on 2020-10-13

[PATCH] patch 7.4.1777 Problem: Newly added features can escape

Gbp-Pq: CVE-2019-20807-pre1.patch.

05fe0d5... by Marc Deslauriers on 2020-10-13

[PATCH] patch 8.0.1263: others can read the swap file if a user is

Gbp-Pq: CVE-2017-17087.patch.

ea5f95b... by Marc Deslauriers on 2020-10-13

patch 8.0.0378: possible overflow when reading corrupted undo file

Gbp-Pq: patch-8.0.0378-possible-overflow-when-reading-corrupted-u.patch.

d7413f8... by Marc Deslauriers on 2020-10-13

patch 8.0.0377: possible overflow when reading corrupted undo file

Gbp-Pq: patch-8.0.0377-possible-overflow-when-reading-corrupted-u.patch.

721dca8... by Marc Deslauriers on 2020-10-13

patch 8.0.0707: freeing wrong memory with certain autocommands

Gbp-Pq: patch-8.0.0707-freeing-wrong-memory-with-certain-autocomm.patch.

8958404... by Marc Deslauriers on 2020-10-13

patch 8.0.0703: illegal memory access with empty :doau command

Gbp-Pq: patch-8.0.0703-illegal-memory-access-with-empty-doau-comm.patch.