ubuntu/+source/vim:applied/debian/stretch

Last commit made on 2019-09-07
Get this branch:
git clone -b applied/debian/stretch https://git.launchpad.net/ubuntu/+source/vim
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/stretch
Repository:
lp:ubuntu/+source/vim

Recent commits

3b802a2... by James McCoy on 2019-06-21

Import patches-applied version 2:8.0.0197-4+deb9u3 to applied/debian/stretch

Imported using git-ubuntu import.

Changelog parent: 5aa237f2b28b7fd7359faa4cd8cf89710e1f3737
Unapplied parent: c6a54b4ea96edc80cd6a028ef8d9a19f977b3b1f

New changelog entries:
  * Backport patch 8.1.0067 to fix loss of syntax highlighting (Closes: #930718)
    + 8.1.0067: syntax highlighting not working when re-entering a buffer
  * Backport patches to address CVE-2019-12735 (Closes: #930020)
    + 8.0.0649: when opening a help file the filetype is set several times
    + 8.0.0651: build failure without the auto command feature
    + 8.1.0066: nasty autocommand causes using freed memory
    + 8.1.0177: defining function in sandbox is inconsistent
    + 8.1.0189: function defined in sandbox not tested
    + 8.1.0205: invalid memory access with invalid modeline
    + 8.1.0206: duplicate test function name
    + 8.1.0208: file left behind after running individual test
    + 8.1.0506: modelinen test fails when run by root
    + 8.1.0538: evaluating a modeline might invoke using a shell command
    + 8.1.0539: cannot build without the sandbox
    + 8.1.0540: may evaluate insecure value when appending to option
    + 8.1.0544: setting 'filetype' in a modeline causes an error
    + 8.1.0546: modeline test with keymap fails
    + 8.1.0547: modeline test with keymap still fails
    + 8.1.0613: when executing an insecure function the secure flag is stuck
    + 8.1.1046: the "secure" variable is used inconsistently
    + 8.1.1365: source command doesn't check for the sandbox
    + 8.1.1366: using expressions in a modeline is unsafe
    + 8.1.1367: can set 'modelineexpr' in modeline
    + 8.1.1368: modeline test fails with python but without pythonhome
    + 8.1.1382: error when editing test files
    + 8.1.1401: misspelled mkspellmem and makespellmem
  * gbp.conf: Set debian-branch to debian/stretch
  * gbp.conf: Set upstream-tag to v%(version)s

c6a54b4... by James McCoy on 2019-06-21

patch 8.1.1401: misspelled mkspellmem as makespellmem

Gbp-Pq: upstream/patch-8.1.1401-misspelled-mkspellmem-as-makespellmem.patch.

e69c23a... by James McCoy on 2019-06-21

patch 8.1.1382: error when editing test file

Gbp-Pq: upstream/patch-8.1.1382-error-when-editing-test-file.patch.

4910b13... by James McCoy on 2019-06-21

patch 8.1.1368: modeline test fails with python but without

Gbp-Pq: upstream/patch-8.1.1368-modeline-test-fails-with-python-but-withou.patch.

d0de110... by James McCoy on 2019-06-21

patch 8.1.1367: can set 'modelineexpr' in modeline

Gbp-Pq: upstream/patch-8.1.1367-can-set-modelineexpr-in-modeline.patch.

a63e46b... by James McCoy on 2019-06-21

patch 8.1.1366: using expressions in a modeline is unsafe

Gbp-Pq: upstream/patch-8.1.1366-using-expressions-in-a-modeline-is-unsafe.patch.

aa62a77... by James McCoy on 2019-06-21

patch 8.1.1365: source command doesn't check for the sandbox

Gbp-Pq: upstream/patch-8.1.1365-source-command-doesn-t-check-for-the-sandb.patch.

ddd6f27... by James McCoy on 2019-06-21

patch 8.1.1046: the "secure" variable is used inconsistently

Gbp-Pq: upstream/patch-8.1.1046-the-secure-variable-is-used-inconsistently.patch.

045adc4... by James McCoy on 2019-06-21

patch 8.1.0613: when executing an insecure function the secure flag

Gbp-Pq: upstream/patch-8.1.0613-when-executing-an-insecure-function-the-se.patch.

ce82114... by James McCoy on 2019-06-21

patch 8.1.0547: modeline test with keymap still fails

Gbp-Pq: upstream/patch-8.1.0547-modeline-test-with-keymap-still-fails.patch.