ubuntu/+source/vim:applied/debian/buster

Last commit made on 2019-06-15
Get this branch:
git clone -b applied/debian/buster https://git.launchpad.net/ubuntu/+source/vim
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/buster
Repository:
lp:ubuntu/+source/vim

Recent commits

7004725... by James McCoy on 2019-06-15

Import patches-applied version 2:8.1.0875-5 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: a65553b7f9cb38ce2a931378046ff9325388df24
Unapplied parent: 7845e1f03e545241d06d8f2760246cd935ce84c2

New changelog entries:
  * gbp.conf: Set debian-tag to debian/%(version)s
  * Backport 'modelineexpr' patches to further restrict modelines
    + 8.1.1366: Using expressions in a modeline is unsafe
    + 8.1.1367: can set 'modelineexpr' in modeline
    + 8.1.1368: Modeline test fails with python but without pythonhome
    + 8.1.1382: Error when editing test file
    + 8.1.1401: misspelled mkspellmem as makespellmem (test fix)

7845e1f... by James McCoy on 2019-06-15

patch 8.1.1401: misspelled mkspellmem as makespellmem

Gbp-Pq: patch-8.1.1401-misspelled-mkspellmem-as-makespellmem.patch.

f6bcad8... by James McCoy on 2019-06-15

patch 8.1.1382: error when editing test file

Gbp-Pq: patch-8.1.1382-error-when-editing-test-file.patch.

a524c24... by James McCoy on 2019-06-15

patch 8.1.1368: modeline test fails with python but without

Gbp-Pq: patch-8.1.1368-modeline-test-fails-with-python-but-withou.patch.

0fedc81... by James McCoy on 2019-06-15

patch 8.1.1367: can set 'modelineexpr' in modeline

Gbp-Pq: patch-8.1.1367-can-set-modelineexpr-in-modeline.patch.

bfef366... by James McCoy on 2019-06-15

patch 8.1.1366: using expressions in a modeline is unsafe

Gbp-Pq: patch-8.1.1366-using-expressions-in-a-modeline-is-unsafe.patch.

f5f534a... by James McCoy on 2019-06-15

patch 8.1.1365: source command doesn't check for the sandbox

Gbp-Pq: patch-8.1.1365-source-command-doesn-t-check-for-the-sandb.patch.

bc75858... by James McCoy on 2019-06-15

patch 8.1.1046: the "secure" variable is used inconsistently

Gbp-Pq: patch-8.1.1046-the-secure-variable-is-used-inconsistently.patch.

59af11f... by James McCoy on 2019-06-15

Add Ubuntu's eoan and Debian's buster, bullseye, bookworm releases

Gbp-Pq: upstream/deb-release-names.patch.

227f855... by James McCoy on 2019-06-15

patch 8.1.0948: when built without +eval "Vim --clean" produces

Gbp-Pq: patch-8.1.0948-when-built-without-eval-Vim-clean-produces.patch.