ubuntu/+source/util-linux:ubuntu/xenial

Last commit made on 2016-04-13
Get this branch:
git clone -b ubuntu/xenial https://git.launchpad.net/ubuntu/+source/util-linux
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/xenial
Repository:
lp:ubuntu/+source/util-linux

Recent commits

fefe08e... by Simon D├ęziel on 2016-04-13

Import patches-unapplied version 2.27.1-6ubuntu3 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 29ebdab3248c91a7f90e09019fd43d4e1c8849f3

New changelog entries:
  * Add debian/patches/script-use-empty-slave.patch taken from
    upstream git (LP: #1553353, Closes: #820843)

29ebdab... by Martin Pitt on 2016-03-30

Import patches-unapplied version 2.27.1-6ubuntu2 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: ab2350f8ba062039a43fc0d25ec493e33495285a

New changelog entries:
  * Add upstream-lscpu-powerpc.patch: lscpu: Fix model and model name on Power
    Systems. (Backported from upstream trunk). (LP: #1563514)

ab2350f... by Martin Pitt on 2016-03-14

Import patches-unapplied version 2.27.1-6ubuntu1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 7a596bd65b9241e7e37ca4801b9670bc8689aacb

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Regularly trim SSDs automatically (core-1311-ssd-trimming):
      + Add debian/fstrim-all.cron: Call fstrim --all. Installed as
        /etc/cron.weekly/fstrim.
    - Upstart support:
      + Add hwclock{-save}.upstart, and install them in debian/rules.
      + Drop debian/hwclock.rules and hwclock.default.
    - Add sulogin-fallback-static-sh.patch: Add support for /bin/static-sh as
      fallback if the regular shell fails to execute. Patch ported from
      sysvinit. (see LP #505887)
    - Add sulogin-lockedpwd.patch: Make sure file systems can be fixed on
      machines with locked root accounts (as Ubuntu does by default). Don't
      require --force for sulogin.
    - Make util-linux Breaks old {p,}mac-fdisk for the fdisk binary takeover.
    - Drop debian/util-linux.preinst: Unconditionally deleting files
      is wrong, and dpkg will overwrite symlinks with real files anyway.
    - Drop debian/util-linux.preinst: Unconditionally deleting files
      is wrong, and dpkg will overwrite symlinks with real files anyway.
    - Adjust the Breaks: cloud-utils to 0.27-0ubuntu16 (the Ubuntu version
      that works with util-linux 2.26), and also move it to cloud-guest-utils.
    - Add debian/libblkid1.maintscript to clean up /etc/blkid.conf on upgrade.
      This needs to be kept until after Ubuntu 16.04 LTS.
  * Debian changes fix upgrade failure. (LP: #1556539)

7a596bd... by Andreas Henriksson on 2016-03-12

Import patches-unapplied version 2.27.1-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 00a969f1605b6ebab7308fadaff619d49ae4baba

New changelog entries:
  * Drop (versioned) init-system-helpers dependency to avoid dep loop.
    - initscripts is guaranteed to be installed in stable/jessie, the file
      is additionally a conffile so initscripts will need to be purged to
      cause a problem for us with i-s-h << 1.29 and purging initscripts is
      not possible until after the upgrade anyway. (Closes: #817857)
  * Temporarily move sysvinit-utils back from Breaks to Depends.
    - again seems to confuse apt and we apparently need a synchronized
      upload with sysvinit to move things to how it should (and now can be
      since initscripts dependency was dropped from u-l) be described.

00a969f... by Andreas Henriksson on 2016-03-10

Import patches-unapplied version 2.27.1-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a2cceda7fcd029833da92cd3d151621c193fa62a

New changelog entries:
  * Completely drop (versioned) tzdata dependency (Closes: #817371)
    - the alternative on systemd-sysv causes (pre-)dependency loops which
      dpkg can't handle (see example in #817780)
    - the reason for the dependency in the first place seems to have been
      ensuring /etc/localtime is a real file. Later the use of
      /etc/localtime seems to have been removed (see #660365).
      Thanks to Felipe Sateler for digging this information up.
    - tzdata itself is Priority: required so should always be around in a
      regular install even without any dependency on it. (i.e. unless it has
      explicitly been removed.)

a2cceda... by Andreas Henriksson on 2016-03-03

Import patches-unapplied version 2.27.1-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 537b4f5dc0b77710118376f2d36203eab6601866

New changelog entries:
  * Drop initscripts dependency now that update-rc.d no longer
    requires it to process init scripts with LSB header dependencies.
    - note that it's still likely to be installed (even under systemd)
      since it's priority is required, it's just that util-linux no longer
      needs to require it to be around.
  * Add dependency on init-system-helpers (>= 1.29~) which contains
    the previously mentioned update-rc.d fix.
    - this can be dropped once init-system-helpers is always >= 1.29~.
  * Drop lsb-base dependency
    - strictly speaking we should have it since hwclock.sh uses
      lsb-base, but initscripts will pull it in for us anyway under
      sysvinit(-core) so this dependency makes no practical gain.
      Dropping it avoids pulling it in when we don't need it (eg. under
      systemd-sysv where hwclock.sh is masked by the systemd package).
  * Add systemd-sysv as an alternative to tzdata dependency.
    - tzdata was according to this changelog added for the benefit of
      the hwclock.sh init script. (Not sure it's required.)
      It's among the top size of debootstrap --variant=minbase packages
      so might be useful to make it uninstallable on minimal containers,
      which this change should accomplish (under systemd-sysv atleast).
  * Finally move sysvinit-utils back to Breaks instead of Depends
    - now that initscript dependency is dropped, the issue with cyclic
      dependency should be no more and we can properly describe the
      relation.
  * Add debian/patches/build-sys-use-PKG_CONFIG.patch
    - cherry-picked from upstream git, fixes crossbuilding (Closes: #811546)

537b4f5... by Andreas Henriksson on 2016-01-26

Import patches-unapplied version 2.27.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 09430cb843fb0106aa3297f2faa4a8256a62f9f8

New changelog entries:
  * Add debian/patches/Mark-setarch-testcase-as-known-fail.patch
    (Closes: #812696)

09430cb... by Andreas Henriksson on 2016-01-24

Import patches-unapplied version 2.27.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8b32c27ef280dfba3725ffa3c16c1c48d605d771

New changelog entries:
  [ Andreas Henriksson ]
  * Handle missing directory in obsolete conversion code (Closes: #804167)
  * hwclock.sh: drop obsolete WARNING referencing non-existing doc
    (Closes: #795194)
  * hwclock.sh: use sed instead of head/tail (Closes: #791511)
  * hwclock.sh: Add Short-Description (Closes: #510086)
  * Drop obsolete lsb-release build-dependency (Closes: #805491)
  * bsdutils: drop ancient README.script (Closes: #231347)
  [ Justin B Rye ]
  * package description tweaks (Closes: #806736)

8b32c27... by Andreas Henriksson on 2015-11-02

Import patches-unapplied version 2.27.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5a5b3c892bc049869a6b472bd3f7b3ebb483b1a9

New changelog entries:
  * Imported Upstream version 2.27.1
    - among other things includes these fixes:
      libmount: fix uid= and gid= translation (Closes: #801527)
      libmount: (monitor) don't check for regular mtab

5a5b3c8... by Andreas Henriksson on 2015-09-17

Import patches-unapplied version 2.27-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: be7f05907a0060055ea6ac379efa41044063deeb

New changelog entries:
  * Add lintian-overrides for linking fdisk-udeb static
  * Force installation of fdisk-udeb lintian overrides
  * Drop Scott from co-maintainers on his request
  * Build static binaries for fdisk-udeb and util-linux-udeb
    - this avoids udeb collecting invalid dependencies on non-udebs
    (Closes: #798347)