ubuntu/+source/upstart:applied/ubuntu/hardy-devel

Last commit made on 2009-04-21
Get this branch:
git clone -b applied/ubuntu/hardy-devel https://git.launchpad.net/ubuntu/+source/upstart
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/hardy-devel
Repository:
lp:ubuntu/+source/upstart

Recent commits

d529ce7... by Michael Biebl on 2009-04-09

Import patches-applied version 0.3.9-2 to applied/debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 8a17ddb19ddd34f48d6bcad52e53533e16b688f0
Unapplied parent: bab1d065cf93efe29162f5e298ff68fe2a9aff4c

New changelog entries:
  * debian/control
    - Bump Standards-Version to 3.8.1. No further changes.
    - Update Vcs-* fields. Package is now managed with Git on git.debian.org.
    - Bump Build-Depends on debhelper to (>= 7).
  * debian/compat
    - Bump debhelper compat level to 7.
  * debian/rules
    - Use dh_prep instead of dh_clean -k.
    - Depend on $(QUILT_STAMPFN) instead of patch; patch is a phony target and
      thus always out of date.
    - Move $(QUILT_STAMPFN) dependency to config.status to avoid potential
      issues with parallel make.
  * debian/upstart-compat-sysv.preinst
    - Remove obsolete conffiles also on (re)install.
  * debian/patches/01-limits.patch
    - Include limits.h to fix build failures with current glibc.
      Patch taken from Ubuntu.
  * debian/patches/02-telinit-u.patch
    - Implement "telinit u" by sending Upstart SIGTERM.
      Patch taken from Ubuntu.
  * debian/patches/03-static-convenience-libs.patch
    - Build libnih and libupstart as static convenience libraries.
      Patch taken from Ubuntu.
  * Use set -e instead of #!/bin/sh -e for all maintainer scripts.

bab1d06... by Michael Biebl on 2009-04-09

Import patches-unapplied version 0.3.9-2 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: ce21adf8236267db369593b8840015b7d924988b

New changelog entries:
  * debian/control
    - Bump Standards-Version to 3.8.1. No further changes.
    - Update Vcs-* fields. Package is now managed with Git on git.debian.org.
    - Bump Build-Depends on debhelper to (>= 7).
  * debian/compat
    - Bump debhelper compat level to 7.
  * debian/rules
    - Use dh_prep instead of dh_clean -k.
    - Depend on $(QUILT_STAMPFN) instead of patch; patch is a phony target and
      thus always out of date.
    - Move $(QUILT_STAMPFN) dependency to config.status to avoid potential
      issues with parallel make.
  * debian/upstart-compat-sysv.preinst
    - Remove obsolete conffiles also on (re)install.
  * debian/patches/01-limits.patch
    - Include limits.h to fix build failures with current glibc.
      Patch taken from Ubuntu.
  * debian/patches/02-telinit-u.patch
    - Implement "telinit u" by sending Upstart SIGTERM.
      Patch taken from Ubuntu.
  * debian/patches/03-static-convenience-libs.patch
    - Build libnih and libupstart as static convenience libraries.
      Patch taken from Ubuntu.
  * Use set -e instead of #!/bin/sh -e for all maintainer scripts.

8a17ddb... by Michael Biebl on 2007-10-22

Import patches-applied version 0.3.9-1 to applied/debian/experimental

Imported using git-ubuntu import.

Unapplied parent: ce21adf8236267db369593b8840015b7d924988b

ce21adf... by Michael Biebl on 2007-10-22

Import patches-unapplied version 0.3.9-1 to debian/experimental

Imported using git-ubuntu import.