ubuntu/+source/ufw:applied/ubuntu/utopic-proposed

Last commit made on 2014-08-11
Get this branch:
git clone -b applied/ubuntu/utopic-proposed https://git.launchpad.net/ubuntu/+source/ufw
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/utopic-proposed
Repository:
lp:ubuntu/+source/ufw

Recent commits

3f17f27... by Martin Pitt on 2014-07-30

Import patches-applied version 0.34~rc-0ubuntu4 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: b91b039b7755aa2421865c7b39648a71971deb4a
Unapplied parent: d40d3da1f674108cd9dab6677421948e678fed5e

New changelog entries:
  * Install the SysV init and upstart script for both Debian and Ubuntu.
    Debian has upstart too, and in Ubuntu we need the init script for LSB
    dependencies and for systemd. (LP: #1341083)
    - Rename debian/ufw.init.debian to debian/ufw.init
    - Rename debian/ufw.upstart.ubuntu to debian/ufw.upstart
    - Remove all the distro specific code from debian/rules and just call
      dh_installinit.
  * Drop the distro specific logrotate configs, and use the ubuntu one with
    "rotate" instead of "reload" everywhere, as Debian's rsyslog init also
    supports "rotate".
  * Add a systemd unit:
    - Add debian/ufw.service
    - Add dh-systemd build dep.
    - debian/rulles: Call dh_systemd_{enable,start}.

d40d3da... by Martin Pitt on 2014-07-30

tests/check-requirements: update for newer python3

Gbp-Pq: 0006-check-for-newer-py3.patch.

0eaf886... by Martin Pitt on 2014-07-30

doc/ufw-framework.8: add note about libvirt

Gbp-Pq: 0005-lp573461.patch.

7865318... by Martin Pitt on 2014-07-30

update before*.rules to add safe icmp to ufw-before-forward,

Gbp-Pq: 0004-add-safe-icmp-to-forward.patch.

ed00e2c... by Martin Pitt on 2014-07-30

doc/ufw-framework.8: update locations of hook scripts

Gbp-Pq: 0003-manpage-hook-path.patch.

3642265... by Martin Pitt on 2014-07-30

distinguish between v4 and v6 rules when both addresses are 'any'

Gbp-Pq: 0002-lp1078665.patch.

f89043f... by Martin Pitt on 2014-07-30

to improve boot speed when disabled, don't source all of

Gbp-Pq: 0001-optimize-boot.patch.

dfbf165... by Martin Pitt on 2014-07-30

Import patches-unapplied version 0.34~rc-0ubuntu4 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: dfd72b14bcae6997c2ad8ceccd800456dd9c3692

New changelog entries:
  * Install the SysV init and upstart script for both Debian and Ubuntu.
    Debian has upstart too, and in Ubuntu we need the init script for LSB
    dependencies and for systemd. (LP: #1341083)
    - Rename debian/ufw.init.debian to debian/ufw.init
    - Rename debian/ufw.upstart.ubuntu to debian/ufw.upstart
    - Remove all the distro specific code from debian/rules and just call
      dh_installinit.
  * Drop the distro specific logrotate configs, and use the ubuntu one with
    "rotate" instead of "reload" everywhere, as Debian's rsyslog init also
    supports "rotate".
  * Add a systemd unit:
    - Add debian/ufw.service
    - Add dh-systemd build dep.
    - debian/rulles: Call dh_systemd_{enable,start}.

b91b039... by Jamie Strandboge on 2014-05-16

Import patches-applied version 0.34~rc-0ubuntu3 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: b824e6752b840b3d5efb8a67912e4d247cb93636
Unapplied parent: 8ad5d03683c5d5816be82e31f21a976d25bf123e

New changelog entries:
  * debian/patches/0005-lp573461.patch: adjust man page for libvirt
    (LP: #573461)
  * debian/patches/0006-check-for-newer-py3.patch: tests/check-requirements
    updated for newer python3

dfd72b1... by Jamie Strandboge on 2014-05-16

Import patches-unapplied version 0.34~rc-0ubuntu3 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: bfe87b1c1883d4e2d801f7f09bffbcf3f31580b2

New changelog entries:
  * debian/patches/0005-lp573461.patch: adjust man page for libvirt
    (LP: #573461)
  * debian/patches/0006-check-for-newer-py3.patch: tests/check-requirements
    updated for newer python3