ubuntu/+source/ubuntu-drivers-common:ubuntu/quantal

Last commit made on 2012-10-05
Get this branch:
git clone -b ubuntu/quantal https://git.launchpad.net/ubuntu/+source/ubuntu-drivers-common
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/quantal
Repository:
lp:ubuntu/+source/ubuntu-drivers-common

Recent commits

de3423d... by Martin Pitt on 2012-10-05

Import patches-unapplied version 1:0.2.71 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 9b057a18a27e7e8ee67ebdd5e8b2f9dce34ccd72

New changelog entries:
  * tests/ubuntu_drivers.py: When calling PackageKit, retry up to 5 seconds on
    o.f.d.Error.ServiceUnknown, so that this also works reliably on our slow
    ARM builders. (LP: #1061748)

9b057a1... by Martin Pitt on 2012-10-04

Import patches-unapplied version 1:0.2.70 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 0b37390a0b593aa219c8b8de6781315f2a76ae87

New changelog entries:
  * UbuntuDrivers/detect.py: Never recommend a driver which has "experiment"
    in the name, unless no other driver is available.

0b37390... by Martin Pitt on 2012-09-06

Import patches-unapplied version 1:0.2.69 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 8e650b3988e3b88e7b7b0aa8764191dd7f7cab64

New changelog entries:
  * Drop share/last_gfx_boot, and stop installing it in setup.py. This file is
    created and updated at runtime and should not be shipped in the package.
    (LP: #1045629)
  * setup.py: Only install the upstart job on platforms where we build
    hybrid-detect. (LP: #1045193)
  * debian/rules: On architectures which do not ship hybrid-detect, generate a
    .maintscript helper to clean up the /etc/init/hybrid-gfx.conf upstart job
    conffile on upgrade.
  * tests/ubuntu_drivers.py: Add test for a video driver which supports
    multiple X.org video ABIs. Reproduces LP #1033222.
  * UbuntuDrivers/detect.py, _check_video_abi_compat(): Do not only consider
    the first xorg-video-abi-* dependency, but all of them. (LP: #1033222)

8e650b3... by Jason Conti on 2012-07-20

Import patches-unapplied version 1:0.2.68 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: ad2338c35bb7dfd81304415ea37a4c98b539971c

New changelog entries:
  * setup.py: Fix hybrid_detect installation. (LP: #1026787)

ad2338c... by Martin Pitt on 2012-07-18

Import patches-unapplied version 1:0.2.67 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: c43b901cb6a63e6a942a570caa252fff94d1c368

New changelog entries:
  * setup.py: Install hybrid-detect through data_files instead of scripts, as
    the later stopped working with python 3.2.3-3 (see LP #1026016)

c43b901... by Martin Pitt on 2012-07-18

Import patches-unapplied version 1:0.2.66 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: e3584f6ee37b3f6c0316bd75f79f16143500986c

New changelog entries:
  * UbuntuDrivers/detect.py, system_device_drivers(): Add driver flag
    "manual_installed" if none of the driver packages are installed, but the
    corresponding kernel module is available. This usually means that the user
    installed the driver manually from upstream. (LP: #1025632)
  * share/fake-devices-wrapper: If $FAKE_INSTALLED_KMOD is set, run the
    wrapped program with a "modinfo" wrapper in $PATH which claims that the
    given kernel module name is available. This can be used to test the
    "manually installed driver" case.

e3584f6... by Martin Pitt on 2012-07-17

Import patches-unapplied version 1:0.2.65 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 355455644478e74e9826c628458be858514b6ca6

New changelog entries:
  * UbuntuDrivers/detect.py, system_driver_packages(): Add 'recommended' flag
    to the nvidia-* and fglrx-* packages, which usually provide more than one
    package for a particular device. (LP: #1025315)
  * UbuntuDrivers/detect.py, auto_install_filter(): Filter out non-recommended
    packages, to avoid installing multiple versions of the NVidia or FGLRX
    driver.
  * UbuntuDrivers/detect.py: Change return value of detect_plugin_packages()
    to a plugin_name → [package, ...] map, so that we retain the plugin names.
  * UbuntuDrivers/detect.py: Add system_device_drivers() API to get a
    by-device view of drivers, plus OS builtin free alternatives (such as
    Nouveau). Add it to README as well. (LP: #1025323)
  * ubuntu-drivers: Add "device" command to show by-device drivers as reported
    by system_device_drivers().

3554556... by Martin Pitt on 2012-07-13

Import patches-unapplied version 1:0.2.64 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 408f4b36a620b6364eeb73ef52ed1b07e745c1ff

New changelog entries:
  * debian/control: Add pciutils and usbutilsl build/binary dependencies, so
    that pci-db and usb-db actually have some data files to work with.

408f4b3... by Martin Pitt on 2012-07-13

Import patches-unapplied version 1:0.2.63 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: daa9853edf6f8c5f9a48e3211da8c90d86146837

New changelog entries:
  * debian/control: Add udev build/binary dependency, to ensure we have pci-db
    and usb-db.

daa9853... by Martin Pitt on 2012-07-13

Import patches-unapplied version 1:0.2.62 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 86a8ed5fef513dd58d5bcf03d2b7e437675e3d50

New changelog entries:
  * debian/control: As the PackageKit apt backend is going away, drop the
    Conflicts to packagekit-backend-aptcc. Instead, recommend
    python3-aptdaemon.pkcompat and update the description to point out that
    the PackageKit API does not work with the aptcc backend.
    (LP: #1023953)
  * UbuntuDrivers.detect.py, system_driver_packages(): Add 'vendor' and
    'model' fields for the human readable names from pci/usb databases.