ubuntu/+source/ubuntu-advantage-tools:ubuntu/trusty-devel

Last commit made on 2019-11-26
Get this branch:
git clone -b ubuntu/trusty-devel https://git.launchpad.net/ubuntu/+source/ubuntu-advantage-tools
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/trusty-devel
Repository:
lp:ubuntu/+source/ubuntu-advantage-tools

Recent commits

91f22c2... by Andreas Hasenack on 2019-11-14

Import patches-unapplied version 19.6~ubuntu14.04.4 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Upload parent: 4ccd22fd8d17e833c40900b6ffbb5ed6f25dc8e5

4ccd22f... by Andreas Hasenack on 2019-11-14

changelog

221aefd... by Andreas Hasenack on 2019-11-08

d/postinst: only configure ESM on supported architectures (LP: #1851858)

999e489... by Andreas Hasenack on 2019-10-30

Import patches-unapplied version 19.6~ubuntu14.04.3 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Upload parent: bb61b65807abb3860640602ffa4c51772bcaac18

bb61b65... by Andreas Hasenack on 2019-10-30

changelog

e3dc4c6... by Chad Smith on 2019-10-29

pkg: rename existing ubuntu-esm-precise.list file to trusty

When upgrading from precise to trusty and esm is enabled,
ubuntu-advantage-tools v 10ubuntu0.14.04.4 does not rename
any apt precise apt sources files to trusty.

So if customers have already upgraded from precise enabled-esm to trusty
10ubuntu0.14.04.4, a subsequent upgrade to version 19.6 will
skip trying to rename:
ubuntu-esm-precise.list -> ubuntu-esm-infra-trusty.list.

postinst unconditionally renames ubuntu-esm-precise.list to
ubuntu-esm-infra-trusty.list. It no longer limits this rename
operation to the case where postinst is upgrading from version 1 (the precise
package version)

Fixes: #899

19f5978... by Andreas Hasenack on 2019-10-25

Import patches-unapplied version 19.6~ubuntu14.04.2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Upload parent: ddaaefef82be6cc887b3017235ae0f49a776fbbf

ddaaefe... by Andreas Hasenack on 2019-10-25

changelog

9425d72... by Andreas Hasenack on 2019-10-25

  * d/control, d/rules: don't run flake8 tests since python3-flake8 is in
    universe (LP: #1849851)

37d4053... by Andreas Hasenack on 2019-10-23

Import patches-unapplied version 19.6~ubuntu14.04.1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: b1f4c5a6e6f44d1f3d819befc439ea42c908830c

New changelog entries:
  * New upstream release (LP: #1832757). Main changes:
    - drop SSO interactive login support
    - d/control: no longer depend on pymacaroons, which was only needed for
      the SSO interactive login support
    - drop keyrings for services not supported in trusty: cc-eal, fips,
      fips-updates, cis audit
    - make sure /var/lib/ubuntu-advantage/private has 0700 perms
    - rename esm to esm-infra. Also handle upgrades
    - don't unecessarily remove config files that are already handled by dpkg
    - expand the apt related runtime dependencies
    - handle sources.list.d esm snippet when release upgrading from precise
    - ua status now reports availability of services even in unattached state
    - the "ua status" output was changed, including the json format option
    - drop "ua status" call in postinst as it now requires internet access and
      that is restricted in LP builders and test runners.
    - fix the d/t/usage DEP8 test that was also using status