ubuntu/+source/ubufox:ubuntu/lucid-devel

Last commit made on 2012-11-21
Get this branch:
git clone -b ubuntu/lucid-devel https://git.launchpad.net/ubuntu/+source/ubufox
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/lucid-devel
Repository:
lp:ubuntu/+source/ubufox

Recent commits

4fb54af... by Chris Coulson on 2012-10-12

Import patches-unapplied version 2.6-0ubuntu0.10.04.1 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: b1171a740f73ebf78f856d13539081b678b81511

New changelog entries:
  * New upstream release
    - see LP: #1080211 for USN information
    - Make the startpage work again in Firefox 17
    - Fix a crash that occurs when the apt cache is broken
    - Fix a whole bunch of memory leaks in the plugin installer
    - Don't poll for file changes, but use inotify instead to determine
      when we need to display a restart notification

b1171a7... by Chris Coulson on 2012-06-27

Import patches-unapplied version 2.1.1-0ubuntu0.10.04.1 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 1eb75a9058af44b57e7137d3da666bc4e28dd012

New changelog entries:
  * New upstream release v2.1.1
    - Drop the alternative plugin selector, as it depends on a patch that
      we no longer carry in Firefox

1eb75a9... by Chris Coulson on 2012-04-23

Import patches-unapplied version 0.9.5-0ubuntu0.10.04.1 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: f06d7905931a5b2488b0904d44fce6a0da9940f5

New changelog entries:
  * New upstream release
    - Update compatibility for Firefox 13 (LP: #987262)
    - Update startpage URL (LP: #985862)

f06d790... by Chris Coulson on 2012-03-02

Import patches-unapplied version 0.9.4-0ubuntu0.10.04.1 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: bde9f83f4ffc913fb0eb815c4b139c846eb3e995

New changelog entries:
  * New upstream release.
    - Drop Ask.com searchplugin
    - LP: #951250
  * Refresh debian/patches/addon_installer.patch
  * Move back out of the application directory now that LP: #915895 is fixed.
    The original solution didn't really make much sense
    - update debian/rules

bde9f83... by Chris Coulson on 2012-01-18

Import patches-unapplied version 0.9.3-0ubuntu0.10.04.3 to ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 92b81d109d244708c31f0a515a3e61d0cc777eb4

New changelog entries:
  * Fix LP: #918052 - Error migrating extensions to be in-profile
    - Migrate the addon to a profile addon even if there is a system-wide
      addon with the same version. It seems this got broken during some recent
      refactoring.
    - For newly installed addons, display the new addon tab, otherwise the
      addon stays disabled

92b81d1... by Chris Coulson on 2011-12-21

Import patches-unapplied version 0.9.3-0ubuntu0.10.04.1 to ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 1ee72576692e3d5ccfdda41a932fbadb19243ee1

New changelog entries:
  * New upstream release v0.9.3
    - Support Firefox 9 and 10 (LP: #904594)
  * New upstream release v0.9.2
    - Bump maxVersion to 8.*
  * New upstream release v0.9.1
    - Rename AboutHome to AboutStartpage, and have it handle about:startpage now
      (to not conflict with the new about:home handler in Firefox)
    - Set default home page to about:startpage
    - Add support for the XPCOM changes in Gecko 2.0
    - In the restart notifier, don't hardcode a list of filenames for different
      browser versions, but just use MOZ_APP_LAUNCHER instead. This will
      indirectly fix LP: #511250 and should prevent it from happening again
    - Merge the plugin finder code from Firefox 4. This now uses AddonManager,
      so the MinVersion needs to be bumped
    - Drop the FF2.0 specific code
    - Drop the AddonsOverlay and associated code, this hasn't worked for
      several releases since we started using software-center, and nobody
      really noticed so far. We can reimplement this at a later date if wanted,
      but it throws JS exceptions when loading in FF4.0 now
    - Specify for the extension to be unpacked by the installer. Without this,
      the prefs aren't used
    - Get the distributionID field for the pfs URL from the preferences, rather
      than hard-coding a value
    - Fix LP: #579091 - ubufox interferes with toolbar buttons for other add-ons
      Don't initialize or assign any value to gBrowser in alternatePlugins.js.
      It runs in the context of browser.xul, so gBrowser will always exist
      once the browser window has loaded
    - Fix LP: #333799 - set a default dictionary language
    - Don't duplicate preferences that we're already setting in Firefox
    - Update Japanese(ja) translations (LP: #746538)
    - Fix LP: #750305 - Don't hard-code links and configs for each release.
      Rather than doing this manually for every release, we add a dist.js with
      distro information (populated at build time with lsb_release) and just
      do all this automatically.
    - Fix LP: #752364 - Plugin Finder Service never finds anything. Use the
      release info in dist.js to construct the URL, now that this got dropped
      from Firefox
    - Fix LP: #728826 - Update icons to new versions.
    - Drop the pluginGlue.js module. This didn't work, as we can no longer
      use a modules registerSelf method to use nsICategoryManager at startup,
      due to the XPCOM registration changes in Firefox 4. Instead, add
      category entries with the chrome.manifest
    - Fix LP: #709125 - User agent doesn't include Ubuntu in it so
      apt.ubuntu.com doesn't work. We add an extra X-Ubuntu HTTP header in
      requests to apt.ubuntu.com, rather than send this information out in
      every request in the UA string
  * Revert an upstream commit to look in the new location for the restart
    required trigger
    - add debian/patches/use_old_restart_notifier_file.patch
    - add debian/patches/series
  * Drop debian/patches/02_fix_about_home.patch - not relevant now
  * Backport a change from trunk to support installing system-wide extensions
    in to the users profile, where they will get updates directly from upstream
    - add debian/patches/addon_installer.patch
    - update debian/patches/series
  * Fix LP: #809601 - do the ubufox => xul-ext-ubufox transition. I'd already
    uploaded a backport of this previously to the firefox-stable PPA, which
    causes upgrades to versions without this transition to fail. In addition
    to this, it is required for lucid -> maverick upgrades to work
  * Move ubufox in to the Firefox application directory
  * Improve the addon installer module

1ee7257... by Chris Coulson on 2010-07-28

Import patches-unapplied version 0.9~rc2-0ubuntu2.1 to ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 5fa151ea6c624bd975978f05dfcc19f663f1cf91

New changelog entries:
  [ Philip Muskovac ]
  * Disable Report a Problem menu for stable release (LP: #557240)
  [ Chris Coulson ]
  * Backport change to fix URL template used for about:home; this fixes the
    problem that Yahoo about:home cannot be reached; also we get rid of the
    redirect everyone is getting on about:home to the Google/ url (LP: #606728)
    - update components/aboutHome.js

5fa151e... by Benjamin Drung on 2010-04-15

Import patches-unapplied version 0.9~rc2-0ubuntu2 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: cce5e665a80040b0a10f6ad7c19b08d50fbeaa72

New changelog entries:
  * Bump Standards-Version to 3.8.4.
  * Drop XS- prefix from Vcs-Bzr.
  * Drop zip from Build-Depends.
  * Use new features of mozilla-devscripts 0.16.
  * Simplify debian/rules.
  * Refer to versioned license file.
  * Add Homepage field.
  * Add set -e and debhelper token to preinst script.
  * Move configuration file from /etc/firefox-3.0/pref/ubufox.js to
    /etc/xul-ext/ubufox (LP: #493805).
  * Remove unused patch system.
  * Switch to dpkg-source 3.0 (quilt) format.

cce5e66... by Alexander Sack on 2010-04-09

Import patches-unapplied version 0.9~rc2-0ubuntu1 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 0390ae272d1a468ca851302f0ab1e0d673a24d9e

New changelog entries:
  New upstream release 0.9rc2:
  * fix online/offline detection by using nsIIOService rather than browser.offline pref
    - thx to Chris Coulson <email address hidden> for the patch
  * use nsIPluginHost to reloadPlugins as nsIPluginManager was removed in ffox 3.6
    - update content/pluginAlternativeOverlay.js
  * fix problem in plugin installer wizard as ubufoxPluginWizardString bundle
    is not accessible through 'this' since ffox 3.6 anymore
    - update content/pluginInstallerWizard.js
  * use Google by default for all languages
    - update locale/*/ubufox-search.properties
  (merge lp:~csaba-kertesz/ubufox/lp418777)
  * fix LP: #418777 - Portuguese string consistency
  (merge lp:~csaba-kertesz/ubufox/lp381674)
  * fix LP: #381674 - Unnecessary whitespace before ellipsis in Ubuntu Firefox menu
  (merge lp:~csaba-kertesz/ubufox/lp414926)
  * fix LP: #414926 - add Bulgarian translation
  (merge lp:~csaba-kertesz/ubufox/lp509536)
  * fix LP: #509536 - add dutch translation

0390ae2... by Alexander Sack on 2010-04-02

Import patches-unapplied version 0.9~rc1-0ubuntu1 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 54292957118d92de4af8659547ae53fa95a0f4e6

New changelog entries:
  New upstream release 0.9rc1:
  * fix LP: #526411 - In a fresh installation, firefox search engines are ordered alphabetically;
    we add ubufox-search.properties for all supported locales
  * fix LP: #452948 - Ellipses are corrected in "Report a Problem..." translations.
    - update locale/*/ubufox.dtd
  * fix LP: #522535 - Apport doesn't recognise Firefox 3.6; add
    getSourcePackageName(); update getAppVersion() to reflect unversioned
    Firefox 3.6
    - update content/overlay.js
  * set Yahoo as browser.search.order.1 and Google as .2
    - update defaults/preferences/ubuntu-mods.js
    - update locale/en-US/ubufox-search.properties
  * drop cherry picked patch
    - delete debian/patches/lp522535_fix_content_overlay.patch
    - update debian/patches/series