ubuntu/+source/tipa:applied/ubuntu/precise-devel

Last commit made on 2011-10-28
Get this branch:
git clone -b applied/ubuntu/precise-devel https://git.launchpad.net/ubuntu/+source/tipa
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/precise-devel
Repository:
lp:ubuntu/+source/tipa

Recent commits

30e96d5... by Jakub Wilk on 2011-10-28

Import patches-applied version 2:1.3-15 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 9df3b19ff1175a415f8875777ac147b3759e301f
Unapplied parent: eaad4c24b3ce2391451681f3591ebdf0e7fc041b

New changelog entries:
  * QA upload (see bug #534384).
    + Set maintainer to Debian QA Group.
  * Add build-arch, build-indep and binary-arch targets.
  * Convert to source format 3.0 (quilt):
    + Add debian/source/format.
    + Drop patching code from debian/rules.
    + Remove quilt from Build-Depends.
  * Improve debian/rules:
    + Trap errors.
    + Use $(CURDIR) variable instead of $(shell pwd).
    + Use $(MAKE) variable.
    + Rewrite get-orig-source target, so that it can be run in any directory,
      doesn't need TMPDIR to be set, create temporary files securely,
      normalize permissions inside tarball and uses maxmimum compression.
  * Add DEP-3 patch headers.
  * Bump standards version to 3.9.2 (no changes needed).
  * Build-depend on ghostscript (needed for pf2afm) instead of gs-common.
  * Move xfonts-tipa.scale to /etc/X11/fonts/Type1/ (see #364530):
    + Update paths in debian/rules.
    + Drop obsolete postinst script.
    + Use dpkg-maintscript-helper in preinst/postinst/postrm. Build-depend on
      debhelper (>= 8.1.0), which can handle debian/*.maintscript files. Add
      ${misc:Pre-Depends}.
  * Bump debhelper compat to 8 (no changes needed).
  * Force tight versioned dependency between xfonts-tipa and tipa.
  * Remove unused debian/tipa.defoma-hints.
  * Drop defoma support. Thanks to Paul Wise for hints.
    + Don't call dh_installdefoma in debian/rules.
    + Drop (build-)dependency on defoma.
  * Remove preinst code that was needed only for upgrades from versions older
    than oldstable.
  * Move xfonts-tipa to section fonts.

eaad4c2... by Jakub Wilk on 2011-10-28

Do not call mktexlsr on the build system.

Gbp-Pq: 50_no-mktexlsr-in-makefile.diff.

dc7066a... by Jakub Wilk on 2011-10-28

Import patches-unapplied version 2:1.3-15 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ab5fa6b631c7541c06655de8a65cb25e7d51da00

New changelog entries:
  * QA upload (see bug #534384).
    + Set maintainer to Debian QA Group.
  * Add build-arch, build-indep and binary-arch targets.
  * Convert to source format 3.0 (quilt):
    + Add debian/source/format.
    + Drop patching code from debian/rules.
    + Remove quilt from Build-Depends.
  * Improve debian/rules:
    + Trap errors.
    + Use $(CURDIR) variable instead of $(shell pwd).
    + Use $(MAKE) variable.
    + Rewrite get-orig-source target, so that it can be run in any directory,
      doesn't need TMPDIR to be set, create temporary files securely,
      normalize permissions inside tarball and uses maxmimum compression.
  * Add DEP-3 patch headers.
  * Bump standards version to 3.9.2 (no changes needed).
  * Build-depend on ghostscript (needed for pf2afm) instead of gs-common.
  * Move xfonts-tipa.scale to /etc/X11/fonts/Type1/ (see #364530):
    + Update paths in debian/rules.
    + Drop obsolete postinst script.
    + Use dpkg-maintscript-helper in preinst/postinst/postrm. Build-depend on
      debhelper (>= 8.1.0), which can handle debian/*.maintscript files. Add
      ${misc:Pre-Depends}.
  * Bump debhelper compat to 8 (no changes needed).
  * Force tight versioned dependency between xfonts-tipa and tipa.
  * Remove unused debian/tipa.defoma-hints.
  * Drop defoma support. Thanks to Paul Wise for hints.
    + Don't call dh_installdefoma in debian/rules.
    + Drop (build-)dependency on defoma.
  * Remove preinst code that was needed only for upgrades from versions older
    than oldstable.
  * Move xfonts-tipa to section fonts.

9df3b19... by Rafael Laboissiere on 2009-04-21

Import patches-applied version 2:1.3-14 to applied/debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 86e9474ea4920092033c8a524fe9f48e118e9597
Unapplied parent: ab5fa6b631c7541c06655de8a65cb25e7d51da00

New changelog entries:
  * Rebuilt with debhelper 7.2.14 to get rid of Lintian warning
    postinst-has-useless-call-to-install-docs
  * debian/control:
    + Bump Standards-Version to 3.8.1 (no changes needed)
    + The package is now maintained with Git at alioth.debian.org. Add
      Vcs-Git field and change Vcs-Browser accordingly.

ab5fa6b... by Rafael Laboissiere on 2009-04-21

Import patches-unapplied version 2:1.3-14 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: c52ea5f4f2a9b45ae95c2f7d46d036d37b1e80c6

New changelog entries:
  * Rebuilt with debhelper 7.2.14 to get rid of Lintian warning
    postinst-has-useless-call-to-install-docs
  * debian/control:
    + Bump Standards-Version to 3.8.1 (no changes needed)
    + The package is now maintained with Git at alioth.debian.org. Add
      Vcs-Git field and change Vcs-Browser accordingly.

86e9474... by Rafael Laboissiere on 2009-02-28

Import patches-applied version 2:1.3-13 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: a84dd1174901c4473f6cf87143182381e9831ea0
Unapplied parent: c52ea5f4f2a9b45ae95c2f7d46d036d37b1e80c6

New changelog entries:
  * Switch from dpatch to quilt for Debian patches management
  * debian/rules: Use debian/clean instead of manually cleaning files
  * debian/compat, debian/control: Bump build-dependency on debhelper to
    >= 7.0.0, otherwise debian/clean is moot
  * debian/clean: New file
  * debian/control:
    + Bump Standards-Version to 3.8.0 (no changes needed)
    + Fix Lintian warning debhelper-but-no-misc-depends
    + Add defoma to Build-Depends-Indep, otherwise the call to
      dh_installdefoma fails
    + Add a generic paragraph at the beginning of the long descriptions
      of the packages xfont-tipa and tipa-doc
  * debian/rules: Use dh_prep instead of dh_clean -k

c52ea5f... by Rafael Laboissiere on 2009-02-28

Import patches-unapplied version 2:1.3-13 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8545469352d006b114b53891da28837629df1cb4

New changelog entries:
  * Switch from dpatch to quilt for Debian patches management
  * debian/rules: Use debian/clean instead of manually cleaning files
  * debian/compat, debian/control: Bump build-dependency on debhelper to
    >= 7.0.0, otherwise debian/clean is moot
  * debian/clean: New file
  * debian/control:
    + Bump Standards-Version to 3.8.0 (no changes needed)
    + Fix Lintian warning debhelper-but-no-misc-depends
    + Add defoma to Build-Depends-Indep, otherwise the call to
      dh_installdefoma fails
    + Add a generic paragraph at the beginning of the long descriptions
      of the packages xfont-tipa and tipa-doc
  * debian/rules: Use dh_prep instead of dh_clean -k

a84dd11... by Rafael Laboissiere on 2008-03-19

Import patches-applied version 2:1.3-12 to applied/debian/lenny

Imported using git-ubuntu import.

Unapplied parent: 8545469352d006b114b53891da28837629df1cb4

8545469... by Rafael Laboissiere on 2008-03-19

Import patches-unapplied version 2:1.3-12 to debian/lenny

Imported using git-ubuntu import.