ubuntu/+source/squid:ubuntu/edgy

Last commit made on 2006-07-13
Get this branch:
git clone -b ubuntu/edgy https://git.launchpad.net/ubuntu/+source/squid
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/edgy
Repository:
lp:ubuntu/+source/squid

Recent commits

6d90e0c... by Anibal Monsalve Salazar on 2006-07-12

Import patches-unapplied version 2.6.1-3ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 145446f7596f335b564f39f68bacee1b5e78bc8c

New changelog entries:
  * Resynchronise with Debian.
  * debian/rules
    - Removed debian/po/*.po~
  * debian/patches/48-kfreebsd-kqueue
    - Added user interface for kqueue() on GNU/kFreeBSD (Thanks to Petr
      Salinger) (Closes: #377873)
  * debian/rules
    - Disabled IPF support on GNU/kFreeBSD
    - Install RELEASENOTES.html in /usr/share/doc
  * debian/NEWS.Debian
    - Added notice on changes to configuration file and reference to the
      RELEASENOTES.html file (Closes: #377950)
  * debian/control
    - Added missing Build-Depends on libdb4.3-dev (Closes: #377473)

145446f... by Martin Pitt on 2006-07-11

Import patches-unapplied version 2.6.1-1ubuntu2 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 256169dc22c44f2a05b052368f0e22a6b45a7326

New changelog entries:
  * Add libdb4.4-dev build dependency to fix FTBFS.

256169d... by Martin Pitt on 2006-07-10

Import patches-unapplied version 2.6.1-1ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 067fe7b78c281e300fe614e6f4d26fd90e7b793a

New changelog entries:
  * Merge from Debian unstable.
  * New upstream version
    - removed patches that have been integrated upstream:
      debian/patches/47-httpreplydestroy.dpatch
  * debian/rules
    - Removed build time upgrade of autoconf since config.{sub,guess} has been
      updated upstream
    - Enabled epoll() support on Linux and Kqueue support on KFreeBSD
    - Enabled Linux TPROXY support for totally transparent proxy support
    - Removed Winbind-based helpers building. Winbind is not supported
      upstream anymore
    - Moved documentation to squid-common
  * debian/postinst
    - Fix configuration file for missing http_port directive
  * debian/control
    - Remove dependency on webmin-squid which is not in the archive anymore
    - Bumped Standards-Version to 3.7.2 (no change required)

067fe7b... by Martin Pitt on 2006-07-06

Import patches-unapplied version 2.5.14-1ubuntu1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 24707ac7e58153429384a94d131646298f7538ac

New changelog entries:
  * Merge from debian unstable.
  * Only Ubuntu change left: Use snakeoil SSL certificate.
  * New upstream release
  * debian/patches/47-httpreplydestroy
    - Added upstream patch fixing assertion failure in HttpReply.c
  * debian/{prerm,postinst}
    - Make squid restart in postinst instead of stopping in prerm
      (Closes: #252467)
  * debian/{rules,control}
    - Added build-time upgrade of config.{guess,sub} for GNU/kFreeBSD
      (Closes: #365211)
  * debian/po/ca.po
     - Added Catalan debconf translation thanks to Miguel Gea Milvaques
       (Closes: #365412)
  * New upstream release

24707ac... by Adam Conrad on 2006-02-22

Import patches-unapplied version 2.5.12-4ubuntu2 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: d1b29c6f2199810ed5f038f6b337affc5dcf29c7

New changelog entries:
  * Add 99-ubuntu-wbinfo_group.dpatch, to make wbinfo_group.pl work properly
    with Samba >= 3.0.21, which is in dapper (Closes: launchpad.net/29228)

d1b29c6... by Fabio Massimo Di Nitto on 2006-02-04

Import patches-unapplied version 2.5.12-4ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 612e3c557af89687ceb4086a2b71d653b015e9b0

New changelog entries:
  * Switch default config to suggest default ssl-cert-snakeoil certificates.
  * Add Depends on ssl-cert.
  * Add patch ssl-cert-snakeoil.

612e3c5... by Luigi Gangitano on 2006-01-16

Import patches-unapplied version 2.5.12-4 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 0716619c6d9ebc25ec243261b629b878ccf0e928

New changelog entries:
  * The "Required is not essential" release
  * debian/control
    - Added dependency on lsb-base (Closes: #347800, #347537)

0716619... by Luigi Gangitano on 2005-12-28

Import patches-unapplied version 2.5.12-3 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: e39b8b8d6a6abdb52c83579fe25314dbec81f4a2

New changelog entries:
  * Rebuilt to fix missing .diff.gz file (Closes: #344404)
  * debian/squid.rc
    - Fixed use of literal value (Closes: #344382)

e39b8b8... by Luigi Gangitano on 2005-12-20

Import patches-unapplied version 2.5.12-2 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 6aeb8ce67b791ddd7f8350ad0d5e23295a729aab

New changelog entries:
  * debian/control
    - Removed circular dependency of squid-common on squid (Closes: #339904)
    - Removed dependency on stat
  * debian/squid.rc
    - Converted to use lsb init functions

6aeb8ce... by Luigi Gangitano on 2005-11-02

Import patches-unapplied version 2.5.12-1 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 469542ed85d354dbc513af0149d76ca36f9ed296

New changelog entries:
  * New upstream release
    - removed patches that have been integrated upstream:
      debian/patches/43-stathist-assert
      debian/patches/44-sslconnect-segfault
      debian/patches/45-store-assert
      debian/patches/46-ntlm-scheme-assert
  * debian/rules
    - Added debconf-updatepo in clean rule (Closes: #335542)
  * debian/po/fr.po
    - Updated French debconf translation, thanks to Michel Grentzinger
      (Closes: #337055)
  * debian/po/sv.po
    - Added Swedish debconf translation, thanks to Daniel Nylander
      (Closes: #330273)
  * debian/changelog
    - Fixed really old entries (1996) and make lintian happy
  * debian/copyright
    - Fixed FSF address in copyright
  * debian/control
    - Bumped Standards-Version to 3.6.2.0, no change needed
  * Urgency high due to security issues
  * debian/patches/46-ntlm-scheme-assert
    - Really enable this patch in 00list (thanks to Martin Pitt for pointing
      this out)