ubuntu/+source/spice:ubuntu/wily-devel

Last commit made on 2016-06-21
Get this branch:
git clone -b ubuntu/wily-devel https://git.launchpad.net/ubuntu/+source/spice
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/wily-devel
Repository:
lp:ubuntu/+source/spice

Recent commits

398df23... by Marc Deslauriers on 2016-06-10

Import patches-unapplied version 0.12.5-1.1ubuntu2.1 to ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: 84ec1b2d465e51e1ed206074ae92d7fa83231340

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory allocation flaw in smartcard interaction
    - debian/patches/CVE-2016-0749/*.patch: add a ref to item and allocate
      msg with the expected size in server/smartcard.c.
    - CVE-2016-0749
  * SECURITY UPDATE: host memory access from guest with invalid primary
    surface parameters
    - debian/patches/CVE-2016-2150/*.patch: create a function to validate
      surface parameters in server/red_parse_qxl.*, improve primary surface
      parameter checks in server/red_worker.c.
    - CVE-2016-2150
  * Added two extra commits to previous security update:
    - 0001-worker-validate-correctly-surfaces.patch
    - 0002-worker-avoid-double-free-or-double-create-of-surface.patch

84ec1b2... by Marc Deslauriers on 2015-10-19

Import patches-unapplied version 0.12.5-1.1ubuntu2 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: bc40c2f5437872d8afcee7e2f9af9cdbf8ec46e6

New changelog entries:
  * SECURITY UPDATE: multiple security issues
    - debian/patches/CVE-2015-526x/*.patch: apply series of patches from
      Red Hat to fix overflows, race conditions, memory leaks and denial of
      service issues.
    - CVE-2015-5260
    - CVE-2015-5261

bc40c2f... by Marc Deslauriers on 2015-09-08

Import patches-unapplied version 0.12.5-1.1ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 27b11d3f5c414457d4ce3e477c89287e5ccb6b6c

New changelog entries:
  * SECURITY UPDATE: heap corruption via monitor configs
    - debian/patches/CVE-2015-3247.patch: only read count once in
      server/red_worker.c.
    - CVE-2015-3247

27b11d3... by Laurent Bigonville on 2015-08-14

Import patches-unapplied version 0.12.5-1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 99ef9c45c1f44d14126965cad35f1af1cb454469

New changelog entries:
  * Non-maintainer upload.
  * Enable smartcard support now that libcacard is in the archive (Closes:
    #786833)

99ef9c4... by Michael Tokarev <email address hidden> on 2014-05-23

Import patches-unapplied version 0.12.5-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 06cd7476956ec235137c89fc337fde465ec80a4b

New changelog entries:
  * new upstream release. Can now build without celt!
  * Dropped patches:
    - make-celt-to-be-optional.patch
    - link-server-test-with-libm-libpthread.patch
    - enable_subdir-objects.patch
    - fix-buffer-overflow-when-decrypting-client-spice-ticket.patch
  * build-depend on libopus-dev, which enables opus support
    (no --enable-opus configure flag for now)
  * do not remove .version in clean anymore (it is part of the tarball)
  * do not use dh_autoreconf, since we aren't changing autoconf anymore
  * update libspice-server1.symbols with new symbols
  * introduce libspice-server1-dbg package (Closes: #743850)
  * fix the vcs-browse url (Closes: #722241)

06cd747... by Liang Guo <email address hidden> on 2013-11-07

Import patches-unapplied version 0.12.4-0nocelt2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0a8a8053df2ef2e583d64cdb1a7694152ad878b0

New changelog entries:
  * Fix CVE-2013-4282 (Closes: #728314)

0a8a805... by Hideki Yamane on 2013-10-21

Import patches-unapplied version 0.12.4-0nocelt1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a498133b5aac1cd91035400e929bf9ce6a3fbd70

New changelog entries:
  * Non-maintainer upload.
  * debian/patches
    - add enable_subdir-objects.patch (Closes: #724093)

a498133... by Liang Guo <email address hidden> on 2013-07-24

Import patches-unapplied version 0.12.4-0nocelt1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7b8932ef600c452c09c6faede12e40fc1b1c0547

New changelog entries:
  * New upstream release (Closes: #717030)
  * Remove .version after build (Closes: #671627)
  * debian/control:
    - Bump Standards-Version to 3.9.4 (no changes)
    - Update VCS-* to use canonical URIs
  * debian/patches:
    - fix-tests-warnings.patch, refresh
    - link-server-test-with-libm-libpthread.patch, add (Closes: #713681)
  * Refresh libspice-server1.symbols

7b8932e... by Liang Guo <email address hidden> on 2013-05-19

Import patches-unapplied version 0.12.3-0nocelt1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 285502ee549a63b519849a94b8f975724e90c38f

New changelog entries:
  * New upstream release
  * debian/patches:
    - fix-build-warning-PIXEL.patch, remove, applied upstream
    - link-libspice-server-with-libm-libpthread.patch, remove,
      applied upstream
    - spice-common-remove-version-construction.patch, remove,
      applied upstream
    - fix-tests-warnings.patch, refresh
    - make-celt-to-be-optional.patch, refresh
  * libspice-server-dev should depends on libglib2.0-dev, or
    qxl driver compile will fail.
  * Refresh libspice-server1.symbols

285502e... by Liang Guo <email address hidden> on 2013-05-10

Import patches-unapplied version 0.12.2-0nocelt3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1c312ccc486266adec2374ec0112dfe51fae50a3

New changelog entries:
  * Upload to unstable