ubuntu/+source/spice:debian/sid

Last commit made on 2019-10-01
Get this branch:
git clone -b debian/sid https://git.launchpad.net/ubuntu/+source/spice
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/sid
Repository:
lp:ubuntu/+source/spice

Recent commits

4afc5a8... by Michael Tokarev <email address hidden> on 2019-10-01

Import patches-unapplied version 0.14.2-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c351472c75e0e1c083706f66e9407e08f6cc1f9b

New changelog entries:
  * disable failing test-listen (Closes: #941006)
  * add fix-test-qxl-parsing-on-ppc64el-and-armhf.patch
  * stop using dh_autoreconf as we do not patch autoconf/automake anymore

c351472... by Michael Tokarev <email address hidden> on 2019-08-31

Import patches-unapplied version 0.14.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 37e10d0858e8f7642538bf9515527375a5f60bc5

New changelog entries:
  * red-replay-qxl-fix-replay-on-32-bit-systems.patch
    hopefully fix the tests failure on arm* and ppc (FTBFS)
  * remove-compile-warnings-on-Linux-32bit-system.patch
    fix tons of compiler warnings on 32bit platforms

37e10d0... by Michael Tokarev <email address hidden> on 2019-08-30

Import patches-unapplied version 0.14.2-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 995526c4907572a1451a379f687b099356c480fc

New changelog entries:
  * set $XDG_RUNTIME_DIR instead of $HOME when running tests
    to avoid dconf cache failure (fix FTBFS on almost all buildds)
  * set GSTREAMER_1_0_LIBS and GLIB2_LIBS (trimmed) for configure
    to avoid linking with useless libs

995526c... by Michael Tokarev <email address hidden> on 2019-08-30

Import patches-unapplied version 0.14.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b0ccbe31f4fb88b2b31975582fee418d035e40df

New changelog entries:
  * new upstream 0.14.2 release
  * remove all security patches (included upstream)
  * set maintainer to the QEMU team (Closes: #911427)
  * spice-protocol needs to be >= 0.14.0
  * require glib >= 2.38
  * do not disable celt051, it is not enabled by default anymore
  * explicitly enable optional features at configure time
    (gstreamer=1.0, sasl, lz4)
  * do not recommend but suggest gstreamer1.0-plugins-ugly
  * stop Break'ing very old spice-client packages
  * set $HOME when running tests
  * switch to python3 when building (Closes: #938548)
  * update libspice-server1.symbols
    (+SPICE_SERVER_0.14.2, +spice_qxl_set_device_info)
  * remove unneded --parallel option to debhelper
  * fix VCS fields to point to salsa

b0ccbe3... by Salvatore Bonaccorso on 2019-01-28

Import patches-unapplied version 0.14.0-1.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 08fa9112b17f4367d15d114375bcf6592e8a4a2e

New changelog entries:
  * Non-maintainer upload.
  * memslot: Fix off-by-one error in group/slot boundary check (CVE-2019-3813)
    (Closes: #920762)

08fa911... by Salvatore Bonaccorso on 2018-10-11

Import patches-unapplied version 0.14.0-1.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4911aae065d3133d5f32643f72dc8c1e17439812

New changelog entries:
  * Non-maintainer upload.
  * tests/pki: Use CA/certificate with 2048 bit RSA keys (Closes: #910634)

4911aae... by Salvatore Bonaccorso on 2018-09-15

Import patches-unapplied version 0.14.0-1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a0983e0236e7234f04caf9385362ac900792822f

New changelog entries:
  * Non-maintainer upload.
  * Fix flexible array buffer overflow (CVE-2018-10873) (Closes: #906315)

a0983e0... by Liang Guo <email address hidden> on 2017-10-19

Import patches-unapplied version 0.14.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 731dc28979e7856ca2d5c55119d161d7542cad55

New changelog entries:
  * New upstream release
  * debian/copyright: refresh
  * debian/control:
    - Add liborc-0.4-dev to Build-Depends
    - Update Build-Depends on debhelper to >= 10
    - Remove dh-autoreconf from Build-Depends
    - Bump Standards-Version to 4.1.1 (no changes)
    - Use https in Homepage
  * debian/compat, bump to 10
  * debian/watch, switch to https

731dc28... by Laurent Bigonville on 2017-09-20

Import patches-unapplied version 0.13.90-0.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3bf9e3b7ebd7b85c6354e0abf52934a2a96ec1d3

New changelog entries:
  * Non-maintainer upload.
  * debian/rules: Disable parallel building for the tests, this will hopefully
    fix FTBFS on some arch (Closes: #876266)

3bf9e3b... by Laurent Bigonville on 2017-08-22

Import patches-unapplied version 0.13.90-0.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4b629d66bc0d867f2004cc87b83a04090bbddc48

New changelog entries:
  * Non-maintainer upload.
  [ Laurent Bigonville ]
  * New upstream release (Closes: #849569)
    - Adjust the build-dependencies
    - Drop d/p/CVE-2016-9577-and-CVE-2016-9578.patch,
      d/p/CVE-2017-7506-1.patch, d/p/CVE-2017-7506-2.patch,
      d/p/CVE-2017-7506-3.patch: All merged upstream
    - Drop debian/patches/fix-tests-warnings.patch, unused
    - debian/libspice-server1.symbols: Add newly exported symbols
  * debian/watch: Enable gpg key verification of the upstream tarball
  * debian/rules: Also remove the Libs.private defs from .pc file
  * debian/control: Bump Standards-Version to 4.1.0 (no further changes)
  * debian/rules: Drop override_dh_installdocs, this was only needed when we
    were building the -dbg package ourself
  * debian/control: Add liblz4-dev to the build-dependencies
  * debian/control: Add the needed gstreamer modules to the
    (build-)dependencies to enable gstreamer support
  * Run wrap-and-sort -ts
  [ Santiago Ruano Rinc√≥n ]
  * debian/tests/automated-tests: Intial DEP-8 test, using upstream automated
    test (Closes: #827027)