ubuntu/+source/speech-dispatcher:ubuntu/utopic

Last commit made on 2014-05-16
Get this branch:
git clone -b ubuntu/utopic https://git.launchpad.net/ubuntu/+source/speech-dispatcher
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/utopic
Repository:
lp:ubuntu/+source/speech-dispatcher

Recent commits

528465d... by Luke Yelavich on 2014-05-16

Import patches-unapplied version 0.8-6ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 431636990c0082f978874a2d108a818a4b5fae39

New changelog entries:
  * The speech-dispatcher user should not have a shell set (LP: #1319970)

4316369... by Luke Yelavich on 2014-04-28

Import patches-unapplied version 0.8-6ubuntu1 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 5dcd85659e55f329487f21c0bd42ca613caa4564

New changelog entries:
  * Merge with debian unstable. Remaining changes:
    - Moved the flite output module to a separate package, and added
      it to suggests, we don't want flite on the Ubuntu CD image
    - Don't build depend on libaudio-dev or libao-dev, Ubuntu CD size is an
      issue, every little bit helps
    - debian/gbp.conf: Adjust for the Ubuntu git branch

5dcd856... by Paul Gevers on 2014-03-17

Import patches-unapplied version 0.8-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 98370c114bf2606d7d4ac194c868850c33e34e9e

New changelog entries:
  * Remove dotconf 1.3 workaround as it is now available in sid

98370c1... by Paul Gevers on 2014-02-15

Import patches-unapplied version 0.8-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 079f40988bd65ff30ada8ee381cd53be572ee01d

New changelog entries:
  * Upload to unstable
  * Work around dotconf 1.3 requirement as it takes too long now

079f409... by Paul Gevers on 2014-02-11

Import patches-unapplied version 0.8-4 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 904105c6db2744e72c784a64fb9a862896917f9e

New changelog entries:
  * Fix maintainer address again (Closes: #736469)
  * Update d/copyright and convert to machine readable format (Closes:
    #734302)
  * Add upstream commit link to spelling error patch

904105c... by Paul Gevers on 2014-01-19

Import patches-unapplied version 0.8-3 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 67f28a938f5ad048494ba50645a21babd8f703c2

New changelog entries:
  * Add symlinks from old /usr/include/* to /usr/include/speech-dispatcher/*
    to ease the transition of the new location (works for all current Debian
    reverse dependencies)
  * Fix links to user config/cache directories in the documentation

67f28a9... by Paul Gevers on 2014-01-17

Import patches-unapplied version 0.8-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 8cf899c13576806e03192176276dd629e0a7785f

New changelog entries:
  * Update init script to use log_action_msg i.s.o. echo (Closes: #679162)
  * Add Replaces/Breaks to python3-speechd and speech-dispatcher-festival
    (Closes: #734778, #734899)
  * Minor tweaks:
    - wrap-and-sort on d/control
    - Add patch descriptions to the ones missing them
    - Update link in copyright to versioned LGPL file
    - Remove override_dh_auto_install target as it only changed *.la files
      that aren't installed
    - Update speech-dispatcher.post* scripts to "set -e" (thanks Lintian)
    - Remove pycompat and XB-Python-Version (obsolete)
  * Fixed the wrong maintainer address
  * Add python3-xdg to python3-speechd dependencies
  * Update *README.Debian with updated configuration location and mention
    the default is to not run as server
  * Fix several spelling errors (thanks Lintian)

8cf899c... by Paul Gevers on 2014-01-02

Import patches-unapplied version 0.8-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 71ee3349e6746f4b6222417ef38d6b2bf04eb0a0

New changelog entries:
  [ Samuel Thibault ]
  * debian/control: Set libspeechd2 multi-arch: same.
  * debian/rules: Set multiarch libdir.
  * debian/libspeechd-dev.install,libspeechd2.install,
    speech-dispatcher.install: Use multiarch libdir.
  * Do not depend on dpkg | install-info, now that we use the install-info
    trigger.
  * Bump Standards-Version to 3.9.5.
  * Bump dotconf dependency to >= 1.3.
  * debian/control: Move VCS to tts team.
  [ Luke Yelavich ]
  * New upstream release
  * debian/patches/infinite-loop.patch: Refreshed
  * Dropped patches:
    - debian/patches/build-doc.patch
    - debian/patches/procname.patch
    - debian/patches/paths+files.patch
    - debian/patches/pthread.patch
  * Add libltdl-dev and intltool to build-depends
  * Update packaging for speech-dispatcher python 3 bindings.
  * Move speech-dispatcher modules to an architecture independent dir, since
    modules can be written in any language, and i386 only modules can be
    used on amd64 systems
  * Create separate audio plugins package
  * Convert to debhelper 7+ packaging.
  * Use dh-autoreconf to handle autotools file rebuilds.
  * Update standards version to 3.9.3.
  * Add X-Python-Version related fields to debian/control.
  * Patch in the speech-dispatcher-cs.texi file since it was forgotten in the
    0.8 tarball
  * Add translations to speech-dispatcher
  [ Jason White ]
  * Raise level of subsection in fdl.texi to correct document structure.
  [ David Henningsson ]
  * debian/patches/pulse-default-latency.patch:
    Default to 20 ms latency instead of 1 ms latency (LP: #1208826)
  [ Luke Yelavich ]
  * spd_audio: Expose dlopened library's symbols to libs it loads. Thanks to
    Christopher Brannon <email address hidden> for the patch, taken from
    the speech-dispatcher mailing list.
  [ Paul Gevers ]
  * New maintainer (Closes: #730983)
  * Acknowledge NMU's
  * libsdaudio.* is not build and installed anymore
    - Drop break/replace in libspeechd-dev
    - Closes: #715119
  * Add source lintian overrides for gfdl/gpl documentation
  * Change speech-dispatcher-festival to Arch: any now it contains a binary
  * Strip all binaries into -dbg package
  * Add d/watch file (Thanks Bart Martens)
  * Raise compat level to 9 to get auto-hardening (was a Wheezy release goal)

71ee334... by Hilko Bengen on 2013-11-23

Import patches-unapplied version 0.7.1-6.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2edeb908f5efe15674978980d85d603c844f3603

New changelog entries:
  * Non-maintainer upload.
  * Fix texinfo error (Closes: #713310)

2edeb90... by Samuel Thibault <email address hidden> on 2012-12-07

Import patches-unapplied version 0.7.1-6.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 00dcbfe36b10f261bb5a6daabae69952ae3468e8

New changelog entries:
  * Non-maintainer upload.
  * control: Add break/replace for move of libsdaudio.{a,so} from
    speech-dispatcher to libspeechd-dev, thanks Andreas Beckmann for the
    report & patch; closes: #694295.
  * patches/espeak-mbrola-generic.conf.patch: Add patch from Mau to fix mbrola
    generic output; closes: #665382.