ubuntu/+source/simple-scan:ubuntu/cosmic

Last commit made on 2018-09-30
Get this branch:
git clone -b ubuntu/cosmic https://git.launchpad.net/ubuntu/+source/simple-scan
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/cosmic
Repository:
lp:ubuntu/+source/simple-scan

Recent commits

5b85f93... by Jörg Frings-Fürst <email address hidden> on 2018-09-30

Import patches-unapplied version 3.30.1.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d8f4936372d9489bac7616490502d3aec4f5fdc0

New changelog entries:
  * New upstream release.

d8f4936... by Jörg Frings-Fürst <email address hidden> on 2018-09-04

Import patches-unapplied version 3.30.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 056cf11c3c317d22515108efe1823ca6660931cd

New changelog entries:
  * New upstream release (Closes: #907932).
  * Declare compliance with Debian Policy 4.2.1 (No changes needed).

056cf11... by Jörg Frings-Fürst <email address hidden> on 2018-07-16

Import patches-unapplied version 3.28.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8ebf57258f3faaff261cf3ab11256104142631e5

New changelog entries:
  * New upstream release (Closes: #892944).
  * Remove upstream applied patches:
    - 0010-metadata.patch
    - 0015-xdg-email.patch
  * debian/copyright:
    - refresh years.
    - Use secure copyright format URI.
    - Add new upstream authors.
  * debian/control:
    - Switch from python-scour to python3-scour since dh_scour is now provided
      by python3-scour only as of scour 0.36-1.
    - Add missing Build-Depends to use all features:
      + libwebp-dev
      + python3-cairo
      + python3-gi
      + python3-gi-cairo
    - Switch Vcs-* to new location.
    - Switch to new homepage.
    - Remove unneeded build depends versions.
  * Declare compliance with Debian Policy 4.1.5 (No changes needed).
  * Refresh debian/upstream/metadata.
  * Some buildsystem changes (Closes: #881934):
    - debian/rules: Add gnome and dh_translation handling.
    - debian/control: Refresh build depends.
    - debian/source_simple-scan.py: Report versions for more scanner drivers.
    Thanks to Jeremy Bicha <email address hidden>

8ebf572... by Jörg Frings-Fürst <email address hidden> on 2017-11-12

Import patches-unapplied version 3.26.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 27ff9c749e0eebfa552cda8b3829b0ccecb336c6

New changelog entries:
  * New upstream release (Closes: #881345):
    - Updated translations.
    - Check if files exist in multi-file saves.
    - Remove "Save As" - save now always prompts when overwriting
      (Closes: #852730).
    - Add a continuous scan option.
    - Make email and print actions insensitive when document empty.
    - Remove .ps and .tiff output support - this is not required.
    - Switch from autotools to Meson.
  * New README.source to explain the branching model used.
  * Switch buildsystem to meson:
    + debian/control:
      - Add meson to Build-Depends.
      - Remove dh-autoreconf from Build-Depends.
    + debian/rules:
      - Remove the --with=autoreconf parameter.
      - Remove override_dh_auto_clean and override_dh_autoreconf section.
    + debian/simple-scan.install:
      - Remove useless /usr/bin and /usr/share.
    + Remove useless debian/patches/0005-zlib.patch.
  * Declare compliance with Debian Policy 4.1.1. (No changes needed).
  * Use the automatic debug symbol packages:
    - Remove simple-scan-dbg section from debian/control.
    - Remove override_dh_strip from debian/rules.
  * New Homepage:
    - debian/watch: switch to gnome.
  * Change to my new email address.
  * Drop useless debian/simple-scan.lintian-overrides.
  * New debian/patches/0010-metadata.patch to install appstream metadata into
    the requested directory /usr/share/metainfo/.

27ff9c7... by Jörg Frings-Fürst on 2016-12-01

Import patches-unapplied version 3.23.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f21a97d0fa1e23031945216501649d618f7ec721

New changelog entries:
  * New upstream release (Closes: #843941):
    - Stop translating icon name in .desktop file (Closes: #838099).
  * Migrate to debhelper 10:
    - Change debian/compat to 10.
    - Change debhelper version in debian/control to >= 10.
  * debian/rules:
    - Remove useless comments and statements.
  * debian/control:
    - Remove obsolete build dependencies (Closes: #843942).
      Thanks to Michael Biebl <email address hidden>!
    - Drop adwaita-icon-theme from Depends for adwaita-icon-theme.
      It is already pulled in by libgtk-3-0 (Closes: #840180).
      Thanks to Laurent Bigonville <email address hidden>!
    - Move build dependency from deprecated python-rsvg to
      librsvg2-dev (Closes: #844152).

f21a97d... by Jörg Frings-Fürst on 2016-08-31

Import patches-unapplied version 3.21.90-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 24bf9e0dc4987011899f9d3885eda410e0b96ea1

New changelog entries:
  * New upstream release:
    - Updated translations.
    - Use recent features of gettext, dropping intltool.
  * Refresh patches/0005-zlib.patch.
  * Dropping intltool:
    - debian/control: Remove intltool from Build-Depends.
    - debian/rules: Remove intltool.
  * Remove patches applied upstream:
    - debian/patches/0100-typos.patch.
  * debian/control:
    - Switch Depends from dbus-x11 to
      default-dbus-session-bus | dbus-session-bus (Closes: #836047).

24bf9e0... by Jörg Frings-Fürst on 2016-04-12

Import patches-unapplied version 3.20.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b2a9336170bd09871e0b8baaf753a83bb981bb3f

New changelog entries:
  * New upstream release:
    - Fix typo in Epson website URL.
    - Enable translations for help documentation.
    - Updated translations.
    - Fix window state saving with client side decorations (Closes: #799090).
  * Add year 2016 to debian/copyright.
  * debian/watch: Bump version to 4 (no changes required).
  * debian/control:
    - Bump Standards-Version to 3.9.8 (no changes required).
    - Use secure URIs.
    - Remove useless comments.
  * New debian/patches/0100-typos.patch:
    - Fix typo in src/autosave-manager.vala.

b2a9336... by Jörg Frings-Fürst on 2015-12-14

Import patches-unapplied version 3.19.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9a100e74d09de61e5a13abe705f12eb84c14a619

New changelog entries:
  * New upstream release:
    - Allow explicit disabling of colord/packagekit support.

9a100e7... by Jörg Frings-Fürst on 2015-11-03

Import patches-unapplied version 3.19.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a97c3891e26d03297921fb0498661c9336f8217f

New changelog entries:
  * New upstream release:
    - Make PackageKit support optional
    - Add help for quality, brightness, contrast settings
    - Fix help references to Wikipedia (currently just say Wiki)
    - Fix SANE capability logging commas
  * Refresh debian/patches/01-zlib.patch.
  * Rename debian/patches/01-zlib.patch to debian/patches/0005-zlib.patch.

a97c389... by Jörg Frings-Fürst on 2015-09-27

Import patches-unapplied version 3.18.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ed5b841354299cc9e3862b6475a3ec230a0f5a08

New changelog entries:
  * New upstream release:
    - Show error message when failing to install drivers.
    - Bump copyright dates.
    - Correctly select the previous device after device list has been updated.
    - Updated translations.
    - Always default to PDF when saving.
    - Use a combo box for selecting the file type in the save dialog.
    - Detect HP scanners and install drivers using PackageKit if found.
    - If SANE detects no scanners but we see USB IDs of Brother, Epson
      or Samsung scanners, prompt the user to go to their website to
      install drivers.
    - Use GUsb instead of GUdev.
    - Fix error dialogs not showing.
  * debian/control:
    - Add to Build-Depends:
      + libgusb-dev
      + libpackagekit-glib2-dev
    - Remove from Build-Depends:
      + libgudev-1.0-dev