ubuntu/+source/sg3-utils:ubuntu/karmic

Last commit made on 2009-07-15
Get this branch:
git clone -b ubuntu/karmic https://git.launchpad.net/ubuntu/+source/sg3-utils
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/karmic
Repository:
lp:ubuntu/+source/sg3-utils

Recent commits

134cb1e... by Martin Pitt on 2009-06-22

Import patches-unapplied version 1.27-0.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7f682bb9e05cb807df3e802bf561e63c972d9c23

New changelog entries:
  [ Martin Pitt ]
  * Non-maintainer upload; this package blocks DeviceKit, and maintainer is
    apparently not active any more. Also clean up and modernize the package
    somewhat while we are at it.
  * New upstream release (required for current devicekit-disks).
    (Closes: #532546). Upstream original tarball repacked to not contain
    debian/ directory.
  * Rename libsgutils1{,-dev} to libsgutils2-2{,-dev}, upstream bumped SONAME.
    Also call the library libgsutils2-2 to match SONAME. Add
    Conflicts/Replaces for "libsgutils2" to provide a clean upgrade from the
    packages as provided by Upstream and Ubuntu.
  * debian/rules: Update build rules for upstream Makefile → autotools switch.
  * debian/rules: Fix cleaning a clean source package.
  * Demote Recommends to Suggests; the library doesn't actually call the
    binaries in sg3-utils. (Closes: #532547)
  * Drop debian/*.dirs, unnecessary with dh_install.
  * Drop sg3-utils.preinst, not necessary to deal with kernel 2.4 any more.
  * Drop libsgutils2-0.install, libsgutils2-0-dev.install, these packages
    don't exist.
  * Drop libsgutils2.post{inst,rm}: Basically empty, debhelper will create its
    own.
  * libsgutils2-dev.install: Drop *.lo.
  * debian/compat: 4 -> 7. Bump debhelper build-depends accordingly.
  * debian/control: Bump Standards-Version to 3.8.2.
  * debian/control: Modernize package description for Linux 2.6.
    (Closes: #506578)
  * debian/rules: Drop -k argument from dh_clean (thanks lintian).
  [ Frank Lichtenheld ]
  * debian/control, debian/rules: Add dependency of libsgutils-dev on
    libcam-dev on kfreebsd-*. (Closes: #519460)

7f682bb... by Eric Schwartz on 2007-12-30

Import patches-unapplied version 1.24-2 to debian/lenny

Imported using git-ubuntu import.