ubuntu/+source/samba:ubuntu/trusty

Last commit made on 2014-04-04
Get this branch:
git clone -b ubuntu/trusty https://git.launchpad.net/ubuntu/+source/samba
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/trusty
Repository:
lp:ubuntu/+source/samba

Recent commits

e601e55... by Steve Langasek on 2014-04-04

Import patches-unapplied version 2:4.1.6+dfsg-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: eac0063ea3fbc50f750588621d77d605e1333973

New changelog entries:
  * Fix a grammatical error in smb.conf that showed up in a ucf prompt on
    upgrade.

eac0063... by Chuck Short on 2014-04-02

Import patches-unapplied version 2:4.1.6+dfsg-1ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 724c13254189e88d9cf11bba12174e80369058f9

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    + debian/VERSION.patch: Update vendor string to "Ubuntu".
    + debian/smb.conf;
       - Add "(Samba, Ubuntu)" to server string.
       - Comment out the default [homes] share, and add a comment about "valid users = %s"
         to show users how to restrict access to \\server\username to only username.
    + debian/samba-common.config:
      - Do not change prioritiy to high if dhclient3 is installed.
    + debian/control:
      - Don't build against or suggest ctdb and tdb.
    + debian/rules:
      - Drop explicit configuration options for ctdb and tdb.
    + Add ufw integration:
      - Created debian/samba.ufw.profile:
      - debian/rules, debian/samba.install: install profile
    + Add apport hook:
      - Created debian/source_samba.py.
      - debian/rules, debia/samb-common-bin.install: install hook.
    + debian/samba.logrotate: call upstart interfaces unconditionally instead
      of hacking arround with pid files.
    + Set sbmclients conflicts with samba4-clients less than 4.0.3+dfsg1-0.1ubuntu4,
      first dummy transitional package version.
    + Dropped patches:
      - debian/patches/CVE-2013-4496.patch: Dropped no longer needed
      - debian/patches/CVE-2013-6442.patch: Dropped no longer needed.
      - debian/patches/readline-ftbfs.patch: Use the debian version.
    + debian/samba-common.dirs: Move /var/lib/samba/private from samba.dirs.
      (LP: #1268180)

724c132... by Ivo De Decker <email address hidden> on 2014-03-15

Import patches-unapplied version 2:4.1.6+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 02411b81187a7bd8ba7c24800be655f673ce1eec

New changelog entries:
  * New upstream security release. Fixes:
    - CVE-2013-4496: password lockout not enforced for SAMR password changes
    - CVE-2013-6442: smbcacls can remove a file or directory ACL by mistake
  * Backport fix for readline 6.3 from master

02411b8... by Ivo De Decker <email address hidden> on 2014-02-22

Import patches-unapplied version 2:4.1.5+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b2237fa1b4af94448ec51df165a6806fda18eca1

New changelog entries:
  [ Jelmer Vernooij ]
  * Fix watch file.
  [ Ivo De Decker ]
  * New upstream release.
  * Remove the part of patch 26_heimdal_compat integrated upstream.

b2237fa... by Jelmer Vernooij on 2014-01-24

Import patches-unapplied version 2:4.1.4+dfsg-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cd8049b2fd5b27d6928b7220733a6b1398a3236d

New changelog entries:
  * Move samba.dckeytab module to samba package, as it relies on hdb.
    Closes: #736405, #736430

cd8049b... by Jelmer Vernooij on 2014-01-18

Import patches-unapplied version 2:4.1.4+dfsg-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8a973d2693b6e451e3540b911b8d0a9170558c2e

New changelog entries:
  [ Jelmer Vernooij ]
  * Depend on newer version of ctdb, as Samba won't build against older
    versions without --enable-old-ctdb.
  * Bump standards version to 3.9.5 (no changes).
  * Move libpac, db_glue and hdb module from samba-libs to samba package
    to reduce size and dependency set of libs package.
  * Fix compatibility with newer versions of the Heimdal HDB API.
    + Update 26_heimdal_compat: Fix initialization of HDB plugin. Thanks Jeff
      Clark. Closes: #732342
    + Add dependency on specific version of the Heimdal HDB API.
      Closes: #732344
  [ Steve Langasek ]
  * dhcp3-client is superseded by dhcp-client; update the references in
    the package. Closes: #736070.
  * Move the dhcp client hook from /etc/dhcp3 to /etc/dhcp.
    Closes: #649100.
  * debian/bin/xsltproc: don't use $FAKETIME as the variable name in our
    wrapper script, this seems to make faketime unhappy.

8a973d2... by Ivo De Decker <email address hidden> on 2014-01-18

Import patches-unapplied version 2:4.1.4+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0d302176171b82fb3ff343d7d6e2720c8d6f711c

New changelog entries:
  * New upstream release.
  * Update version of talloc build-deps to 2.0.8.
  * python-samba: add depends on python-ntdb.

0d30217... by Ivo De Decker <email address hidden> on 2013-12-27

Import patches-unapplied version 2:4.1.3+dfsg-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1482b802bf443b94e633b8e1f4205f7c24b06a2b

New changelog entries:
  * Add debug symbols for all binaries to samba-dbg. Closes: #732493
  * Add lintian overrides for empty prerm scripts.

1482b80... by Ivo De Decker <email address hidden> on 2013-12-09

Import patches-unapplied version 2:4.1.3+dfsg-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: ee0c78ccdc4c31a95c42db84f84154c66a1503c9

New changelog entries:
  [ Jelmer Vernooij ]
  * New upstream release.
   + Drop 0002-lib-replace-Allow-OS-vendor-to-assert-that-getpass-i.patch:
     upstream no longer uses getpass.
  * Add source dependency on libntdb1, and stop passing --disable-ntdb,
    which has been removed.
  * Remove handling for SWAT, which is no longer shipped upstream.
  * Split VFS modules out from samba-libs into a separate binary
    package.
  * Move service and process_model modules from the samba-libs to the
    samba package. Prevents dependencies on libkdc2-heimdal and
    libhdb9-heimdal.
  [ Ivo De Decker ]
  * Add build-dep on python-ntdb.
  * Add build-dep on libncurses5-dev.
  * Add depends on python-ntdb to samba.
  * New upstream release.
  [ Steve Langasek ]
  * Check for alternative's presence before calling update-alternatives
    --remove-all, instead of silently ignoring all errors from
    update-alternatives.
  [ Debconf translations ]
  * Spanish (Javier Fern├índez-Sanguino). Closes: #731800

ee0c78c... by Ivo De Decker <email address hidden> on 2013-12-09

Import patches-unapplied version 2:4.0.13+dfsg-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8203473f07007c2d043e760725262ebac78ea873

New changelog entries:
  [ Steve Langasek ]
  * Move update-alternatives upgrade removal handling to the postinst, where
    it belongs. Closes: #730090.
  * Really remove all references to encrypted passwords: the
    samba-common.config script still included references, which could cause
    upgrade failures in some cases. Closes: #729167.
  [ Ivo De Decker ]
  * New upstream security release. Fixes:
    - CVE-2013-4408: DCE-RPC fragment length field is incorrectly checked
    - CVE-2012-6150: pam_winbind login without require_membership_of
                     restrictions
  * Add empty prerm scripts for samba and samba-common-bin.prerm, to allow
    upgrades from earlier versions with broken prerm script (bug introduced in
    2:4.0.10+dfsg-3)
  * Don't fail in postinst when removing old alternatives fails.
  [ Jelmer Vernooij ]
  * Fix invocations of 'update-alternatives --remove-all'. Closes: #731192