ubuntu/+source/rhythmbox:debian/experimental

Last commit made on 2016-04-03
Get this branch:
git clone -b debian/experimental https://git.launchpad.net/ubuntu/+source/rhythmbox
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/experimental
Repository:
lp:ubuntu/+source/rhythmbox

Recent commits

6bec5cf... by Andreas Henriksson on 2016-04-02

Import patches-unapplied version 3.3-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 417df3edd05612f264fecf8faeec15f4f9f4e5f9

New changelog entries:
  * Add debian/patches/grilo-0.3.patch from bgo#759589
  * Switch libgrilo-0.2-dev build-dependency to libgrilo-0.3-dev
  * debian/rules: uncomment autoreconf.mk include.

417df3e... by Michael Biebl on 2016-02-02

Import patches-unapplied version 3.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a1fea58a9042efdeb7b2528deb13848b3ffa4919

New changelog entries:
  [ Tim Lunn ]
  * New upstream release 3.3 (closes: #813289)
    + New plugin supporting Android devices via gvfs-mtp
    + Encoding settings are now configurable per device type
    + Encoding settings can force lossless files to be transcoded
  * Bump build-dep on libgtk-3-dev (>= 3.12.0)
  * debian/rhythmbox-plugins.install: Install android plugin
  * d/p/0001-audioscrobbler-Fix-displaying-icon-for-libre.fm.patch: Drop,
    included in new release
  * debian/librhythmbox-core9.symbols: Update with new symbols
  * debian/rules: Remove obsolete --disable-scrollkeeper configure flag
  [ Michael Biebl ]
  * Remove Debian menu entry.

a1fea58... by Iain Lane on 2015-05-06

Import patches-unapplied version 3.2.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8adf42da13aa6d0f292eb58eb5d452228c3cebb0

New changelog entries:
  * debian/control{,.in}: We use python3-gi, change dep
  * Use the adwaita-icon-theme instead of gnome-icon-theme
  * Build with dh-autoreconf for new ports.
  * New upstream release 3.2.1
    + Support for disc and track total tags
    + Soundcloud plugin
    + Ability to clear, re-fetch and manually set cover art using the song
      info window
    + Many style and layout fixes
  * debian/*: Update packaging to reflect SONAME bump from .8 to .9.
  * debian/debian/librhythmbox-core9.symbols: Update with symbol changes in
    this release.
  * debian/rhythmbox-plugins.install: Install the soundcloud plugin.
  * debian/rules: Build with --fail-missing so we always install or explicitly
    exclude everything.
  * debian/patches/0001-audioscrobbler-Fix-displaying-icon-for-libre.fm.patch:
    Take patch from upstream bug to display the correct icon for the libre.fm
    plugin.

8adf42d... by Michael Biebl on 2014-10-01

Import patches-unapplied version 3.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a2c7d39b689be7d437ae61a64a7b19c28cff301d

New changelog entries:
  [ Andreas Henriksson ]
  * Build-depend on libdiscid-dev instead of libdiscid0-dev (Closes: #753636)
  [ Michael Biebl ]
  * New upstream release.
  * Bump Build-Depends on libsecret-1-dev to (>= 0.18) as per configure.ac.
  * Update Homepage: URL.
  * Update symbols file.
  * Install AppData file for Rhythmbox.
  * Install context plugin again. It was removed to avoid mixed linkage of
    gstreamer 0.10 / 1.0 which is no longer a problem.
  * Install style.css which is used by the custom css provider.

a2c7d39... by Emilio Pozuelo Monfort <email address hidden> on 2014-05-25

Import patches-unapplied version 3.0.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 75660f6ab6e007d1dee4e800e793969490d9f514

New changelog entries:
  [ Iain Lane ]
  * Call dh_python3 instead of dh_python2 and pass --no-ext-rename to leave
    the module filenames alone.
  * Update Depends and Build-Depends for py3
  * Have -plugins depend on gir1.2-secret-1 for the magnatune plugin
  [ Emilio Pozuelo Monfort ]
  * New upstream release.
  * debian/librhythmbox-core8.symbols:
    + Update for new symbols.
  * debian/control.in:
    + Update build dependencies.

75660f6... by Andreas Henriksson on 2013-10-17

Import patches-unapplied version 3.0.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d63b70d4c78cba292ee2aa6c5813726b6dda754f

New changelog entries:
  * Add Gstreamer-related GPL exception clause to debian/copyright
  * New upstream release.
  * Bump libdmapsharing-3.0-dev build-dependency to >= 2.9.19
  * Update debian/librhythmbox-core8.symbols with one added symbol.

d63b70d... by Andreas Henriksson on 2013-10-03

Import patches-unapplied version 3.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e552b50c36323adf84f1e975a1fecfa435235805

New changelog entries:
  [ Michael Biebl ]
  * New upstream release.
  * Update librhythmbox-core7 → librhythmbox-core8 for the soname bump.

e552b50... by Emilio Pozuelo Monfort <email address hidden> on 2013-06-02

Import patches-unapplied version 2.99.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9d152a46f127298bdeba5f026cb7eb9455a2e296

New changelog entries:
  * debian/rules:
    + Use DEB_DH_INSTALL_ARGS_rhythmbox-plugins as that's supported
      nowadays.
    + Install the frmradio plugin on !linux as it builds there now.
    + Disable the mtpdevice plugin on !linux as it needs gudev or hal
      and we don't build with hal anymore. Closes: #710750.

9d152a4... by Emilio Pozuelo Monfort <email address hidden> on 2013-06-01

Import patches-unapplied version 2.99.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cccca38b90b54ec3e5217ffe3e58dcd7a776da4f

New changelog entries:
  [ Michael Biebl ]
  * Stop building with HAL support on non-Linux. HAL is dead upstream and
    scheduled to be removed.
  [ Emilio Pozuelo Monfort ]
  * Upload to unstable.

cccca38... by Jordi Mallach on 2013-05-28

Import patches-unapplied version 2.99.1-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 0502bcd6726c35630330ea31ca68a035974b74be

New changelog entries:
  [ Jean Schurger ]
  * New upstream version.
  * Removed debian/patches/CVE-2012-3355.patch (fixed upstream).
  * Dropped debian/patches/rb-mb5.patch (New 'audiocd' plugin code doesn't rely
    on libmusicbrainz, making this patch obsolete).
  * Updated dependencies according to configure.in:
    - libtotem-plparser-dev
    - libgrilo-0.2-dev replaces libgrilo-0.1-dev
  * Bump Standards-Version to 3.9.4.
  * Updated Vcs-Svn.
  * Added symbols file for librhythmbox-core6.
  * Temporarly disable webkit support to prevent mixed gst 0.10 / 1.0 linkage.
    - debian/patches/00_no_webkit_no_context_pane.patch
    - debian/rules: --without-webkit
    - debian/rhythmbox-plugins.install: do not try to install 'context' plugin
  * debian/control.in
    - Dropped 'gconf' build dependency it's not used anymore.
    - Dropped 'libmusicbrainz5' build dependency. It was introduced
      by the 'rb-mb5.patch'.
      Previous 'libmusicbrainz4' build dependency (before applying
      'rb-mb5.patch') is not needed anymore. (New 'audiocd' plugin code
      doesn't rely on libmusicbrainz).
  * New upstream version.
  * Removed debian/patches/00_no_webkit_no_context_pane.patch as it have
    been applied upstream.
  * debian/control.in: (according to configure.ac)
    - Updated libdmapsharing-3.0 build dependency to 2.9.16.
    - Removed libgnome-keyring-dev build dependency.
    - Added libsecret-1-dev build dependency.
    - Migrated from libgstreamer0.10 to libgstreamer1.0.
  * debian/rules:
    - Disabled visualizer as we cannot install 'libmx-1.0-2' right now.
    - Don't disable webkit anymore as the gst 0.10 / 1.0 linkage problem
      have been fixed upstream.
  * debian/librhythmbox-core7: Bumped symbols file version (previous one
    was librhythmbox-core6 but never released).
  [ Jeremy Bicha ]
  * debian/control.in:
    - Bump minimum GTK, glib, and clutter
    - Drop obsolete avahi dependencies
    - Build-depend on yelp-tools instead of gnome-doc-tools
  * debian/rhythmbox-data.install:
    - Install help from new location
  [ Jordi Mallach ]
  * Bump to debhelper compat v9.
  * Pass -c4 to dpkg-gensymbols.
  * Update symbols file.