ubuntu/+source/rabbitmq-server:applied/debian/buster

Last commit made on 2018-10-30
Get this branch:
git clone -b applied/debian/buster https://git.launchpad.net/ubuntu/+source/rabbitmq-server
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/buster
Repository:
lp:ubuntu/+source/rabbitmq-server

Recent commits

a9c0f09... by Thomas Goirand <email address hidden> on 2018-10-30

Import patches-applied version 3.7.8-4 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 46780ccbc183f5a726fe6687c11b6b86f9a51c33
Unapplied parent: 1fee780529c1858a0422869d8156c69091319550

New changelog entries:
  * Remove Elixir version patch.
  * Build-depends on Elixir 1.6.6.

1fee780... by Thomas Goirand <email address hidden> on 2018-10-30

Import patches-unapplied version 3.7.8-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2a4d03f736a38fddf6c3d85bccde17813c40c11c

New changelog entries:
  * Remove Elixir version patch.
  * Build-depends on Elixir 1.6.6.

46780cc... by Thomas Goirand <email address hidden> on 2018-10-29

Import patches-applied version 3.7.8-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 924f6d7ced961fa2824760bd116c11270236401d
Unapplied parent: aadbc79529c5d04d1a2e82a29b522a3586586ffa

New changelog entries:
  * Remove $LANG wrapper hack.
  * Wrap rabbitmqctl to set $LANG and avoid warning.

2a4d03f... by Thomas Goirand <email address hidden> on 2018-10-29

Import patches-unapplied version 3.7.8-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2621fb36121d62516855c169e2b96592d2013c32

New changelog entries:
  * Remove $LANG wrapper hack.
  * Wrap rabbitmqctl to set $LANG and avoid warning.

aadbc79... by Thomas Goirand <email address hidden> on 2018-10-29

Allow using Elixir 1.6.5

Gbp-Pq: allow-using-elixir-1.6.5.patch.

924f6d7... by Thomas Goirand <email address hidden> on 2018-10-24

Import patches-applied version 3.7.8-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 8d913632df57dded5b4f1af694164765c1588e86
Unapplied parent: 303a5634c08ca2db17ded477b213ac727b819e88

New changelog entries:
  [ Daniel Baumann ]
  * Updating vcs fields.
  * Updating copyright format url.
  * Updating maintainer field.
  * Running wrap-and-sort -bast.
  * Updating standards version to 4.0.0.
  * Removing gbp.conf, not used anymore or should be specified in the
    developers dotfiles.
  * Correcting permissions in debian packaging files.
  * Updating standards version to 4.0.1.
  * Deprecating priority extra as per policy 4.0.1.
  * Updating standards version to 4.1.0.
  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/changelog: Remove trailing whitespaces
  * d/control: Use <email address hidden> as maintainer
  [ Thomas Goirand ]
  * New upstream release:
    - Fix FTBFS with newer Erlang (Closes: #910623).
  * Fix the way to calculate upstream VERSION in debian/rules.
  * Switched rabbitmq-server.service to type notify, and other minor changes
    in this file (Closes: #812342), do not wait for timeout on shutdown either
    (Closes: #902136).
  * Updated debian/control for this release.
  * Bumped debhelper to 10.
  * Standards-Version is now 4.2.1.
  * Add patch to accept Elixir 1.6.5.
  * Also package manpages.

2621fb3... by Thomas Goirand <email address hidden> on 2018-10-24

Import patches-unapplied version 3.7.8-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: be2ea2d7e0c7d9091a1b1733bddcb014fad243a6

New changelog entries:
  [ Daniel Baumann ]
  * Updating vcs fields.
  * Updating copyright format url.
  * Updating maintainer field.
  * Running wrap-and-sort -bast.
  * Updating standards version to 4.0.0.
  * Removing gbp.conf, not used anymore or should be specified in the
    developers dotfiles.
  * Correcting permissions in debian packaging files.
  * Updating standards version to 4.0.1.
  * Deprecating priority extra as per policy 4.0.1.
  * Updating standards version to 4.1.0.
  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/changelog: Remove trailing whitespaces
  * d/control: Use <email address hidden> as maintainer
  [ Thomas Goirand ]
  * New upstream release:
    - Fix FTBFS with newer Erlang (Closes: #910623).
  * Fix the way to calculate upstream VERSION in debian/rules.
  * Switched rabbitmq-server.service to type notify, and other minor changes
    in this file (Closes: #812342), do not wait for timeout on shutdown either
    (Closes: #902136).
  * Updated debian/control for this release.
  * Bumped debhelper to 10.
  * Standards-Version is now 4.2.1.
  * Add patch to accept Elixir 1.6.5.
  * Also package manpages.

303a563... by Thomas Goirand <email address hidden> on 2018-10-24

Allow using Elixir 1.6.5

Gbp-Pq: allow-using-elixir-1.6.5.patch.

8d91363... by Thomas Goirand <email address hidden> on 2017-06-28

Import patches-applied version 3.6.10-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 757d4210f7d0a366dc9bd396593a2f6517b22138
Unapplied parent: be2ea2d7e0c7d9091a1b1733bddcb014fad243a6

New changelog entries:
  * New upstream release (Closes: #863586), fixing multiple issues:
    - CVE-2017-4965: XSS vulnerabilities in management UI
    - CVE-2017-4966: authentication details are stored in browser-local storage
      without expiration
    - CVE-2017-4967: XSS vulnerabilities in management UI

be2ea2d... by Thomas Goirand <email address hidden> on 2017-06-28

Import patches-unapplied version 3.6.10-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f4262f1d8d1515da39ae2aa8f6f6c8d48ae1e362

New changelog entries:
  * New upstream release (Closes: #863586), fixing multiple issues:
    - CVE-2017-4965: XSS vulnerabilities in management UI
    - CVE-2017-4966: authentication details are stored in browser-local storage
      without expiration
    - CVE-2017-4967: XSS vulnerabilities in management UI