ubuntu/+source/quassel:applied/ubuntu/precise-devel

Last commit made on 2014-11-17
Get this branch:
git clone -b applied/ubuntu/precise-devel https://git.launchpad.net/ubuntu/+source/quassel
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/precise-devel
Repository:
lp:ubuntu/+source/quassel

Recent commits

ccef3cb... by Felix Geyer on 2014-11-04

Import patches-applied version 0.8.0-0ubuntu1.2 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 702597a30c5ab8b643fa3b07cd19c2c7a9306988
Unapplied parent: 10fe7fb21a54a40f3b3d6832e798dd547d398828

New changelog entries:
  * SECURITY UPDATE: out-of-bounds read in ECB Blowfish decryption
    - debian/patches/CVE-2014-8483.patch: backport upstream patch
    - CVE-2014-8483
    - LP: #1388333

10fe7fb... by Felix Geyer on 2014-11-04

[PATCH] Check for invalid input in encrypted buffers

Gbp-Pq: CVE-2014-8483.patch.

f460e8c... by Felix Geyer on 2014-11-04

[PATCH] Make sure that clients can't access buffers belonging to

Gbp-Pq: CVE-2013-6404.patch.

c320239... by Felix Geyer on 2014-11-04

[PATCH 2/2] Allow the core to use expired certificates.

Gbp-Pq: 0002-Allow-the-core-to-use-expired-certificates.patch.

6ac5559... by Felix Geyer on 2014-11-04

[PATCH 1/2] Support intermediate CA certificates.

Gbp-Pq: 0001-Support-intermediate-CA-certificates.patch.

649ae75... by Felix Geyer on 2014-11-04

kubuntu_02_enable_message_indicator.diff

No DEP3 Subject or Description header found

Gbp-Pq: kubuntu_02_enable_message_indicator.diff.

869f5d2... by Felix Geyer on 2014-11-04

kubuntu_01_default_network_channel.patch

No DEP3 Subject or Description header found

Gbp-Pq: kubuntu_01_default_network_channel.patch.

d9f387e... by Felix Geyer on 2014-11-04

Import patches-unapplied version 0.8.0-0ubuntu1.2 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 3550f17462556d24e1c889520e3d38b524b2e649

New changelog entries:
  * SECURITY UPDATE: out-of-bounds read in ECB Blowfish decryption
    - debian/patches/CVE-2014-8483.patch: backport upstream patch
    - CVE-2014-8483
    - LP: #1388333

702597a... by Felix Geyer on 2014-01-16

Import patches-applied version 0.8.0-0ubuntu1.1 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 7b0d7ff9449140f86c60153310c2b4dd54ca84ad
Unapplied parent: af719ba7dec56c8f7e235d65c7cb6c0dbf576a35

New changelog entries:
  * SECURITY UPDATE: clients can access backlogs belonging to other users
    - debian/patches/CVE-2013-6404.patch: add upstream patch
    - CVE-2013-6404
    - LP: #1255362

3550f17... by Felix Geyer on 2014-01-16

Import patches-unapplied version 0.8.0-0ubuntu1.1 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: dd21f1036551679d10802eead66584ef0f270cd1

New changelog entries:
  * SECURITY UPDATE: clients can access backlogs belonging to other users
    - debian/patches/CVE-2013-6404.patch: add upstream patch
    - CVE-2013-6404
    - LP: #1255362