ubuntu/+source/qtwebkit-source:ubuntu/oneiric-devel

Last commit made on 2011-09-19
Get this branch:
git clone -b ubuntu/oneiric-devel https://git.launchpad.net/ubuntu/+source/qtwebkit-source
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/oneiric-devel
Repository:
lp:ubuntu/+source/qtwebkit-source

Recent commits

9eae9f1... by Felix Geyer on 2011-09-19

Import patches-unapplied version 2.2~2011week36-0ubuntu1 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: ae78fe4307acc630c96aa498e0e7ca4881481ed3

New changelog entries:
  * New upstream release (2.2.0 RC1).
    - Drop kubuntu_fix_jit_warnings_i386.diff, applied upstream.
    - Fixes crash in amarok wikipedia applet. (LP: #846709)
  * Add Vcs-Bzr control field.

ae78fe4... by Rohan Garg on 2011-08-30

Import patches-unapplied version 2.2~2011week34-0ubuntu1 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: 2a05ce38604a1f5b969e68aa89c697602a9e4276

New changelog entries:
  * New upstream release (LP: #844792)
    - Drop kubuntu_gstreamer_build_fix.diff, applied upstream
    - Refresh stabs_format_debug_info.diff
    - Use WTF_USE_GSTREAMER instead of USE_GSTREAMER

2a05ce3... by Steve Langasek on 2011-08-15

Import patches-unapplied version 2.2~2011week27-0ubuntu2 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: 390f6d81dccf3cf50e16ad6b8bd1656654079d18

New changelog entries:
  * Build for multiarch, required since qt4-x11 has switched over.

390f6d8... by Felix Geyer on 2011-07-20

Import patches-unapplied version 2.2~2011week27-0ubuntu1 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: a5e47f007ba069472a261d96ddc94e710e03527c

New changelog entries:
  * Merge from Debian vcs, remaining changes:
    - Rename source package to qtwebkit-source.
    - Use the lzma dh sequence.
    - Add qwebview designer plugin.
    - Drop qtmobility-dev build-dependency and disable geolocation.
    - Make libqtwebkit-dev depend on ${shlibs:Depends} as we are shipping
      the qwebview designer plugin.
  * Drop transitional package libqtwebkit4-declarative.
  * New upstream release.
  * Refresh patches.
  * Drop kubuntu_01_include_files.diff, not needed anymore.
  * Disable linux_amd64_no_overcommit.diff, fixed upstream.
  * Disable 05_sparc_unaligned_access.diff, 06_kfreebsd_strnstr.diff and
    09_hurd.diff for now, architectures not supported on Ubuntu.
  * Use the GStreamer multimedia backend.
    - Build-depend on libgstreamer0.10-dev and
      libgstreamer-plugins-base0.10-dev.
  * Remove upstream Source/Makefile which makes dh_auto_clean fail.
  * Fix include and lib path in qtdesigner-qwebview/qwebview.pro.
  * Add README.source explaining how to create a new upstream tarball.
  * Add kubuntu_fix_jit_warnings_i386.diff to fix FTBFS on i386 due to -Werror.
  [ Pino Toscano ]
  * Use wildcard architectures:
    - !kfreebsd-i386 !kfreebsd-amd64 !hurd-i386 -> linux-any
    - kfreebsd-i386 kfreebsd-amd64 hurd-i386 -> !linux-any
  * Add defines_qt_webkit.diff to display correctly documentation in Qt Creator
    Help plugin. (Closes: #619443)
  * Bump Standards-Version to 3.9.2 (no changes needed).
  * New upstream release.
  [ José Manuel Santamaría Lema ]
  * Add linux_amd64_no_overcommit.diff to avoid crashes on amd64 with less than
    3 or 4GB of RAM. Thanks to Felix Geyer for his help with this issue.
  [ Fathi Boudra ]
  * Ship libqtwebkit-qmlwebkitplugin package. (Closes: #601650)
  * Drop webcore_qtplatformplugin_createfullscreenvideohandler_ftbfs.patch.
  * Rename 08_powerpc_s390_no_gc_sections.diff to no_gc_sections.diff and
    extend it to cover armel and mip* as well. Full list: powerpc, s390, arm*,
    mips*.
  * Really replace -g with -gstabs on s390, mips, mipsel and armel. Previously
    it used to grab -g from environment CXXFLAGS. Hopefully this will truly
    fix OOMs when linking. (Closes: #618325)
  * Urgency=high, transition stuff.
  [ Pino Toscano ]
  * Build-depend on libphonon-dev on non-Linux architectures. (Closes: #617656)
  [ Modestas Vainius ]
  * Build with -gstabs on armel (Closes: #618325). Added to the
    stabs_format_debug_info.diff patch (former
    07_s390_stabs_format_debugging_information.diff).
  * Urgency=high, transition stuff.
  * New upstream release - upload to Sid.
  * Add webcore_qtplatformplugin_createfullscreenvideohandler_ftbfs.patch to
    work around the build failure.
  * Switch to Qt MultimediaKit for the video support (instead of Phonon), build
    depends on QtMultimediaKit.
  * Enable geolocation support: build depends on QtLocation and define
    ENABLE_GEOLOCATION.
  * New upstream release: switch to Qt WebKit 2.1 branch.
  [ Fathi Boudra ]
  * Update debian/control:
    - build depends on Qt 4.7.0 beta 2.
  * Update debian/rules:
    - pass DEFINES+=ENABLE_VIDEO to build with audio/video support.
  * Update libqtwebkit-dev.install file: add qwebkitplatformplugin.h.
  [ Modestas Vainius ]
  * Fix debian/control Vcs fields to point to the new location.
  [ Pino Toscano ]
  * Add patch 09_hurd.diff to fix compilation on Hurd.

a5e47f0... by Felix Geyer on 2011-03-08

Import patches-unapplied version 2.1~really2.0.2-0ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: f3aadb9b53e3f87698119a5f36d29e311d9fb4a9

New changelog entries:
  * New upstream release.
  * Adapt 04_enable_debug_information.diff to new upstream version.
  * Add the QtDesigner qwebview plugin. (LP: #674367)

f3aadb9... by Felix Geyer on 2011-02-27

Import patches-unapplied version 2.1~really2.0.1-0ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: cf257a044d076ea4400a832efa2c1ed8d1be3d16

New changelog entries:
  * Revert to package version 2.0.0-0ubuntu1. QtWebkit 2.1 is only supported
    on Symbian. (LP: #710582)
  * New upstream version 2.0.1.
  * Rename debian-changes-2.0.0-0ubuntu1 to kubuntu_01_include_files.diff and
    strip auto-generated files from the patch.
  * Use the lzma dh sequence.
  * Drop kubuntu_01_phonon.diff, pass DEFINES+=ENABLE_VIDEO to qmake instead.

cf257a0... by Jonathan Riddell on 2011-01-20

Import patches-unapplied version 2.1~git20110120-0ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: eb07892f4d738baec59b7dec42270ef95d48fe21

New changelog entries:
  * New upstream snapshot
  * Trimmed off unnecessary directories to make tar a sane size
  * Don't run dh_auto_build

eb07892... by Rico Tzschichholz on 2010-12-04

Import patches-unapplied version 2.1~git20101116-0ubuntu9 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: cb381775d595538e95b9d49edef23ddb6c3bb0eb

New changelog entries:
  * Fix installation destination of qt_webkit_version.pri (LP: #681345)

cb38177... by Jonathan Riddell on 2010-11-27

Import patches-unapplied version 2.1~git20101116-0ubuntu8 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 1a266fb282597a6632990d45a6037239f1f0bca7

New changelog entries:
  * Install headers to right location, sigh

1a266fb... by Jonathan Riddell on 2010-11-27

Import patches-unapplied version 2.1~git20101116-0ubuntu7 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 5da1c3e7d77309370460bae82e3553f52903291b

New changelog entries:
  * Move headers to right directory