ubuntu/+source/qtscriptgenerator:ubuntu/trusty

Last commit made on 2012-05-02
Get this branch:
git clone -b ubuntu/trusty https://git.launchpad.net/ubuntu/+source/qtscriptgenerator
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/trusty
Repository:
lp:ubuntu/+source/qtscriptgenerator

Recent commits

df1c74e... by Modestas Vainius <email address hidden> on 2012-05-01

Import patches-unapplied version 0.2.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ad96037c06a8b041dbe1a26f5e18ab9dd60fcbbb

New changelog entries:
  * New upstream release.
  * Update upstream_support_later_phonon.diff patch to support Phonon 4.6.
    Thanks to Felix Geyer. (Closes: #662771)
  * Bump debhelper compat level to 9 in order to gain build flag support.
  * Remove custom build flag management code from debian/rules.
  * Bump Standards-Version to 3.9.3: no changes needed.
  * Add multi-arch support:
    - build depend on multi-arch aware Qt 4.8.0;
    - switch libqtscript4-qtbindings to Architecture:any and mark it
      Multi-Arch:same;
    - mark all bindings package Multi-Arch: same and add to ${misc:Pre-Depends}
      to their Pre-Depends.
    - install plugins into multiarch path (/usr/lib/<arch>/qt4/).
  * Fix package descriptions. Thanks to Martin Eberhard Schauer for the patch.
    (Closes: #634171)
  * Fix FTBFS with gcc 4.7 (patch upstream_gcc4.7_fix.diff).

ad96037... by Modestas Vainius <email address hidden> on 2011-04-24

Import patches-unapplied version 0.1.0+git20101026+8b191fbc-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 73e457e6a5edb2da9cbb4925552f4a9c7e2bf716

New changelog entries:
  * debian_simple_top_makefile.diff: make generated_cpp depend on typesystem
    xml files.
  * Add upstream_arm_fix_ftbfs.diff patch to fix FTBFS on arm* architectures.

73e457e... by Modestas Vainius <email address hidden> on 2011-04-23

Import patches-unapplied version 0.1.0+git20101026+8b191fbc-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 13cbecc6c46dd330f99218138e7431f09de371f1

New changelog entries:
  * New upstream development snapshot to support Qt 4.7.
  * Remove DMUA field from debian/control. I'm a DD now.
  * Switch my e-mail address to @debian.org one.
  * Git repository moved to my new DD account on alioth. Change Vcs fields in
    debian/control accordingly.
  * Build depend on libqtwebkit-dev | libqt4-dev (<< 4:4.7.0). Also steal
    debian_webkit_phonon_include.diff from kubuntu to enable building with Qt
    4.7. Fixes FTBFS. (Closes: #618172)
  * Drop topgit support.
  * Move patches out of subdirectories.
  * Switch source package to 3.0 (quilt).
  * Bump Standards-Version to 3.9.2: no changes needed.
  * Drop upstream_gcc4.4_ftbfs_fix.diff, merged upstream.
  * Adapt debian_drop_extra_linkage_fix.diff to upstream changes.
  * Add patch upstream_support_later_phonon.diff which fixes building against
    system Phonon 4.5.0.
  * Reimplement top Makefile in the parallel-safe manner (patch
    debian_simple_top_makefile.diff) and pass --parallel to dh.
  * Add doc-base control file for libqtscript4-doc.

13cbecc... by Modestas Vainius <email address hidden> on 2009-05-09

Import patches-unapplied version 0.1.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e6e56c75b9f5c23fc7443ad0bdc9a55ca96937e2

New changelog entries:
  * Fix noopt check.
  * Export QMAKE_TARGET.
  * Use dh_makeshlibs --remaining-packages instead of the previous hack,
    hence depend on debhelper 7.2.7.
  * Bump Standards-Version to 3.8.1. No changes needed.
  * New patches:
    - general/memory_alignment_fix.diff - some unaligned memory fixes. It
      should fix FTBFS on armel/sparc (Closes: #525980).
    - general/gcc4.4_ftbfs_fix.diff - fixes FTBFS with gcc 4.4
      (Closes: #526167).
    - debian/drop_extra_linkage_fix - do not link with unnecessary libraries.
  * Use new quilt dh sequence module, build depend on quilt (>= 0.46-7~).
  * Backports friendly debhelper build dependency versioning.
  * Update debian/README.source: build branch merged into master.
  * Improve simple_top_makefile patch:
    - build process depends on existance of plugins;
    - update timestamps whenever possible to avoid unnecessary rebuilds.

e6e56c7... by Modestas Vainius <email address hidden> on 2009-04-25

Import patches-unapplied version 0.1.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fe401655d7482432a3b3a06d5ee89848295eb986

New changelog entries:
  * Reenable libqtscript4-phonon, build depend on Qt 4.5.
  * Add notice about Qt 4.5 copyright to debian/copyright.

fe40165... by Modestas Vainius <email address hidden> on 2009-03-07

Import patches-unapplied version 0.1.0-1 to debian/sid

Imported using git-ubuntu import.