ubuntu/+source/python-qt4:debian/squeeze

Last commit made on 2013-10-19
Get this branch:
git clone -b debian/squeeze https://git.launchpad.net/ubuntu/+source/python-qt4
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/squeeze
Repository:
lp:ubuntu/+source/python-qt4

Recent commits

e44948d... by Scott Kitterman on 2013-08-31

Import patches-unapplied version 4.7.3-1+squeeze1 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 959ffa5c4ce8002127e20a73f2a13cfce1ecc80e

New changelog entries:
  * Add debian/patches/loadUI.diff (Closes: #697348)
    - Code backported from stable (4.9.3) version
    - Thanks to Jerome Kieffer for pointing out the fix and testing it

959ffa5... by Torsten Marek <email address hidden> on 2010-04-18

Import patches-unapplied version 4.7.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0473515141cc5a470db147e45730c68652619c53

New changelog entries:
  * New upstream release
  * Build against Qt 4.6
  * debian/control
    - Bumped build dependency on libqt4-dev to >= 4.6.0

0473515... by Torsten Marek <email address hidden> on 2010-03-26

Import patches-unapplied version 4.7.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1d1d0116eaf025db5cf7e85431d20093f7e948dd

New changelog entries:
  * New upstream release
  * debian/control
    - Bumped build dependency on sip to 4.10.1
  * debian/patches/fix_objdir_dbus_check.diff
    - Removed, fixed upstream
  * debian/rules
    - Upstream changelog has been removed, don't try to install it

1d1d011... by Torsten Marek <email address hidden> on 2010-02-02

Import patches-unapplied version 4.7-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2102839c94be2e58efd9adcd30c0de8b8983b612

New changelog entries:
  * Uploaded new upstream to unstable
    (Closes: #567224, #561878, #564657, 558112)
  * debian/control
    - Bumped standards version to 3.8.4, no changes necessary
  * debian/rules
    - Build rc module for qtdemo.py and don't compress XML files
      (Closes: #558244)
  * debian/README.source
    - Removed, we don't use dpatch anymore
  * debian/patches/{series,htmllinks.diff}
    - Adapted/removed, pyqt4ref.html is not installed into html/
      any more

2102839... by Torsten Marek <email address hidden> on 2010-01-26

Import patches-unapplied version 4.7-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 3c5be4968834750443c068dc0a1664f8c4af2cf8

New changelog entries:
  * New upstream release
  * debian/control
    - Droppend dependency on python-elementtree, package has been removed.
    - Depend on ${sip:Depends} instead of hard-coding sip package version
    - Build-depend on python-sip-dev, sip4 and python-sip4-dev have been
      removed
  * Converted package to source format "3.0 (quilt)"
  * debian/patches/{qreal_float_support,htmllinks}.diff
    - Adapted to quilt
  * debian/patches/debian_configure_changes.diff
    - Partially applied by upstream, only Debian-specific changes remaining
  * debian/rules
    - Remove dpatch handling
    - Add call to dh_sip in binary-common
  * debian/patches/fix_objdir_dbus_check.diff
    - Fix bug in configure that prevented the dbus module from being built

3c5be49... by Michael Casadevall <email address hidden> on 2009-10-07

Import patches-unapplied version 4.6-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e1b2206707256b1f9356c9a542df7bbae8d208ed

New changelog entries:
  [ Torsten Marek ]
  * debian/rules
    - Fix .noinit creation for Python 2.6 by using py_sitename in install-arch-%
  [ Michael Casadevall ]
  * New upstream release
  * debian/control:
    - Updated for new release of sip4

e1b2206... by Torsten Marek <email address hidden> on 2009-08-28

Import patches-unapplied version 4.5.4-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a00a71aaf21ca76c8718e19b74e6c190aa8259f1

New changelog entries:
  [ Torsten Marek ]
  * New upstream release
  * Acknowledge NMU. (Thanks, Bastian!)
    + Closes: #536900
  * debian/patches/05_license_check.dpatch
    - Dropped, fixed in new upstream release
  * debian/control
    - Added conflict with python-qt4-common to python-qt4 (Closes: #536595)
    - Bumped standards version to 3.8.2, no changes necessary
  * debian/rules
    - Fix install-arch to allow parallel builds (Closes: #539053)
  * debian/compat
    - Raise debhelper compatibility level to 7
  [ Michael Casadevall ]
  * Reinstalled uic/widget-plugins at upstream location (Closes: #541475)
    - Adapted debian/rules and python-qt4.install
    - Thanks Didier Raboud for the patch
  * debian/control:
    - Bumped standards version to 3.8.3
    - Add Break: python-kde4 (<< 4:4.2.4) due to ABI change (Closes: #540057)

a00a71a... by Bastian Blank on 2009-07-28

Import patches-unapplied version 4.5.1-1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e76aee1312bdb06bdf44e1b2c81370878faf3f4d

New changelog entries:
  * Non-maintainer upload.
  * Fix license check. (closes: #536900)

e76aee1... by Torsten Marek <email address hidden> on 2009-06-18

Import patches-unapplied version 4.5.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 68ae9f3167f07228236875484cec49e86f1cd9d4

New changelog entries:
  * New upstream bugfix release
  * debian/control
    - Bump all dependencies on sip to 4.8.1
  * New upstream release (Closes: #486931, #480296, #520188)
  * debian/python-qt4.install
    - Install QtScriptTools module
  * debian/rules
    - Don't try to install missing dbus modules for Python 2.6
    - Share configuration options between debug and normal builds
    - Do not link against libGL.so and libGLU.so
  * debian/patches/01_configure.dpatch
    - Updated for qpy support modules
  * debian/patches/02_htmllinks.dpatch
    - Updated
  * debian/patches/04_widget-plugins_location.dpatch
    - Updated
  * debian/control
    - Build-dependencies and dependencies bumped to sip 4.8
    - Removed python-qt4-common, not needed anymore because
      python-qt4-dev does not ship Python files anymore
  * debian/pyuic4
    - Added simple wrapper script for pyuic4

68ae9f3... by Bernd Zeimetz on 2009-04-08

Import patches-unapplied version 4.4.4-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5c03953c18124522cea04fe73bd2843386a53875

New changelog entries:
  * medium urgency as we are fixing a RC bug which makes
    several other packages FTBFS.
  * debian/rules:
    - Prepare build-process for Python 2.6.
    - Install the python-qt4-dbus debug extensions properly again,
      they were forgotten during the migration to python-support.
    - Move pyuic4's widget-plugins directory to
      /usr/share/python-qt4 as the directory must not be a
      namespace package - therefore it doesn't make sense to install
      it within the normal modules directory.
      Thanks to Pierre Chifflier for the bugreport (Closes: #523059).
  * debian/*.install:
    - Handle *-package directories to support Python 2.6.
  * debian/control:
    - Use versioned dependencies on python-qt4-common,
      thanks to Zed Pobre for the bug report (Closes: #505572).
    - pyqt4-dev-tools: make the dependency on python-qt a
      versioned one.
  * debian/patches/04_widget-plugins_location.dpatch:
    - Adding patch to tell pyuic about the new location of the
      widget plugins.
  * debian/control:
    - Switch to python-support, drop all X*-Python fields.
    - Adding myeslf to Uploaders.
  * debian/rules:
    - Avoid all insane hacks which were messing with
      /var/lib/python-support. This was prone to fail in any case,
      and will result in FTBFS as soon as python-support 1.0 will
      hit unstable. This should also fix #512739 as python-support
      uses triggers, so the broken 'local' file (which was installed
      via python-central from an old package) will be gone.
      (Closes: #512739)
    - Create debian/python-qt4-dbus.install on the fly as
      directories may change depending on the used python-support
      version.
  * debian/README.source, debian/pycompat:
    - Dropping file, not needed anymore.
  * debian/python-qt4-dbus.install: dropping file, see above.
  * debian/pyversions: create file, build for Python 2.4 and later.
  [ Sandro Tosi ]
  * debian/manpages/pyuic4.1
    - fixed minor error; thanks to Ori Avtalion for the report; Closes: #518957
  [ Michael Casadevall ]
  * Moved package from experimental to unstable
  * debian/control:
    - Updated my email to <email address hidden>
    - Bumped standards version to 3.8.1
    - Corrected section mismatches
      - Changed python-qt-*-dbg section to debug
    - Tightened build-deps to match normal dependences.
      - sip4 versioned to build against 4.7.9 matching the Depends