ubuntu/+source/pulseaudio:debian/sid

Last commit made on 2020-02-06
Get this branch:
git clone -b debian/sid https://git.launchpad.net/ubuntu/+source/pulseaudio
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/sid
Repository:
lp:ubuntu/+source/pulseaudio

Recent commits

4821cee... by Felipe Sateler on 2020-02-05

Import patches-unapplied version 13.0-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 88ef963bf8f672fb37219aef257045d9fdf4a925

New changelog entries:
  * Fix removal of 00-disable-autospawn.conf.
    The autoremoval script was wrongly put into the pulseaudio package, while
    it should have been in the libpulse0 package. Moreover, the version specified
    was wrong (set at 12.2 instead of 13.0) (Closes: #950413)

88ef963... by Felipe Sateler on 2020-01-31

Import patches-unapplied version 13.0-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 49067f186372555c3d29a656dbd01e48e6b099dd

New changelog entries:
  [ Steve Langasek ]
  * Make autopkgtests cross-test-friendly.
    In Ubuntu, we are in the process of moving the i386 architecture to a
    compatibility-only layer on amd64, and therefore we are also moving our
    autopkgtest infrastructure to test i386 binaries in a cross-environment.
    This requires changes to some tests so that they are cross-aware and can do
    the right thing.
    The pulseaudio tests currently fail in this environment, because they are
    build tests that do not invoke the toolchain in a cross-aware manner. I've
    verified that the attached patch lets the tests successfully build (and run)
    i386 tests on an amd64 host.
    Note that upstream autopkgtest doesn't currently set DEB_HOST_ARCH so this
    is a complete no-op in Debian for the moment. Support for cross-testing in
    autopkgtest is currently awaiting review at
    https://salsa.debian.org/ci-team/autopkgtest/merge_requests/69 and once
    landed, will still have no effect unless autopkgtest is invoked with a '-a'
    option. So this change should be safe to land in your package despite this
    not being upstream in autopkgtest. (Closes: #946375)
  [ Felipe Sateler ]
  * Enable autospawn automatically on sysvinit systems.
    Instead of having a default configuration, make pulseaudio default to
    disabled, and then have a sysvinit service to reenable the autospawn
    setting
    (Closes: #923203)
  * Allow installing pulseaudio with elogind.
    Because we now autospawn with non-systemd, we can use the weaker guarantees
    provided by elogind
    (Closes: #923201)
  * Drop postinst snippet dealing with old upgrades.
    5.0 is already in oldoldstable so no need to carry it anymore
  * Set upstream metadata fields: Name (from ./configure), Repository,
    Repository-Browse.
    Fixes: lintian: upstream-metadata-file-is-missing
    See-also: https://lintian.debian.org/tags/upstream-metadata-file-is-missing.html
  * Bump Standards-Version.
    No changes needed
  * Enable the systemd user units dynamically, not statically.
    Now that there is support for systemd --user in debhelper, lets use that to
    enable the user units instead of having a global link (Closes: #943999)

49067f1... by Felipe Sateler on 2019-10-25

Import patches-unapplied version 13.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fa96ccf619c8fea1cb79c08be4e08ba3e03b69b7

New changelog entries:
  * qpaeq: migrate to python3.
    Patch picked from Fedora and cleaned up for upstream inclusion.
    (Closes: #937338)
  * d/control: Remove duplicate Priority: field
  * Add dev package information to symbols file.
    Thanks lintian tag symbols-file-missing-build-depends-package-field
  * Pick upstream patch disabling flat-volumes by default.
    (Closes: #837637, #541538)

fa96ccf... by Felipe Sateler on 2019-10-06

Import patches-unapplied version 13.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 7bf950d95e3534a7f081bb34af93b509aa19428e

New changelog entries:
  [ Andreas Henriksson ]
  * Drop obsolete gconf build-dependency.
    The package already builds with --disable-gconf configure flag.
    (Closes: #941794)
  [ Felipe Sateler ]
  * Use https URI in Homepage field.
  * Bump Standards-Version

7bf950d... by Sebastien Bacher on 2019-09-16

Import patches-unapplied version 13.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: aebc6911304abe41f6d8bc7b76b4628e97711512

New changelog entries:
  * New upstream version
  * debian/pulseaudio-utils.install:
    - install the new pa-info utility

aebc691... by Felipe Sateler on 2019-08-22

Import patches-unapplied version 12.99.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 889ecd90357a3b39970cda361dd4c95409743397

New changelog entries:
  * New upstream version 12.99.2
    - Fixes FTBFS with gcc-9. (Closes: #925807)
    - Drop all patches, applied upstream
    - Add new symbols added to libpulse0
  * Remove autopoint override.
    Since version 12, regular intltool is used, not gtkdocize
  * Bump debhelper compat level to 12

889ecd9... by Felipe Sateler on 2019-08-05

Import patches-unapplied version 12.2-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 187cf2326922ef53a4fa28746d9c18c4b9bc1714

New changelog entries:
  * Pick upstream patch fixing mute state restoring (Closes: #913102)

187cf23... by Felipe Sateler on 2019-02-14

Import patches-unapplied version 12.2-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c6abd84032862010a52b7e9fba8775a48b051fb5

New changelog entries:
  [ Jan Graichen ]
  * Load correct profile for Arctis 7 and Arctis Pro headsets.
    (Closes: #918067)

c6abd84... by Felipe Sateler on 2019-01-16

Import patches-unapplied version 12.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b2c5d06ce7e94e8c2d1d53c1a06fbfb449a92e96

New changelog entries:
  [ Joseph Herlant ]
  * d/changelog & d/control: Remove trailing whitespaces
  [ Felipe Sateler ]
  * Backport upstream patches for better Arctis headset support
    (Closes: #918067)
  * Ship link from /etc/alsa/conf.d/pulse.conf to /usr/share/alsa/alsa.conf.d/pulse.conf.
    Upstream alsa decided to stop supporting the /usr path (Closes: #915696)
  * Don't compile with -ffast-math.
    This flag results in calls to (at least) isfinite() and isnan() becoming
    skipped, and a constant false returned. (Closes: #916504)

b2c5d06... by Felipe Sateler on 2018-09-14

Import patches-unapplied version 12.2-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 619b3e8a3467f7a0bfc60b7ac2ae5326e7f67661

New changelog entries:
  [ Joseph Herlant ]
  * Allow rounding without having to allow a random number of errors in
    tests/volume-test.c (Closes: #906504)
  [ Felipe Sateler ]
  * Bump debhelper compat level to 11.
    Also switch to the new debhelper-compat virtual package
  * Bump Standards-Version