ubuntu/+source/pulseaudio:applied/debian/experimental

Last commit made on 2020-02-20
Get this branch:
git clone -b applied/debian/experimental https://git.launchpad.net/ubuntu/+source/pulseaudio
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/experimental
Repository:
lp:ubuntu/+source/pulseaudio

Recent commits

3fdf334... by Sebastien Bacher on 2020-02-20

Import patches-applied version 13.99.1-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 311ad8464858860b896052a9382f2bafce7500bf
Unapplied parent: 0204a2d3be508617d0b59df5042a5c383f644048

New changelog entries:
  * New upstream rc version, including those changes:
    - default sink selection for a better user experience, ALSA UCM support,
      disabling flat volumes by default, stream rescue moving to core,
      GStreamer-based RTP support, and qpaeq moving to Python 3.
  * debian/control:
    - B-D on libgstreamer1.0-dev and libgstreamer-plugins-base1.0-dev,
      needed to enable the gstreamer based RTP support
  * debian/patches/qpaeq-Drop-unused-imports.patch,
    debian/patches/qpaeq-use-python3-instead-of-python-2.patch,
    debian/patches/daemon-conf-disable-flat-volumes-by-default.patch:
    - dropped the changes included in the new version

0204a2d... by Sebastien Bacher on 2020-02-20

Disable autospawn by default

Gbp-Pq: disable-autospawn.patch.

51f2ed1... by Sebastien Bacher on 2020-02-20

Import patches-unapplied version 13.99.1-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 4821cee36876f5c8c373a7b3451e796a753992b4

New changelog entries:
  * New upstream rc version, including those changes:
    - default sink selection for a better user experience, ALSA UCM support,
      disabling flat volumes by default, stream rescue moving to core,
      GStreamer-based RTP support, and qpaeq moving to Python 3.
  * debian/control:
    - B-D on libgstreamer1.0-dev and libgstreamer-plugins-base1.0-dev,
      needed to enable the gstreamer based RTP support
  * debian/patches/qpaeq-Drop-unused-imports.patch,
    debian/patches/qpaeq-use-python3-instead-of-python-2.patch,
    debian/patches/daemon-conf-disable-flat-volumes-by-default.patch:
    - dropped the changes included in the new version

311ad84... by Felipe Sateler on 2020-02-05

Import patches-applied version 13.0-5 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 0353e1172c5a883bc7daf6482b0958298bef2b4f
Unapplied parent: 99216ddbe2b0e58b5a9dadbb7e6fbd10ec09eeb1

New changelog entries:
  * Fix removal of 00-disable-autospawn.conf.
    The autoremoval script was wrongly put into the pulseaudio package, while
    it should have been in the libpulse0 package. Moreover, the version specified
    was wrong (set at 12.2 instead of 13.0) (Closes: #950413)

4821cee... by Felipe Sateler on 2020-02-05

Import patches-unapplied version 13.0-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 88ef963bf8f672fb37219aef257045d9fdf4a925

New changelog entries:
  * Fix removal of 00-disable-autospawn.conf.
    The autoremoval script was wrongly put into the pulseaudio package, while
    it should have been in the libpulse0 package. Moreover, the version specified
    was wrong (set at 12.2 instead of 13.0) (Closes: #950413)

99216dd... by Felipe Sateler on 2020-02-05

Disable autospawn by default

Gbp-Pq: disable-autospawn.patch.

58d6fc6... by Felipe Sateler on 2020-02-05

daemon-conf: disable flat-volumes by default

Gbp-Pq: daemon-conf-disable-flat-volumes-by-default.patch.

8fcd720... by Felipe Sateler on 2020-02-05

qpaeq: use python3 instead of python 2

Gbp-Pq: qpaeq-use-python3-instead-of-python-2.patch.

6217387... by Felipe Sateler on 2020-02-05

qpaeq: Drop unused imports

Gbp-Pq: qpaeq-Drop-unused-imports.patch.

0353e11... by Felipe Sateler on 2020-01-31

Import patches-applied version 13.0-4 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: c352325c496332431e0fa205301d7235f3a78675
Unapplied parent: c5a8226d55b55254c55f4fddd2c17684eb660315

New changelog entries:
  [ Steve Langasek ]
  * Make autopkgtests cross-test-friendly.
    In Ubuntu, we are in the process of moving the i386 architecture to a
    compatibility-only layer on amd64, and therefore we are also moving our
    autopkgtest infrastructure to test i386 binaries in a cross-environment.
    This requires changes to some tests so that they are cross-aware and can do
    the right thing.
    The pulseaudio tests currently fail in this environment, because they are
    build tests that do not invoke the toolchain in a cross-aware manner. I've
    verified that the attached patch lets the tests successfully build (and run)
    i386 tests on an amd64 host.
    Note that upstream autopkgtest doesn't currently set DEB_HOST_ARCH so this
    is a complete no-op in Debian for the moment. Support for cross-testing in
    autopkgtest is currently awaiting review at
    https://salsa.debian.org/ci-team/autopkgtest/merge_requests/69 and once
    landed, will still have no effect unless autopkgtest is invoked with a '-a'
    option. So this change should be safe to land in your package despite this
    not being upstream in autopkgtest. (Closes: #946375)
  [ Felipe Sateler ]
  * Enable autospawn automatically on sysvinit systems.
    Instead of having a default configuration, make pulseaudio default to
    disabled, and then have a sysvinit service to reenable the autospawn
    setting
    (Closes: #923203)
  * Allow installing pulseaudio with elogind.
    Because we now autospawn with non-systemd, we can use the weaker guarantees
    provided by elogind
    (Closes: #923201)
  * Drop postinst snippet dealing with old upgrades.
    5.0 is already in oldoldstable so no need to carry it anymore
  * Set upstream metadata fields: Name (from ./configure), Repository,
    Repository-Browse.
    Fixes: lintian: upstream-metadata-file-is-missing
    See-also: https://lintian.debian.org/tags/upstream-metadata-file-is-missing.html
  * Bump Standards-Version.
    No changes needed
  * Enable the systemd user units dynamically, not statically.
    Now that there is support for systemd --user in debhelper, lets use that to
    enable the user units instead of having a global link (Closes: #943999)