ubuntu/+source/postgresql-9.1:debian/jessie

Last commit made on 2016-06-05
Get this branch:
git clone -b debian/jessie https://git.launchpad.net/ubuntu/+source/postgresql-9.1
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/jessie
Repository:
lp:ubuntu/+source/postgresql-9.1

Recent commits

5d529c5... by Christoph Berg <email address hidden> on 2016-05-27

Import patches-unapplied version 9.1.22-0+deb8u1 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: 6db9e6edfa80d65b83bef1fa45b2fb2130779093

New changelog entries:
  * New upstream release: No effective changes for PL/Perl, the version must
    just be higher than the one in wheezy.
  * New upstream version, relevant PL/Perl change:
    + Correctly handle empty arrays in plperl_ref_from_pg_array.

6db9e6e... by Christoph Berg <email address hidden> on 2016-02-11

Import patches-unapplied version 9.1.20-0+deb8u1 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: f7d62e531a44c555d2aad14c9e402fff9b8f251b

New changelog entries:
  * New upstream release: No effective changes for PL/Perl, the version must
    just be higher than the one in wheezy.

f7d62e5... by Christoph Berg <email address hidden> on 2015-10-08

Import patches-unapplied version 9.1.19-0+deb8u1 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: f5fd6aa8bc70a8860dc936af7893fcc513bdfeab

New changelog entries:
  * New upstream version, relevant PL/Perl change:
    + Fix plperl to handle non-ASCII error message texts correctly.

f5fd6aa... by Christoph Berg on 2015-06-12

Import patches-unapplied version 9.1.18-0+deb8u1 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: d8c3808d56fd715286feb6f4238b7dc0b162b059

New changelog entries:
  * New upstream release: No effective changes for PL/Perl, the version must
    just be higher than the one in wheezy.
  * New upstream release: No effective changes for PL/Perl, the version must
    just be higher than the one in wheezy.

d8c3808... by Christoph Berg <email address hidden> on 2015-05-21

Import patches-unapplied version 9.1.16-0+deb8u1 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: 60a722b8dd2a3bd43faef480aa037da2d5f175c3

New changelog entries:
  * New upstream version, relevant PL/Perl change:
    + Improve detection of system-call failures (Noah Misch)
      Our replacement implementation of snprintf() failed to check for errors
      reported by the underlying system library calls; the main case that
      might be missed is out-of-memory situations. In the worst case this
      might lead to information exposure, due to our code assuming that a
      buffer had been overwritten when it hadn't been. Also, there were a few
      places in which security-relevant calls of other system library
      functions did not check for failure.
      It remains possible that some calls of the *printf() family of functions
      are vulnerable to information disclosure if an out-of-memory error
      occurs at just the wrong time. We judge the risk to not be large, but
      will continue analysis in this area. (CVE-2015-3166)
  * Repository moved to git, update Vcs headers.

60a722b... by Christoph Berg <email address hidden> on 2015-02-05

Import patches-unapplied version 9.1.15-0+deb8u1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b88d209de53f3ba72da90a19e1a0c82581dfc986

New changelog entries:
  * New upstream release: No effective changes for PL/Perl, the version must
    just be higher than the one in wheezy.

b88d209... by Christoph Berg on 2014-07-28

Import patches-unapplied version 9.1.14-0+deb8u1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3c313acc45f4fd4b6d834e3e3a5028369669ea9f

New changelog entries:
  * New upstream release: No effective changes for PL/Perl, the version must
    just be higher than the one in wheezy.
  * Add Breaks: postgresql-9.1 (<< 9.1.12) to ensure the server package
    supports CheckFunctionValidatorAccess.
  * Update Vcs URLs.
  * Remove 60-pg_regress_socketdir.patch, 61-extra_regress_opts: Went
    upstream (and aren't relevant for plperl anyway).
  * Add perl license to debian/copyright.

3c313ac... by Martin Pitt on 2014-03-18

Import patches-unapplied version 9.1.13-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 84eb2e12def4a9b8eabe72f8733eb79e7d271394

New changelog entries:
  * New upstream release:
    - Fix memory leak in PL/Perl when returning a composite result, including
      multiple-OUT-parameter cases.
  * Bump Standards-Version to 3.9.5. No changes necessary.

84eb2e1... by Martin Pitt on 2014-02-20

Import patches-unapplied version 9.1.12-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 53829c0c0efa6e9135b3838b0827ed2ede903748

New changelog entries:
  * New upstream release: No effective changes for PL/Perl, the version must
    just be higher than the one in wheezy.

53829c0... by Martin Pitt on 2013-12-17

Import patches-unapplied version 9.1.11-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2a7125c4004b07b44a75300dcd62925486f1d76f

New changelog entries:
  * Branch off "jessie" for the reduction to PL/Perl, keep "trunk" for the
    full builds on apt.postgresql.org. Update Vcs-*.
  * Drop all binary packages except for postgresql-plperl-9.1. Version 9.1 is
    obsolete and not supported in Jessie any more. However,
    postgresql-plperl-9.1 from Wheezy is not installable in Jessie any more
    due to the different Perl version, so we need a postgresql-plperl-9.1
    built against libperl5.18 so that you can upgrade your existing 9.1
    clusters to 9.3. Drop unnecessary build dependencies and disable the
    optional features to speed up the build.
  * Drop autopkgtest, we can't test this package standalone within wheezy.