ubuntu/+source/pollinate:applied/ubuntu/yakkety

Last commit made on 2016-08-30
Get this branch:
git clone -b applied/ubuntu/yakkety https://git.launchpad.net/ubuntu/+source/pollinate
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/yakkety
Repository:
lp:ubuntu/+source/pollinate

Recent commits

39f517a... by Dustin Kirkland  on 2016-08-30

Import patches-applied version 4.23-0ubuntu1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 586ba4654f9b9be17e2e45ad1b2a307f89ce6f01
Unapplied parent: 1a0cf735412b9560b756d43e7175c3fbdcc143d9

New changelog entries:
  * pollinate:
    - revert revision r300, as this was the wrong fix to the slow pollinate
      problem; as it turns out, it was the user_agent function, which was
      running apt-cache very early in boot, before the apt database had
      been created
    - as it turns out, we need the curl timeout options in order for curl
      to work properly and be resilient against issues with the network
      coming up early in boot

1a0cf73... by Dustin Kirkland  on 2016-08-30

Import patches-unapplied version 4.23-0ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 27675b045a370114d4585b32edbf7a3cadf9a2f4

New changelog entries:
  * pollinate:
    - revert revision r300, as this was the wrong fix to the slow pollinate
      problem; as it turns out, it was the user_agent function, which was
      running apt-cache very early in boot, before the apt database had
      been created
    - as it turns out, we need the curl timeout options in order for curl
      to work properly and be resilient against issues with the network
      coming up early in boot

586ba46... by Dustin Kirkland  on 2016-07-22

Import patches-applied version 4.22-0ubuntu1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 669d26fc101aceb75543615a0f2a61152b9930e2
Unapplied parent: 27675b045a370114d4585b32edbf7a3cadf9a2f4

New changelog entries:
  * debian/pollinate.default, pollinate: LP: #1604155
    - fix a couple of bugs affecting how long pollinate takes, and if
      it actually completes successfully
    - dpkg -l is way faster than apt-cache, when there is no apt cache
    - wait a maximum of 10 seconds
    - only log to stderr if in an interactive terminal; otherwise, just
      log to syslog
      + this fixes the odd double-printing to /var/log/syslog
    - optimize obtaining version strings by saving one pipe per call
    - source /etc/lsb/release and use $DISTRIB_DESCRIPTION, rather
      than calling lsb-release (python, can be slow)
    - add -m (max-timeout) back to curl options; removing this option
      has caused network failures in various strange ways
    - when network fails due to timeout, log accordingly
    - ignore cloud-init package not found; it's optional

27675b0... by Dustin Kirkland  on 2016-07-22

Import patches-unapplied version 4.22-0ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: c099e49eb11b87aa4e84dba9245742fa1ef181bf

New changelog entries:
  * debian/pollinate.default, pollinate: LP: #1604155
    - fix a couple of bugs affecting how long pollinate takes, and if
      it actually completes successfully
    - dpkg -l is way faster than apt-cache, when there is no apt cache
    - wait a maximum of 10 seconds
    - only log to stderr if in an interactive terminal; otherwise, just
      log to syslog
      + this fixes the odd double-printing to /var/log/syslog
    - optimize obtaining version strings by saving one pipe per call
    - source /etc/lsb/release and use $DISTRIB_DESCRIPTION, rather
      than calling lsb-release (python, can be slow)
    - add -m (max-timeout) back to curl options; removing this option
      has caused network failures in various strange ways
    - when network fails due to timeout, log accordingly
    - ignore cloud-init package not found; it's optional

669d26f... by Dustin Kirkland  on 2016-07-11

Import patches-applied version 4.21-0ubuntu1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 1e648eac2c56df48031fc78fb05140f6a2e283f2
Unapplied parent: c099e49eb11b87aa4e84dba9245742fa1ef181bf

New changelog entries:
  [ Dustin Kirkland ]
  * pollinate:
    - fix broken printing of binary data, this was breaking check_pollen
      nagios scripts on the server
  [ Junien Fridrick ]
  * entropy.ubuntu.com.pem:
    - simplify CA cert to just the DigiCert chain (drop GoDaddy)

c099e49... by Dustin Kirkland  on 2016-07-11

Import patches-unapplied version 4.21-0ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 17258508f4d5ce2fda2333ebb4e0990ce6389b8f

New changelog entries:
  [ Dustin Kirkland ]
  * pollinate:
    - fix broken printing of binary data, this was breaking check_pollen
      nagios scripts on the server
  [ Junien Fridrick ]
  * entropy.ubuntu.com.pem:
    - simplify CA cert to just the DigiCert chain (drop GoDaddy)

1e648ea... by Dustin Kirkland  on 2016-05-20

Import patches-applied version 4.20-0ubuntu1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 52d02b67bd9624892ade9cffff50f3f935067b6c
Unapplied parent: 17258508f4d5ce2fda2333ebb4e0990ce6389b8f

New changelog entries:
  * debian/control:
    - drop the anerd references, hasn't existed in basically forever
    - update description
    - add dummy | dh-apparmor dependency to get this building on precise,
      where dh-systemd doesn't exist
    - drop run-one dependency, no longer needed
    - make the bsdutils dependency (for logger) explicit, add epoch
  * debian/rules:
    - use systemd, when possible
  * pollinate:
    - fix breakage on older (trusty, precise) Ubuntu, where logger does not
      support --id=[ID]; check version of bsdutils (provides logger) to
      ensure that it's at least ubuntu wily
    - cloud-init version string
  * debian/pollinate.service, debian/pollinate.upstart:
    - improve the init messages logged

1725850... by Dustin Kirkland  on 2016-05-20

Import patches-unapplied version 4.20-0ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: f8d15a79412a47047ad3fb0bd97fec8d9101aca6

New changelog entries:
  * debian/control:
    - drop the anerd references, hasn't existed in basically forever
    - update description
    - add dummy | dh-apparmor dependency to get this building on precise,
      where dh-systemd doesn't exist
    - drop run-one dependency, no longer needed
    - make the bsdutils dependency (for logger) explicit, add epoch
  * debian/rules:
    - use systemd, when possible
  * pollinate:
    - fix breakage on older (trusty, precise) Ubuntu, where logger does not
      support --id=[ID]; check version of bsdutils (provides logger) to
      ensure that it's at least ubuntu wily
    - cloud-init version string
  * debian/pollinate.service, debian/pollinate.upstart:
    - improve the init messages logged

52d02b6... by Dustin Kirkland  on 2016-05-06

Import patches-applied version 4.19-0ubuntu1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 9d495933e57df9c8d47549eb27d2168cd9606955
Unapplied parent: f8d15a79412a47047ad3fb0bd97fec8d9101aca6

New changelog entries:
  [ Martin Pitt ]
  * debian/pollinate.service: Move installation from network.target to
    multi-user.target. network.target is too early and causes dependency loops
    with e. g. NFS. (LP: #1576333)
  * debian/pollinate.preinst: Clean up old enablement symlink on upgrade. This
    needs to be kept until after 18.04 LTS.

f8d15a7... by Dustin Kirkland  on 2016-05-06

Import patches-unapplied version 4.19-0ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 83f639ecf71a48f320e8ad35f99f5ae679cf6ba7

New changelog entries:
  [ Martin Pitt ]
  * debian/pollinate.service: Move installation from network.target to
    multi-user.target. network.target is too early and causes dependency loops
    with e. g. NFS. (LP: #1576333)
  * debian/pollinate.preinst: Clean up old enablement symlink on upgrade. This
    needs to be kept until after 18.04 LTS.