ubuntu/+source/policykit-1:applied/ubuntu/trusty-devel

Last commit made on 2019-04-03
Get this branch:
git clone -b applied/ubuntu/trusty-devel https://git.launchpad.net/ubuntu/+source/policykit-1
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/trusty-devel
Repository:
lp:ubuntu/+source/policykit-1

Recent commits

60cbd23... by Marc Deslauriers on 2019-03-27

0.105-4ubuntu3.14.04.6 (patches applied)

Imported using git-ubuntu import.

0fed144... by Marc Deslauriers on 2019-03-27

[PATCH] backend: Compare PolkitUnixProcess uids for temporary

Gbp-Pq: CVE-2019-6133.patch.

d1dbfaf... by Marc Deslauriers on 2019-03-27

[PATCH] Allow uid of -1 for a PolkitUnixProcess

Gbp-Pq: CVE-2018-19788-3.patch.

788a355... by Marc Deslauriers on 2019-03-27

[PATCH] tests: add tests for high uids

Gbp-Pq: CVE-2018-19788-2.patch.

08ce9e2... by Marc Deslauriers on 2019-03-27

[PATCH] Allow negative uids/gids in PolkitUnixUser and Group objects

Gbp-Pq: CVE-2018-19788-1.patch.

832820c... by Marc Deslauriers on 2019-03-27

Fix CVE-2018-1116: Trusting client-supplied UID

Gbp-Pq: CVE-2018-1116.patch.

3031c56... by Marc Deslauriers on 2019-03-27

docs: Update for changes to uid binding/AuthenticationAgentResponse2

Gbp-Pq: CVE-2015-4625-3.patch.

5baf32c... by Marc Deslauriers on 2019-03-27

CVE-2015-4625: Bind use of cookies to specific uids

Gbp-Pq: CVE-2015-4625-2.patch.

559205c... by Marc Deslauriers on 2019-03-27

CVE-2015-4625: Use unpredictable cookie values, keep them secret

Gbp-Pq: CVE-2015-4625-1.patch.

3571eaf... by Marc Deslauriers on 2019-03-27

CVE-2015-3255 Fix GHashTable usage.

Gbp-Pq: CVE-2015-3255.patch.