ubuntu/+source/policykit-1:applied/ubuntu/cosmic-devel

Last commit made on 2019-04-03
Get this branch:
git clone -b applied/ubuntu/cosmic-devel https://git.launchpad.net/ubuntu/+source/policykit-1
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/cosmic-devel
Repository:
lp:ubuntu/+source/policykit-1

Recent commits

ed84197... by Marc Deslauriers on 2019-03-27

0.105-21ubuntu0.4 (patches applied)

Imported using git-ubuntu import.

f2b20c4... by Marc Deslauriers on 2019-03-27

[PATCH] backend: Compare PolkitUnixProcess uids for temporary

Gbp-Pq: CVE-2019-6133.patch.

8167c63... by Marc Deslauriers on 2019-03-27

[PATCH] Allow uid of -1 for a PolkitUnixProcess

Gbp-Pq: CVE-2018-19788-3.patch.

973b000... by Marc Deslauriers on 2019-03-27

[PATCH] tests: add tests for high uids

Gbp-Pq: CVE-2018-19788-2.patch.

419884c... by Marc Deslauriers on 2019-03-27

[PATCH] Allow negative uids/gids in PolkitUnixUser and Group objects

Gbp-Pq: CVE-2018-19788-1.patch.

da8cc7f... by Marc Deslauriers on 2019-03-27

Build against libsystemd

Gbp-Pq: 10_build-against-libsystemd.patch.

818057e... by Marc Deslauriers on 2019-03-27

Install systemd service file for polkitd.

Gbp-Pq: 06_systemd-service.patch.

2d767e2... by Marc Deslauriers on 2019-03-27

Revert "Default to AdminIdentities=unix-group:wheel for local

Gbp-Pq: 05_revert-admin-identities-unix-group-wheel.patch.

649008d... by Marc Deslauriers on 2019-03-27

Use gettext for translations in .policy files

Gbp-Pq: 02_gettext.patch.

1aadfaa... by Marc Deslauriers on 2019-03-27

Use Debian's common-* PAM infrastructure, plus pam_env

Gbp-Pq: 01_pam_polkit.patch.