ubuntu/+source/pitivi:ubuntu/utopic-proposed

Last commit made on 2014-10-08
Get this branch:
git clone -b ubuntu/utopic-proposed https://git.launchpad.net/ubuntu/+source/pitivi
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/utopic-proposed
Repository:
lp:ubuntu/+source/pitivi

Recent commits

8045738... by Iain Lane on 2014-10-06

Import patches-unapplied version 0.93-4ubuntu1 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: ffc4cc879d88e14a2e8728494537556855253427

New changelog entries:
  * 0001-work-around-fix-crash-in-non-GNOME-Shell-WMs.-timeli.patch
    - Take patch from upstream bug #727851 to fix a crash on startup due to
      initialising clutter-gtk and clutter-gst in the wrong order.
  * Cherry-pick patches from upstream
    - 0002-project-Fix-setting-of-restriction-caps-values.patch
      + Use set_value, not assignment as GstStructure doesn't support the
        latter.
    - 0003-elements-Don-t-use-path_round_rectangle.patch
    - 0004-elements-Don-t-use-Cogl-anymore.patch
      + Don't drop Cogl.path_round_rectangle which wasn't used and gave
        warnings on the console since they were accidentally dropped from
        Cogl's gi bindings (see
        http://lists.freedesktop.org/archives/cogl/2014-April/001641.html)
    - 0005-pitivi-Start-using-glimagesink-as-default-sink.patch
    - 0006-pipeline-Reimplement-connectWithViewer-for-glimagesi.patch
      + Use glimagesink instead of cluttersink which resolves serious
        rendeiring problems with the preview window.
        > Depend on gstreamer1.0-plugins-bad for this.

ffc4cc8... by Sebastian Dröge on 2014-04-25

Import patches-unapplied version 0.93-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bf5b4dea1a92ce0108b79694048d0699223d6040

New changelog entries:
  * debian/control:
    + Add dependency on python-gi-cairo (Closes: #743825).

bf5b4de... by Sebastian Dröge on 2014-04-05

Import patches-unapplied version 0.93-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 53f468caeb107e9846b01a503b25d388e6a588ff

New changelog entries:
  * debian/control:
    + Depend on python-gi (>= 3.10), older versions do not work
      with pitivi (Closes: #732813).
    + Add missing dependency on gir1.2-clutter-gst-2.0 (Closes: #743692).
    + Add suggests on gir1.2-notify-0.7 and gir1.2-gnomedesktop-3.0.

53f468c... by Sebastian Dröge on 2014-03-29

Import patches-unapplied version 0.93-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 977889af33e4d9c985f27e66b63ab0ae86ec8e46

New changelog entries:
  * debian/patches/01_disable-devel-mode.patch:
    + Fix typo in patch.
  * Upload to unstable.

977889a... by Sebastian Dröge on 2014-03-29

Import patches-unapplied version 0.93-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 3f74d7e2fb4575a59629145fd041c91ce400c979

New changelog entries:
  * New upstream release candidate.

3f74d7e... by Sebastian Dröge on 2013-11-04

Import patches-unapplied version 0.92-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: b1347adfceb3ee40041c4bc561a5dfdc284919ac

New changelog entries:
  * New upstream release candidate.

b1347ad... by Sebastian Dröge on 2013-11-01

Import patches-unapplied version 0.91-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 8f5d7a054d9839f79d2c6bf11612dc359aaad0cf

New changelog entries:
  * New upstream release candidate.

8f5d7a0... by Luca Falavigna on 2013-06-01

Import patches-unapplied version 0.15.2-0.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 34802d90ebe068f485e33454b7c4cc3b73f15109

New changelog entries:
  * Non-maintainer upload.
  * Convert to dh_python2 (Closes: #616940).

34802d9... by Timo Jyrinki on 2012-06-12

Import patches-unapplied version 0.15.2-0.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8725bc72bea4a797866a79870ea75e9381a2f748

New changelog entries:
  * Non-maintainer upload.
  * New upstream release (Closes: #673547)
  - Fixes compatibility with newer GStreamer good plugins
  * Raise python-gtk dep to 2.24 (Closes: #664278)

8725bc7... by Sebastian Dröge on 2011-09-28

Import patches-unapplied version 0.15.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 16f601c1ea7c0988da3f5970a791daf0317c2704

New changelog entries:
  * New upstream release:
    + debian/control:
      - Update python-gtk2 dependency to >= 2.17.
      - Update gstreamer0.10-gnonlin dependency to >= 0.10.17.
      - Add Recommends for python-numpy for the autoaligner.
      - Build-depend on gnome-doc-utils >= 0.18.0.
      - Build-depend on pkg-config.
    + debian/patches/01_disable-devel-mode.patch:
      - Updated to apply cleanly again
    + debian/rules:
      - Don't abort the build if there are no files with a shebang
        that have to get the executable bit set.