ubuntu/+source/pitivi:ubuntu/edgy-devel

Last commit made on 2006-07-31
Get this branch:
git clone -b ubuntu/edgy-devel https://git.launchpad.net/ubuntu/+source/pitivi
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/edgy-devel
Repository:
lp:ubuntu/+source/pitivi

Recent commits

beb78da... by Loïc Minier on 2006-07-30

Import patches-unapplied version 0.10.1-1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 70ecfb4d1ee4e056654616f04e33609642c5d7f5

New changelog entries:
  * New upstream release, "Sister and friend".
  * Update to new Python policy.
    - Bump up debhelper build-dep to >= 5.0.37.2.
    - Set Python compatibility level to 2.
    - Add XB-Python-Version to pitivi.
    - Add a python-central (>= 0.4.17) build-dep.
    - Build-depend on cdbs (>= 0.4.43).
    - Add a XS-Python-Version (current).
    - Call dh_pycentral to fill XB-Python-Version and add a pycentral dep, and
      swap the executable bit fixup with the dh_py* calls.

70ecfb4... by Loïc Minier on 2006-05-06

Import patches-unapplied version 0.10.0-1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: a596894187bbde7d757c78089ff7638a3963bbea

New changelog entries:
  * New upstream release, "It's a birthday party".
    - Drop python-gnome2-dev build-dep.
      [debian/control]
    - Bump libgstreamer0.10-dev build-dep to 0.10.4.
      [debian/control]
    - Bump gstreamer0.10-gnonlin-dev build-dep to 0.10.2.
      [debian/control]
    - Remove gstreamer0.10-gnomevfs and python-gnome2 from the deps of pitivi.
      [debian/control]
    - Update description with current description in Wiki and stop claiming
      unsupported features.
  * Fix typo in upstream URL. (Closes: #360810)
    [debian/copyright]
  * Add a depends on gstreamer0.10-x because Recommends are not pulled in
    correctly. (Closes: #360812)
    [debian/control]
  * Move debhelper and cdbs to Build-Deps (arch dependent) for clean.
    [debian/control]
  * Bump up Standards-Version to 3.7.2.
    [debian/control]
  * The "Don't take drugs when packaging upload".
  * Fix architecture.
    - Switch from Architecture: any to all, doh!
      [debian/control]
    - Drop shlibs:Depends.
      [debian/control]
    - Switch from Build-Depends to Build-Depends-Indep.
      [debian/control]
  * Fix build-deps (note for self: don't rush uploading a CVS snapshot).
    - Add a python-cairo-dev (>= 1.0.0) build-dep-indep, thanks Bastian
      Blank. (Closes: #360052)
      [debian/control]
  * Set the executable bit on the Python classes with a shebang to make
    lintian happy.
    [debian/rules]
  * Add dependencies on GStreamer packages shipping elements referenced
    directly in the source: gstreamer0.10-gnomevfs,
    gstreamer0.10-plugins-base, gstreamer0.10-plugins-good,
    libgstreamer0.10-0. (Closes: #359635)
    [debian/control]
  * New upstream CVS snapshot.
  * Initial upload to Debian. (Closes: #291069)
  * Set myself as the Maintainer.
    [debian/control]
  * Fix license to be LGPL and fix copyright holders for the Python version.
    [debian/copyright]
  * Add CDBS' utils.
    [debian/rules]
  * Drop version of the python-dev build-dep to build against 2.3.
    [debian/control]
  * Drop gettext build-dep.
    [debian/control]
  * Replace python-gnome2-dev by a python-gnome2 dep.
    [debian/control]
  * Tweak descriptions a bit.
    [debian/control]

a596894... by Daniel Holbach on 2006-02-23

Import patches-unapplied version 0.9.9.2-0ubuntu2 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: cfa73578b58ef10c961e95211db8361076570259

New changelog entries:
  * Rebuild.

cfa7357... by Daniel Holbach on 2006-02-04

Import patches-unapplied version 0.9.9.2-0ubuntu1 to ubuntu/dapper

Imported using git-ubuntu import.