ubuntu/+source/pidgin:ubuntu/wily-updates

Last commit made on 2016-07-12
Get this branch:
git clone -b ubuntu/wily-updates https://git.launchpad.net/ubuntu/+source/pidgin
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/wily-updates
Repository:
lp:ubuntu/+source/pidgin

Recent commits

c4c4901... by Marc Deslauriers on 2016-07-12

Import patches-unapplied version 1:2.10.11-0ubuntu4.2 to ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: 020c5fb220c0c6a4a7a6bb8a3a175dade603e7c9

New changelog entries:
  * SECURITY UPDATE: denial of service and code execution in MXIT protocol
    - debian/patches/CVE-2016-*.patch: fix multiple issues.
    - CVE-2016-2365
    - CVE-2016-2366
    - CVE-2016-2367
    - CVE-2016-2368
    - CVE-2016-2369
    - CVE-2016-2370
    - CVE-2016-2371
    - CVE-2016-2372
    - CVE-2016-2373
    - CVE-2016-2374
    - CVE-2016-2375
    - CVE-2016-2376
    - CVE-2016-2377
    - CVE-2016-2378
    - CVE-2016-2380
    - CVE-2016-4323

020c5fb... by Sebastien Bacher on 2016-02-23

Import patches-unapplied version 1:2.10.11-0ubuntu4.1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 29e781ff57bcbfe221dfbeb5e862e3bdb74a3b92

New changelog entries:
  * debian/patches/hg_gst_leak.patch:
    "When receiving an error or stream finished message, we can free the
     Gstreamer pipeline so we don't leak it for each sound." (lp: #1479715)

29e781f... by Robert Ancell on 2015-06-25

Import patches-unapplied version 1:2.10.11-0ubuntu4 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: e50b10e5bb3e1a01891e13f3a244509505b4ac2a

New changelog entries:
  * No change rebuild against libfarstream-0.2-5

e50b10e... by Robert Ancell on 2015-06-10

Import patches-unapplied version 1:2.10.11-0ubuntu3 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: b6bf9796a1dc1c41b1c19917e9519b98705d956a

New changelog entries:
  * debian/control:
    - Build-depend on python3
    - libpurple-bin depends on python3, python3-dbus
    - Add missing depend on dbus for libpurple-bin
  * debian/patches/python3.patch:
    - Use Python 3 (LP: #1440390)

b6bf979... by Robert Ancell on 2015-05-28

Import patches-unapplied version 1:2.10.11-0ubuntu2 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 9167c17a984390fc62fc5920feaa1207e32c2513

New changelog entries:
  * debian/control:
    - Build-depend on libgstreamer1.0-dev, libgstreamer-plugins-base1.0-dev,
      libfarstream-0.2
    - Recommend gstreamer1.0-plugins-base, gstreamer1.0-plugins-good
  * debian/patches/gstreamer1.patch:
    - Use gstreamer 1.0 (LP: #1295207)

9167c17... by Robert Ancell on 2015-05-28

Import patches-unapplied version 1:2.10.11-0ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 96d542abaada5c5872ca0ab0e52c20acc9068d2f

New changelog entries:
  * New upstream release (LP: #1402424)
  * debian/patches/CVE-2014-3775.patch:
  * debian/patches/CVE-2014-3698.patch:
  * debian/patches/CVE-2014-3696.patch:
  * debian/patches/CVE-2014-3695.patch:
  * debian/patches/CVE-2014-3694.patch:
    - Applied upstream
  * debian/libpurple0.symbols:
    - Updated

96d542a... by Marc Deslauriers on 2014-10-28

Import patches-unapplied version 1:2.10.9-0ubuntu8 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: ac9aa72290802e8d8cc037b6f07dc6299df02b25

New changelog entries:
  * SECURITY UPDATE: insufficient ssl certificate validation
    - debian/patches/CVE-2014-3694.patch: fix basic constraints checking in
      libpurple/certificate.c, libpurple/certificate.h,
      libpurple/plugins/ssl/ssl-gnutls.c, libpurple/plugins/ssl/ssl-nss.c.
    - CVE-2014-3694
  * SECURITY UPDATE: denial of service via malformed MXit emoticon response
    - debian/patches/CVE-2014-3695.patch: properly check lengths in
      libpurple/protocols/mxit/markup.c.
    - CVE-2014-3695
  * SECURITY UPDATE: denial of service via malformed Groupwise message
    - debian/patches/CVE-2014-3696.patch: check sizes in
      libpurple/protocols/novell/nmevent.c.
    - CVE-2014-3696
  * SECURITY UPDATE: XMPP information leak
    - debian/patches/CVE-2014-3698.patch: fix leaks in
      libpurple/protocols/jabber/jutil.c.
    - CVE-2014-3698

ac9aa72... by Dimitri John Ledkov on 2014-09-18

Import patches-unapplied version 1:2.10.9-0ubuntu7 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 0dc4a7f23ab1b7c892e1f3e9d7e5763b47457cb2

New changelog entries:
  * Add dialpad support.

0dc4a7f... by TomasHnyk on 2014-09-02

Import patches-unapplied version 1:2.10.9-0ubuntu6 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 46f31d897fd5cf92ffe07e883a7ef0148f11c8de

New changelog entries:
  * debian/control, debian/rules, debian/prefs.xml:
    Build with --enable-unity. (LP: #1362368)

46f31d8... by Colin Watson on 2014-08-21

Import patches-unapplied version 1:2.10.9-0ubuntu5 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: c235b4adbad38234f2d3430a2bded6f7430333ca

New changelog entries:
  * Rebuild for Perl 5.20.0.