ubuntu/+source/phpmyadmin:applied/debian/stretch

Last commit made on 2020-07-18
Get this branch:
git clone -b applied/debian/stretch https://git.launchpad.net/ubuntu/+source/phpmyadmin
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/stretch
Repository:
lp:ubuntu/+source/phpmyadmin

Recent commits

65dd21b... by William Desportes on 2020-03-22

4:4.6.6-4+deb9u1 (patches applied)

Imported using git-ubuntu import.

6615883... by William Desportes on 2020-03-22

Patch for PMASA-2020-2, CVE-2020-10804

Gbp-Pq: CVE-2020-10804.patch.

cb38cc7... by William Desportes on 2020-03-22

Patch for PMASA-2020-4, CVE-2020-10803

Gbp-Pq: fix-tests-for-CVE-2020-10803.patch.

6c935df... by William Desportes on 2020-03-22

Implement signSqlQuery and checkSqlQuerySignature for PMASA-2020-4

Gbp-Pq: add-functions-for-CVE-2020-10803.patch.

f05095f... by William Desportes on 2020-03-22

Patch for PMASA-2020-4, CVE-2020-10803

Gbp-Pq: CVE-2020-10803.patch.

0d142f6... by William Desportes on 2020-03-22

Fix tests for CVE-2019-12616

Gbp-Pq: fix-tests-for-CVE-2019-12616.patch.

d420b18... by William Desportes on 2020-03-22

Patch for PMASA-2020-3, CVE-2020-10802

Gbp-Pq: CVE-2020-10802.patch.

0b5db58... by William Desportes on 2020-03-22

Patch for PMASA-2020-1, CVE-2020-5504

Gbp-Pq: CVE-2020-5504.patch.

e547e2c... by William Desportes on 2020-03-22

A vulnerability was found that allows an attacker to trigger a CSRF attack against a phpMyAdmin user. The attacker can trick the user, for instance through a broken <img> tag pointing at the victim's phpMyAdmin database, and the attacker can potentially deliver a payload (such as a specific INSERT or DELETE statement) through the victim.

Gbp-Pq: CVE-2019-12616.patch.

aa658f4... by William Desportes on 2020-03-22

A vulnerability was reported where a specially crafted database name can be

Gbp-Pq: CVE-2019-11768.patch.