ubuntu/+source/phonon:ubuntu/artful

Last commit made on 2016-07-31
Get this branch:
git clone -b ubuntu/artful https://git.launchpad.net/ubuntu/+source/phonon
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/artful
Repository:
lp:ubuntu/+source/phonon

Recent commits

3ad222e... by Pino Toscano <email address hidden> on 2016-07-31

Import patches-unapplied version 4:4.9.0-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4f704bc6aa236c422b83af68b5d0cc7233d4dbbc

New changelog entries:
  * Team upload.
  [ Pino Toscano ]
  * Remove the unused libqzeitgeist-dev build dependency.
  * Switch the default backend for phonon (Qt4) from phonon-backend-vlc to
    phonon-backend-gstreamer: since vlc is a Qt5 application, using it in
    Qt4-based application will cause crashes due to symbols clashes.
  [ Debconf translation updates ]
  * Turkish (Mert Dirik). (Closes: #757504)

4f704bc... by Lisandro Damián Nicanor Pérez Meyer <email address hidden> on 2016-06-10

Import patches-unapplied version 4:4.9.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9c1377a03407f10cd1dd18e14f690d229f8fe2b3

New changelog entries:
  * Drop qtquick1-5-dev as a build dependency (Closes: #824957).
  * Update symbols files with buildds' logs.
  * Update Vcs-[Git Browser] to their https counterparts.

9c1377a... by Maximiliano Curia on 2016-05-18

Import patches-unapplied version 4:4.9.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: edbaa892d232230ad94817b798535071e79bfe07

New changelog entries:
  [ Automatic packaging ]
  * Update symbols files from buildds logs (4:4.9.0-1).
  * Update symbols files.
  [ Maximiliano Curia ]
  * Update symbols files, hppa and sparc64 brought back lots of gccinternal symbols
  * Add missing Breaks/Replaces

edbaa89... by Maximiliano Curia on 2016-05-14

Import patches-unapplied version 4:4.9.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 9fbab203d8b586c933e7b25c97badfd86c8a6c1c

New changelog entries:
  * New upstream release (4.9.0).
  * Update symbols files.
  * Drop automoc build dependency (Closes: #824123) Thanks to Александр Волков
    for the report.
  * Add qtquick1-5-dev missing build dependency
  * Update watch file
  * Update build-deps and deps with the info from cmake
  * Bump Standards-Version to 3.9.8
  * Migrate to the automatic dbgsym packages
  * Update symbols files with the logs from the buildds.
  * Refresh patches
  * Update install files
  * Add myself to the uploaders list

9fbab20... by Felix Geyer on 2015-08-29

Import patches-unapplied version 4:4.8.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ec6b8848e33bf766558918a25f83b1b9d5523cb8

New changelog entries:
  * Team upload.
  * Make some symbols in libphonon4qt5 create a dependency on phonon4qt5
    similar to libphonon4.
  * Fix dependency of phonon4qt5: phonon-backend -> phonon4qt5-backend
  * Correctly display the recommended backend in phonon4qt5-backend-null
    debconf warning.
  * Stop suggesting a mplayer backend, no such thing exists in the archive.

ec6b884... by Lisandro Damián Nicanor Pérez Meyer <email address hidden> on 2015-08-08

Import patches-unapplied version 4:4.8.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2c4bb05a927ece3d5922b2ee44f4b907ca25bfcf

New changelog entries:
  [ Maximiliano Curia ]
  * New upstream release (4.8.3).
  * Use the new PHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT build
    option.
  * Refresh patches.
  * Update phonon_is_not_forced_in_KDE patch
  * Import upstream patch:
    upstream_dont_allocate_a_char_with_undefined_size
  * Import upstream patch: upstream_fix_build_with_qt_5.4.2
  * New patch: fix_include_dirs
  * Add ecm build dep.
  * Update symbols files.
  * Update install files.
  * Bump Standards-Version to 3.9.6, no changes needed.

2c4bb05... by Maximiliano Curia on 2015-02-10

Import patches-unapplied version 4:4.8.0-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d1ce1875c529ab60f5ccf994203a7527b9a19ea7

New changelog entries:
  * Team upload.
  [ Lisandro Damián Nicanor Pérez Meyer ]
  * Add myself to Uploaders.
  [ Rohan Garg ]
  * Update phonon_is_not_forced_in_KDE.diff so that the
    new include path is properly exported.

d1ce187... by Lisandro Damián Nicanor Pérez Meyer <email address hidden> on 2014-11-27

Import patches-unapplied version 4:4.8.0-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 396c50831f38a1c0898320ede6476b5c9c3ea5cb

New changelog entries:
  * Team upload.
  * Add do_not_assume_existing_backend.patch to solve a crash when running
    without a backend (Closes: #771138).

396c508... by Diane Trout on 2014-09-28

Import patches-unapplied version 4:4.8.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d9b9c491d9a45184ef088243f962084ddf3dd647

New changelog entries:
  * Remove debian/installgen, no longer used.
  * Simplify merginging expand4qt5_vars.awk into expand_vars.awk

d9b9c49... by Diane Trout on 2014-09-20

Import patches-unapplied version 4:4.8.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 409308bf274aaaa9ae562a71f44b9d2c24a442a0

New changelog entries:
  [ Lisandro Damián Nicanor Pérez Meyer ]
  * Provide Qt 5 versions of the packages (Closes: #731936).
    - Modify debian/rules to allow the double build.
  [ Diane Trout]
  * add libqt5opengl5-dev to build dependencies.
  * update SO versions to 4.8.0 for libphonon4qt5*.install
  * Add myself to upoaders.
  * phonon4qt5-backend-null should only conflict with other
    phonon4qt5-backends.
  * update libphonon4qt5-dev.install package
  * Add symbols files for libphonon4qt5 and libphonon4qt5experimental4
  * Add override_dh_strip target to correctly build libphonon-dbg (qt4)
    and libphonon4qt5-dbg (qt5) debug packages.
  * Add qttools5-dev as a build dependency in order to build qt5 phononwidgets
    designer support library.
  * Merge in changes from Kubuntu to support Qt5 debconf warning.
    (Done by Jonathan Riddell)
  * Rename libphonon4qt5 library to libphonon4qt5-4 to match soname