ubuntu/+source/pciutils:ubuntu/intrepid

Last commit made on 2008-10-24
Get this branch:
git clone -b ubuntu/intrepid https://git.launchpad.net/ubuntu/+source/pciutils
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/intrepid
Repository:
lp:ubuntu/+source/pciutils

Recent commits

155cb17... by Tim Gardner on 2008-10-22

Import patches-unapplied version 1:3.0.0-4ubuntu4 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 87787f9000441967aaffddd970a87801e1a9caf3

New changelog entries:
  * Updated PCI IDs

87787f9... by Tim Gardner on 2008-10-13

Import patches-unapplied version 1:3.0.0-4ubuntu3 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 096492b22d0ffb6a19f560976666fc0fd27570c7

New changelog entries:
  * Updated PCI IDs
  * Modified update-pciids.sh to accomodate new format in
     the PCI identifiers file.

096492b... by Tim Gardner on 2008-09-22

Import patches-unapplied version 1:3.0.0-4ubuntu2 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 4d314bb849dbd6fb2a17ac38e66957f9ccc6322d

New changelog entries:
  * Updated PCI IDs

4d314bb... by Tim Gardner on 2008-06-19

Import patches-unapplied version 1:3.0.0-4ubuntu1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: e8c4bee466ffaefa57de9ff06d19c7542e4cbefd

New changelog entries:
  * Updated PCI IDs

e8c4bee... by Anibal Monsalve Salazar on 2008-05-11

Import patches-unapplied version 1:3.0.0-4 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: ab8c6d7c0b5fc9f5cf1dd7be99f9be299e068c9e

New changelog entries:
  * Uncompress pci.ids.gz in debian/rules. Closes: #479766
  * Don't compress pci.ids in update-pciids.sh
  * pci.ids: updated with daily snapshot dated Sun 2008-05-11 01:05:02

ab8c6d7... by Anibal Monsalve Salazar on 2008-04-29

Import patches-unapplied version 1:3.0.0-3 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: a28f9d9d154313652fe8ed1dc3faf419e1e99b60

New changelog entries:
  * libpci-dev conflicts with pciutils-dev. Closes: #478290
  * libpci-dev is priority standard
  * Compile the udeb lspci with libpci.a
  * Don't uncompress pci.ids.gz
  * update-pciids works as expected. Closes: #411314, #452008
  * pci.ids: updated with daily snapshot dated 2008-04-27 01:05:01
  * New upstream version
  * pci.ids: updated with daily snapshot dated Sat 2008-04-12 01:05:01
  * pci.ids: updated with daily snapshot dated Sat 2008-04-12 01:05:01
  * New upstream version
  * Install the pkgconfig file in the pciutils-dev package.
    Patch by Nicolas Boullis <email address hidden>.
    Closes: #403181
  * pci.ids: updated with daily snapshot dated Wed 2008-02-20 02:05:01
  * pciutils-udeb is priority standard. Closes: #420227
  * New upstream version
  * Acknowledged NMU. Closes: #425639
  * pci.ids: updated with daily snapshot dated Wed 2008-01-23 02:05:02
    Closes: #422713
  * pciutils and pciutils-udeb depend on ${misc:Depends}
  * pciutils-dev depends on zlib1g-dev. Closes: 396640, #413462
  * pciutils-dev depends on pciutils (= ${binary:Version})
  * Bumped debhelper compat to 5
  * Bumped Standards-Version to 3.7.3
  * Put myself as maintainer
  * Set homepage control header
  * pciutils is priority standard
  * Removed empty lib directory from pciutils-udeb
  * Replaced "-$(MAKE)" with "[ ! -f Makefile ] || $(MAKE)" in debian/rules
  * Non-maintainer upload.
  * Removed obsolete dependency libpci2. Closes: #425639

a28f9d9... by Matt Taggart on 2006-10-27

Import patches-unapplied version 1:2.2.4-1 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: c2b80f7852ceb6cd7b87a4a55e848385a49725a7

New changelog entries:
  [ Matthew Wilcox ]
  * New upstream version.
  * Get rid of build-* rules in debian/rules, don't call build from
    binary-indep and don't touch build-* files.
  * gzip the udeb's stripped pci.ids, but gunzip the deb's pci.ids so
    that programs linked against earlier versions of libpci continue
    to work. Also modify update-pciids so that it'll install an
    uncompressed version of pci.ids.
  * Change Makefile to not build pcimodules for HURD. Closes: #380032
  * Improve the error message if we can't read the standard header
  * Remove myself as an Uploader
  [ Matt Taggart ]
  * update pci.ids to 2006-10-27 01:05:01
  [ Matthew Wilcox ]
  * New upstream version
    - Adds -nn option. Closes: #268031
    - Adds deviceclass field. Closes: #335665
    - Fixes I/O port access on Hurd. Closes: #379407
  * Fix Maintainer email address
  [ Matthew Wilcox ]
  * New upstream version. Closes: #329370
    - Builds on HURD. Closes: #349239
    - Debian GNU/kFreeBSD should now build. Closes: #292324
    - Uses correct header type for PCI-X. Closes: #265745
    - u64 is now defined in include/pci/types.h. Closes: #265771
    - Subsystem vendors now printed correctly. Closes: #304576
    - Error message corrected. Closes: #347872
    - nv40 replaced with NV40. Closes: #343222
    - Memory window size now reported correctly. Closes: #256607
    - The manpage now explains why capabilties are available only to root.
      Closes: #173274
    - Domains are properly supported. Closes: #369751
  * New debian maintainers. Thanks to Remco for his years of service.
  * Added option to use curl (instead of wget or lynx) to retrieve pci.ids
  * Revert patch to change -m format from #250737. Closes: #347877
  * Move /var/lib/pciutils/pci.ids back to /usr/share/misc/pci.ids.
    Closes: #336331
  * Fix typos in pcimodules manpages. Closes: #356129, #302142
  * Remove libpci.so.2; depend on libpci2 to provide this for compatibility
    with sarge.
  * Build libpci.a with -fPIC for packages which need to build shared
    libraries.
  * Remove -X option as upstream has vetoed it. It wasn't actually being
    used anyway.
  * Add -D option (which will be in the next upstream release) to always
    show domains.
  * Stop installing the pciutils.lsm file.
  [ Matt Taggart ]
  * update debian/copyright date and author email address
  * Make the pci.ids update a separate debian/rules target that's not
    invoked in a default build
  * minor cleanups in debian/rules
  * get rid of README.debian, it's redundant with upstream info
  * New maintainer, closes: #359915.
  * ACK NMUs, closes: #261536, #271226, #278479, #281411, #281413,
    #284110, #326274.
  * Set Standards-Version to 3.6.2.
  * Added homepage to package descriptions.
  * Added debian watch file.
  [ Christian Perrier ]
  * Non-maintainer upload to add a udeb providing lspci for d-i purposes
    Closes: #284110
  [ Colin Watson ]
  * Changes merged from Ubuntu patches:
    - Add pciutils-udeb, for use in the installer. Contains only lspci,
      libpci.so.2, and pci.ids.
    - Reduce pciutils-udeb's copy of pci.ids by over 100KB by removing
      subsystem ids, which I don't think we need in the installer, and
      comments.
    - Move pciutils-udeb's copy of libpci.so.2 to /lib; it seems to confuse
      mklibs less that way.
  * NMU durring BSP
  * remove unneeded wget build-dependancy
  * Store pci.ids under /var for better FHS complicance (closes: #278479)
    patch by Sam Morris
  * Remove pci.ids.old etc when purging the package (closes: #281413)
    patch by Sam Morris
  * fix lspci -F for new or old lspci -x format (closes: #261536)
    based on patch by Ben Pfaff
  * update pci.ids (closes: #281411, hopefully closes: #326274)
  * Updated pci.ids
  * Closes: #259990: pciutils{, -dev}: package description shouldn't
    contain "(for 2.*.* kernels)"
  * Install example.c in package (closes: #228660)
  * Added Conflicts with older alsa-utils version (closes: #259661)
  * Updated pci.ids
  * Updated pci.ids
  * Add pcimodules utility (closes: #253020)
  * Add -X option for output suitable for use in XFree86Config (closes:
    #251828)
  * Fix problem with lspci displaying wrong bar size (closes: #256352)
  * Make machine-readable output better machine-readable (closes:
    #250737)
  * Oops now with correct replaces versioning

c2b80f7... by Remco van de Meent <email address hidden> on 2004-04-20

Import patches-unapplied version 1:2.1.11-11 to ubuntu/warty

Imported using git-ubuntu import.