ubuntu/+source/pciutils:debian/stretch

Last commit made on 2016-12-01
Get this branch:
git clone -b debian/stretch https://git.launchpad.net/ubuntu/+source/pciutils
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/stretch
Repository:
lp:ubuntu/+source/pciutils

Recent commits

31b304a... by Anibal Monsalve Salazar on 2016-11-30

Import patches-unapplied version 1:3.5.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 699678b243464aa1f1f3aa801053564bd8cd6aaa

New changelog entries:
  [ Anibal Monsalve Salazar ]
  * New upstream version 3.5.2
  * Update pci.ids with version 2016.11.21
  * Refresh patches
  * Standards-Version: 3.9.8
  [ Helmut Grohne ]
  * Fix FTCBFS (Closes: 834794)
    - export cross $PKG_CONFIG
    - export cross $HOST

699678b... by Samuel Thibault <email address hidden> on 2016-11-22

Import patches-unapplied version 1:3.3.1-1.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cda0968dba05a9f6dce836350252d552eb7de037

New changelog entries:
  * Non-maintainer upload.
  * Fix linking on non-linux architectures by cleaning link rules.
    (Closes: #815669)

cda0968... by Laurent Bigonville on 2016-01-13

Import patches-unapplied version 1:3.3.1-1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6dc6f4336945486d100f3bf6ec71be272a84a6c6

New changelog entries:
  * Non-maintainer upload.
  * Enable libkmod support on linux architectures (Closes: #807043)
  * Enable udev hwdb support on linux architectures

6dc6f43... by Anibal Monsalve Salazar on 2015-08-11

Import patches-unapplied version 1:3.3.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0d8b0f304fe69c4168471e3b8aa16088ddc10fa5

New changelog entries:
  * New upstream version 3.3.1
    Closes: #773165
  * Update pci.ids with version 2015.07.31
  * Merged upstream:
    05-674708-setpci.man.patch
    06-675087-update-pciids.man.patch
  * Refresh patches.
  * Debian policy version is 3.9.6
  * Make the build reproducible
    Patch by Reiner Herrmann
    Closes: #783144
  * Fix wrong option for modprobe in man page of pcimodules
    Patch by Maximiliano Curia
    Closes: #613626

0d8b0f3... by Anibal Monsalve Salazar on 2014-09-09

Import patches-unapplied version 1:3.2.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3cb283bad234a341e538403ef71ebe24a73ae2fe

New changelog entries:
  * Update pci.ids with version 2014.09.09.
  * Use default compression for binary packages.
  * Refresh patches.

3cb283b... by Anibal Monsalve Salazar on 2014-02-16

Import patches-unapplied version 1:3.2.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 80686555e4f81d5511ca37bd848f2b1f30459363

New changelog entries:
  * Update pci.ids with version 2014.02.14

8068655... by Anibal Monsalve Salazar on 2013-12-27

Import patches-unapplied version 1:3.2.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9cac08e06db150d8b390e8b8666e746146d5b5e8

New changelog entries:
  * New upstream version 3.2.1
    - CardBus bridge capabilities are displayed.
    - PCIe L1 PM substates are decoded.
    - Various bugs were fixed in decoding of PCIe capabilities.
    - The sysfs back-end does not spit out unnecessary warnings when
      slots report only a partial device address. This actually
      on IBM pSeries.
  * Update 01-Makefile.patch
  * Update pci.ids with version 2013.12.27
  * Debian policy version is 3.9.5
  * Suggests package lynx-cur
    Closes: #710580

9cac08e... by Anibal Monsalve Salazar on 2013-07-02

Import patches-unapplied version 1:3.2.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c53a28026ccffa76e7f11681881ec0129b2a2074

New changelog entries:
  * Update pci.ids with version Version: 2013.07.01
  * Update package description
    Patch by Justin B Rye
    Closes: #708363
  * libpci.pc: add -lresolv and -lz for static linking
    Add 07-697383-libpci.pc.in.patch
    Closes: #697383

c53a280... by Anibal Monsalve Salazar on 2013-06-06

Import patches-unapplied version 1:3.2.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8444aab8d81acc68b89a1871f6907c3440bf91b0

New changelog entries:
  * Update pci.ids with version Version: 2013.06.06

8444aab... by Anibal Monsalve Salazar on 2013-05-23

Import patches-unapplied version 1:3.2.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f3f2e39456d6a7c9db0876acde6cfdaf24bcd3c8

New changelog entries:
  * New upstream version 3.2.0
    - 3.2.0
      On newer Linux systems, we use libkmod to look up kernel modules
      (modules.pcimap no longer exists.) To facilitate this, libpci
      is able to look up module aliases in sysfs.
    - 3.1.10
      Decoding of LTR/OBFF in PCIe capabilities.
  * Debian policy version is 3.9.4
  * Update pci.ids with version 2013.05.22
  * update-pciids is in /usr/sbin
    Closes: #708361
  * Update
    01-Makefile.patch
    04-update-pciids.sh.patch
  * Fix various issues in setpci.man update-pciids.man
    Patches by Bjarni Ingi Gislason
    Add 05-674708-setpci.man.patch
    Add 06-675087-update-pciids.man.patch
    Closes: #674708, #675087
  [ Colin Watson ]
  * Set CROSS_COMPILE rather than CC when cross-building, so that we use the
    correct ar and ranlib too.
    Closes: #694903
  * Tell the upstream build system not to strip binaries when installing
    them; dh_strip will handle that, using the correct strip program and
    honouring DEB_BUILD_OPTIONS=nostrip.
    Closes: #694903