ubuntu/+source/pciutils:applied/ubuntu/edgy-devel

Last commit made on 2006-07-12
Get this branch:
git clone -b applied/ubuntu/edgy-devel https://git.launchpad.net/ubuntu/+source/pciutils
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/edgy-devel
Repository:
lp:ubuntu/+source/pciutils

Recent commits

6dc7349... by Scott James Remnant (Canonical) on 2006-07-12

Import patches-applied version 1:2.2.1-2ubuntu2 to applied/ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 569fc11ca3607ac1aa75a7b64ef4e6ab3891d83a
Unapplied parent: 0d2c0d4bd8813ca200a77e5bb0d48933c57b98d9

New changelog entries:
  * Fake-sync with Debian (sync this in future).
  * Fix Maintainer email address
  [ Matthew Wilcox ]
  * New upstream version. Closes: #329370
    - Builds on HURD. Closes: #349239
    - Debian GNU/kFreeBSD should now build. Closes: #292324
    - Uses correct header type for PCI-X. Closes: #265745
    - u64 is now defined in include/pci/types.h. Closes: #265771
    - Subsystem vendors now printed correctly. Closes: #304576
    - Error message corrected. Closes: #347872
    - nv40 replaced with NV40. Closes: #343222
    - Memory window size now reported correctly. Closes: #256607
    - The manpage now explains why capabilties are available only to root.
      Closes: #173274
    - Domains are properly supported. Closes: #369751
  * New debian maintainers. Thanks to Remco for his years of service.
  * Added option to use curl (instead of wget or lynx) to retrieve pci.ids
  * Revert patch to change -m format from #250737. Closes: #347877
  * Move /var/lib/pciutils/pci.ids back to /usr/share/misc/pci.ids.
    Closes: #336331
  * Fix typos in pcimodules manpages. Closes: #356129, #302142
  * Remove libpci.so.2; depend on libpci2 to provide this for compatibility
    with sarge.
  * Build libpci.a with -fPIC for packages which need to build shared
    libraries.
  * Remove -X option as upstream has vetoed it. It wasn't actually being
    used anyway.
  * Add -D option (which will be in the next upstream release) to always
    show domains.
  * Stop installing the pciutils.lsm file.
  [ Matt Taggart ]
  * update debian/copyright date and author email address
  * Make the pci.ids update a separate debian/rules target that's not
    invoked in a default build
  * minor cleanups in debian/rules
  * get rid of README.debian, it's redundant with upstream info
  * New maintainer, closes: #359915.
  * ACK NMUs, closes: #261536, #271226, #278479, #281411, #281413,
    #284110, #326274.
  * Set Standards-Version to 3.6.2.
  * Added homepage to package descriptions.
  * Added debian watch file.
  [ Christian Perrier ]
  * Non-maintainer upload to add a udeb providing lspci for d-i purposes
    Closes: #284110
  [ Colin Watson ]
  * Changes merged from Ubuntu patches:
    - Add pciutils-udeb, for use in the installer. Contains only lspci,
      libpci.so.2, and pci.ids.
    - Reduce pciutils-udeb's copy of pci.ids by over 100KB by removing
      subsystem ids, which I don't think we need in the installer, and
      comments.
    - Move pciutils-udeb's copy of libpci.so.2 to /lib; it seems to confuse
      mklibs less that way.
  * NMU durring BSP
  * remove unneeded wget build-dependancy
  * Store pci.ids under /var for better FHS complicance (closes: #278479)
    patch by Sam Morris
  * Remove pci.ids.old etc when purging the package (closes: #281413)
    patch by Sam Morris
  * fix lspci -F for new or old lspci -x format (closes: #261536)
    based on patch by Ben Pfaff
  * update pci.ids (closes: #281411, hopefully closes: #326274)
  * Updated pci.ids
  * Closes: #259990: pciutils{, -dev}: package description shouldn't
    contain "(for 2.*.* kernels)"
  * Install example.c in package (closes: #228660)
  * Added Conflicts with older alsa-utils version (closes: #259661)
  * Updated pci.ids
  * Updated pci.ids
  * Add pcimodules utility (closes: #253020)
  * Add -X option for output suitable for use in XFree86Config (closes:
    #251828)
  * Fix problem with lspci displaying wrong bar size (closes: #256352)
  * Make machine-readable output better machine-readable (closes:
    #250737)
  * Oops now with correct replaces versioning

0d2c0d4... by Scott James Remnant (Canonical) on 2006-07-12

Import patches-unapplied version 1:2.2.1-2ubuntu2 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: c2b80f7852ceb6cd7b87a4a55e848385a49725a7

New changelog entries:
  * Fake-sync with Debian (sync this in future).
  * Fix Maintainer email address
  [ Matthew Wilcox ]
  * New upstream version. Closes: #329370
    - Builds on HURD. Closes: #349239
    - Debian GNU/kFreeBSD should now build. Closes: #292324
    - Uses correct header type for PCI-X. Closes: #265745
    - u64 is now defined in include/pci/types.h. Closes: #265771
    - Subsystem vendors now printed correctly. Closes: #304576
    - Error message corrected. Closes: #347872
    - nv40 replaced with NV40. Closes: #343222
    - Memory window size now reported correctly. Closes: #256607
    - The manpage now explains why capabilties are available only to root.
      Closes: #173274
    - Domains are properly supported. Closes: #369751
  * New debian maintainers. Thanks to Remco for his years of service.
  * Added option to use curl (instead of wget or lynx) to retrieve pci.ids
  * Revert patch to change -m format from #250737. Closes: #347877
  * Move /var/lib/pciutils/pci.ids back to /usr/share/misc/pci.ids.
    Closes: #336331
  * Fix typos in pcimodules manpages. Closes: #356129, #302142
  * Remove libpci.so.2; depend on libpci2 to provide this for compatibility
    with sarge.
  * Build libpci.a with -fPIC for packages which need to build shared
    libraries.
  * Remove -X option as upstream has vetoed it. It wasn't actually being
    used anyway.
  * Add -D option (which will be in the next upstream release) to always
    show domains.
  * Stop installing the pciutils.lsm file.
  [ Matt Taggart ]
  * update debian/copyright date and author email address
  * Make the pci.ids update a separate debian/rules target that's not
    invoked in a default build
  * minor cleanups in debian/rules
  * get rid of README.debian, it's redundant with upstream info
  * New maintainer, closes: #359915.
  * ACK NMUs, closes: #261536, #271226, #278479, #281411, #281413,
    #284110, #326274.
  * Set Standards-Version to 3.6.2.
  * Added homepage to package descriptions.
  * Added debian watch file.
  [ Christian Perrier ]
  * Non-maintainer upload to add a udeb providing lspci for d-i purposes
    Closes: #284110
  [ Colin Watson ]
  * Changes merged from Ubuntu patches:
    - Add pciutils-udeb, for use in the installer. Contains only lspci,
      libpci.so.2, and pci.ids.
    - Reduce pciutils-udeb's copy of pci.ids by over 100KB by removing
      subsystem ids, which I don't think we need in the installer, and
      comments.
    - Move pciutils-udeb's copy of libpci.so.2 to /lib; it seems to confuse
      mklibs less that way.
  * NMU durring BSP
  * remove unneeded wget build-dependancy
  * Store pci.ids under /var for better FHS complicance (closes: #278479)
    patch by Sam Morris
  * Remove pci.ids.old etc when purging the package (closes: #281413)
    patch by Sam Morris
  * fix lspci -F for new or old lspci -x format (closes: #261536)
    based on patch by Ben Pfaff
  * update pci.ids (closes: #281411, hopefully closes: #326274)
  * Updated pci.ids
  * Closes: #259990: pciutils{, -dev}: package description shouldn't
    contain "(for 2.*.* kernels)"
  * Install example.c in package (closes: #228660)
  * Added Conflicts with older alsa-utils version (closes: #259661)
  * Updated pci.ids
  * Updated pci.ids
  * Add pcimodules utility (closes: #253020)
  * Add -X option for output suitable for use in XFree86Config (closes:
    #251828)
  * Fix problem with lspci displaying wrong bar size (closes: #256352)
  * Make machine-readable output better machine-readable (closes:
    #250737)
  * Oops now with correct replaces versioning

569fc11... by Remco van de Meent <email address hidden> on 2004-04-20

Import patches-applied version 1:2.1.11-11 to applied/ubuntu/warty

Imported using git-ubuntu import.

Unapplied parent: c2b80f7852ceb6cd7b87a4a55e848385a49725a7

c2b80f7... by Remco van de Meent <email address hidden> on 2004-04-20

Import patches-unapplied version 1:2.1.11-11 to ubuntu/warty

Imported using git-ubuntu import.