ubuntu/+source/pango1.0:ubuntu/zesty

Last commit made on 2017-02-28
Get this branch:
git clone -b ubuntu/zesty https://git.launchpad.net/ubuntu/+source/pango1.0
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
ubuntu/zesty
Repository:
lp:ubuntu/+source/pango1.0

Recent commits

e87381d... by Michael Biebl on 2017-02-28

Import patches-unapplied version 1.40.4-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a8bdd754740bb7cb0b4a568ba8c791fdf898802a

New changelog entries:
  * New upstream release.
  * Drop debian/patches/disable-layout-test.patch, no longer needed.
  * Force update of pango-view.1.in to ensure it doesn't contain a dummy text.
    This requires a Build-Depends on help2man. (Closes: #774431)

a8bdd75... by Martin Pitt on 2016-10-25

Import patches-unapplied version 1.40.3-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b2a964fe5c085e87b9b373ecbd5622331a9d15d6

New changelog entries:
  [ Martin Pitt ]
  * Drop libpango1.0-doc's "lynx | www-browser" dependency. Docs can also be
    read with devhelp, Chromium, or other browsers, there is no reason for
    this to be a strict dependency.
  [ Jeremy Bicha ]
  * Add missing hyphen to fix autopkgtest

b2a964f... by Michael Biebl on 2016-09-22

Import patches-unapplied version 1.40.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c0f67e1ba6845052536d143dfc9ac1f2081f0b6c

New changelog entries:
  * Update debian/libpango1.0-doc.install to use the installed files.
    This allows us to use dh-install --fail-missing.
  * Enable all hardening build flags.

c0f67e1... by Michael Biebl on 2016-09-22

Import patches-unapplied version 1.40.3-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9d09e29977c532f66c16c76e21f454cc2af6ce80

New changelog entries:
  * New upstream release.
  * Drop libpango1.0-0-dbg and switch to automatic dbgsym packages.
  * Bump debhelper compat level to 9.
  * Drop debian/libpango1.0-common.README.Debian, it's horribly outdated.
  * Drop the multiflavor builds. Those are no longer necessary after the
    modules system has been dropped and we have udebs for all necessary
    dependencies.
  * Convert from cdbs to dh.
  * Bump debhelper compat level to 10.
  * Use dh_install --list-missing to show uninstalled files.
  * Remove symlink-to-doc migration code from pre-wheezy.
  * Drop obsolete Replaces from pre-wheezy.
  * Use dbus-run-session to run tests (autopkgtest). (Closes: #836040)
  * Drop debian/patches/configure-without-libthai.patch now that there's a
    libthai udeb.

9d09e29... by Andreas Henriksson on 2016-08-30

Import patches-unapplied version 1.40.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9ee1cf771117821f4fde144a7d763a67ed138ef4

New changelog entries:
  [ Jeremy Bicha ]
  * debian/control.in: Add homepage
  [ Andreas Henriksson ]
  * New upstream release.

9ee1cf7... by Michael Biebl on 2016-04-15

Import patches-unapplied version 1.40.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b3be04dc0165e5961f2ae0701723649ef1b022b7

New changelog entries:
  [ Andreas Henriksson ]
  * Drop --without-libthai now that there's a libthai udeb (Closes: #803228)
  * Bump libthai build-dependency to 0.1.22-3~ which gives us the udeb.
  * State font-cantarell is only a build-dependency unless nocheck profile.
    - since we only need it for tests to pass.
  [ Michael Biebl ]
  * New upstream release.
  * Bump Build-Depends on debhelper to (>= 9.20141010) and add a versioned
    Build-Depends on dpkg-dev (>= 1.17.14) for <!nocheck> support.
  * Drop obsolete Conflicts, Breaks and Replaces from pre-wheezy.
  * Bump Standards-Version to 3.9.8.

b3be04d... by Andreas Henriksson on 2015-10-20

Import patches-unapplied version 1.38.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 63c4d28dd524580625f22ab6c5466e3d7f5909d5

New changelog entries:
  [ Michael Biebl ]
  * Use https:// for Vcs-Browser
  [ Andreas Henriksson ]
  * New upstream release.
  * Bump build-dependencies according to configure.ac changes:
    - libharfbuzz-dev >= 0.9.30
  * Drop debian/patches/tests-needs-asserts.patch, fixed upstream.
  * Bump Standards-Version to 3.9.6
  * Add "(transitional package)" to libpango1.0-0 short description
    (Closes: #714766)

63c4d28... by Andreas Henriksson on 2015-09-28

Import patches-unapplied version 1.38.0-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0c63e1a981dcd1bd1817dfaa5f1d30b9ef717375

New changelog entries:
  * Add debian/patches/configure-without-libthai.patch
    - make it possible to disable checking for libthai
  * debian/rules: configure udeb build --without-libthai
    - this avoids the udeb picking up a dependency on libthai which has
      no udeb. (Closes: #800356)
  * Add debian/patches/disable-layout-test.patch
    - disable flaky test while waiting for feedback on bgo#755733

0c63e1a... by Andreas Henriksson on 2015-09-28

Import patches-unapplied version 1.38.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 225c71d9c147cec25b5c51070bc849e629eb0d53

New changelog entries:
  * New upstream release.
  * Add debian/patches/tests-needs-asserts.patch
    - fixes issue in testattributes (bgo#755126) under --disable-debug
  * Make tests fatal again.

225c71d... by Andreas Henriksson on 2015-09-16

Import patches-unapplied version 1.37.5-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: e0fe77f4e70afca7ca1bfae11d477e3fa5dbaa74

New changelog entries:
  * New upstream development release.
    - The module system is now deprecated.
  * Drop patches obsoleted by module system deprecation:
    - 10_scan-module-files-in-dirs.patch
    - 11_module-files-append-module-files-d.patch
    - 14_makefile_modules_ft2_link_harfbuzz.patch
  * Drop lingering unused patch
    - 13_configure-thai-modules.patch
  * Partial import of Ubuntu gnome3 staging ppa 1.37.4-0ubuntu1~wily0
    - symbols files updates
    - package updates for modules deprecation
    - drop debian/dh_pangomodules.in + debian/libpango1.0-dev.manpages
  * Make tests non-fatal while waiting for feedback on BGO#755126
    - This seems to be a problem in the test itself rather then pango.