ubuntu/+source/pam:applied/ubuntu/artful

Last commit made on 2017-04-22
Get this branch:
git clone -b applied/ubuntu/artful https://git.launchpad.net/ubuntu/+source/pam
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/artful
Repository:
lp:ubuntu/+source/pam

Recent commits

372e739... by Steve Langasek on 2017-04-21

Import patches-applied version 1.1.8-3.2ubuntu3 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 51f6d5501c9d5c71c470af8ab91fc299f11cbd68
Unapplied parent: c6a5ddee3a9f2caaa09a9a0e2ace761725bba3f7

New changelog entries:
  * No-change rebuild to pick up -fPIE compiler default in static
    libraries

c6a5dde... by Steve Langasek on 2017-04-21

Import patches-unapplied version 1.1.8-3.2ubuntu3 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: a9caa0339f73959535134b211f3e680f92e84be3

New changelog entries:
  * No-change rebuild to pick up -fPIE compiler default in static
    libraries

51f6d55... by Marc Deslauriers on 2016-03-16

Import patches-applied version 1.1.8-3.2ubuntu2 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 3d76562b034304f77416f59120e3e91ef8f8b486
Unapplied parent: a9caa0339f73959535134b211f3e680f92e84be3

New changelog entries:
  * debian/patches-applied/cve-2015-3238.patch: removed manpage changes
    so they don't get regenerated during build and cause a multiarch
    installation issue. (LP: #1558114)

a9caa03... by Marc Deslauriers on 2016-03-16

Import patches-unapplied version 1.1.8-3.2ubuntu2 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 9ff544fb088baa359eda655f3937292c714d196b

New changelog entries:
  * debian/patches-applied/cve-2015-3238.patch: removed manpage changes
    so they don't get regenerated during build and cause a multiarch
    installation issue. (LP: #1558114)

3d76562... by Marc Deslauriers on 2016-03-16

Import patches-applied version 1.1.8-3.2ubuntu1 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 9ee87ef23fb4c564a12413128200e54851f2af92
Unapplied parent: 9ff544fb088baa359eda655f3937292c714d196b

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - debian/libpam-modules.postinst: Add PATH to /etc/environment if it's
      not present there or in /etc/security/pam_env.conf. (should send to
      Debian).
    - debian/libpam0g.postinst: only ask questions during update-manager when
      there are non-default services running.
    - debian/libpam0g.postinst: check if gdm is actually running before
      trying to reload it.
    - debian/libpam0g.postinst: the init script for 'samba' is now named
      'smbd' in Ubuntu, so fix the restart handling.
    - Change Vcs-Bzr to point at the Ubuntu branch.
    - debian/patches-applied/series: Ubuntu patches are as below ...
    - debian/patches-applied/ubuntu-rlimit_nice_correction: Explicitly
      initialise RLIMIT_NICE rather than relying on the kernel limits.
    - debian/patches-applied/pam_umask_usergroups_from_login.defs.patch:
      Deprecate pam_unix's explicit "usergroups" option and instead read it
      from /etc/login.def's "USERGROUP_ENAB" option if umask is only defined
      there. This restores compatibility with the pre-PAM behaviour of login.
    - debian/patches-applied/pam_motd-legal-notice: display the contents of
      /etc/legal once, then set a flag in the user's homedir to prevent
      showing it again.
    - debian/update-motd.5, debian/libpam-modules.manpages: add a manpage
      for update-motd, with some best practices and notes of explanation.
    - debian/patches/update-motd-manpage-ref: add a reference in pam_motd(8)
      to update-motd(5)
    - debian/local/common-session{,-noninteractive}: Enable pam_umask by
      default, now that the umask setting is gone from /etc/profile.
    - debian/local/pam-auth-update: Add the new md5sums for pam_umask addition.
    - Build-depend on libfl-dev in addition to flex, for cross-building
      support.
    - Add /usr/local/games to PATH.
    - Adjust debian/patches-applied/update-motd to write to
      /run/motd.dynamic, as sysvinit/ssh/login in Debian have been changed
      to use this file and no longer links /etc/motd to /var/run/motd.
    - debian/patches-applied/pam_umask_usergroups_from_login.defs.patch:
      include patch to autogenerated manpage file
    - debian/patches-applied/pam-loginuid-in-containers: pam_loginuid:
      Update patch with follow-up changes to loginuid.c
    - debian/patches-applied/extrausers.patch: Add a pam_extrausers module
      that is basically just a copy of pam_unix but looks at
      /var/lib/extrausers/{group,passwd,shadow} instead of /etc/
    - debian/libpam-modules-bin.install: install the helper binaries for
      pam_extrausers to /sbin
    - debian/rules: Make pam_extrausers_chkpwd sguid shadow
    - debian/patches-applied/extrausers.patch: Ship pre-generated man page
    - debian/patches-applied/pam-limits-nofile-fd-setsize-cap: cap the default
      soft nofile limit read from pid 1 to FD_SETSIZE.
    - debian/control: have libpam-modules recommend update-motd package

9ff544f... by Marc Deslauriers on 2016-03-16

Import patches-unapplied version 1.1.8-3.2ubuntu1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 098ff91c5d15b8d9c9292122b6edf85cc674ce45

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - debian/libpam-modules.postinst: Add PATH to /etc/environment if it's
      not present there or in /etc/security/pam_env.conf. (should send to
      Debian).
    - debian/libpam0g.postinst: only ask questions during update-manager when
      there are non-default services running.
    - debian/libpam0g.postinst: check if gdm is actually running before
      trying to reload it.
    - debian/libpam0g.postinst: the init script for 'samba' is now named
      'smbd' in Ubuntu, so fix the restart handling.
    - Change Vcs-Bzr to point at the Ubuntu branch.
    - debian/patches-applied/series: Ubuntu patches are as below ...
    - debian/patches-applied/ubuntu-rlimit_nice_correction: Explicitly
      initialise RLIMIT_NICE rather than relying on the kernel limits.
    - debian/patches-applied/pam_umask_usergroups_from_login.defs.patch:
      Deprecate pam_unix's explicit "usergroups" option and instead read it
      from /etc/login.def's "USERGROUP_ENAB" option if umask is only defined
      there. This restores compatibility with the pre-PAM behaviour of login.
    - debian/patches-applied/pam_motd-legal-notice: display the contents of
      /etc/legal once, then set a flag in the user's homedir to prevent
      showing it again.
    - debian/update-motd.5, debian/libpam-modules.manpages: add a manpage
      for update-motd, with some best practices and notes of explanation.
    - debian/patches/update-motd-manpage-ref: add a reference in pam_motd(8)
      to update-motd(5)
    - debian/local/common-session{,-noninteractive}: Enable pam_umask by
      default, now that the umask setting is gone from /etc/profile.
    - debian/local/pam-auth-update: Add the new md5sums for pam_umask addition.
    - Build-depend on libfl-dev in addition to flex, for cross-building
      support.
    - Add /usr/local/games to PATH.
    - Adjust debian/patches-applied/update-motd to write to
      /run/motd.dynamic, as sysvinit/ssh/login in Debian have been changed
      to use this file and no longer links /etc/motd to /var/run/motd.
    - debian/patches-applied/pam_umask_usergroups_from_login.defs.patch:
      include patch to autogenerated manpage file
    - debian/patches-applied/pam-loginuid-in-containers: pam_loginuid:
      Update patch with follow-up changes to loginuid.c
    - debian/patches-applied/extrausers.patch: Add a pam_extrausers module
      that is basically just a copy of pam_unix but looks at
      /var/lib/extrausers/{group,passwd,shadow} instead of /etc/
    - debian/libpam-modules-bin.install: install the helper binaries for
      pam_extrausers to /sbin
    - debian/rules: Make pam_extrausers_chkpwd sguid shadow
    - debian/patches-applied/extrausers.patch: Ship pre-generated man page
    - debian/patches-applied/pam-limits-nofile-fd-setsize-cap: cap the default
      soft nofile limit read from pid 1 to FD_SETSIZE.
    - debian/control: have libpam-modules recommend update-motd package

9ee87ef... by Tianon Gravi on 2016-01-06

Import patches-applied version 1.1.8-3.2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 4169cd48a774013ee5829363c6cc5a8f152bd975
Unapplied parent: 098ff91c5d15b8d9c9292122b6edf85cc674ce45

New changelog entries:
  * Non-maintainer upload.
  * Fix CVE-2015-3238: DoS/user enumeration due to blocking pipe in pam_unix
    module (Closes: #789986)

098ff91... by Tianon Gravi on 2016-01-06

Import patches-unapplied version 1.1.8-3.2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: ba9a54a5f21d3f767b01746e8261a32af435001e

New changelog entries:
  * Non-maintainer upload.
  * Fix CVE-2015-3238: DoS/user enumeration due to blocking pipe in pam_unix
    module (Closes: #789986)

4169cd4... by Michael Gilbert <email address hidden> on 2014-08-09

Import patches-applied version 1.1.8-3.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: bd1b2067858b6a1da51d145edac5c998a23aab78
Unapplied parent: ba9a54a5f21d3f767b01746e8261a32af435001e

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Fix CVE-2013-7041: case-insensitive comparison used for verifying
    passwords in the pam_userdb module (closes: #731368).
  * Fix CVE-2014-2583: multiple directory traversal issues in the
    pam_timestamp module (closes: 757555)

ba9a54a... by Michael Gilbert <email address hidden> on 2014-08-09

Import patches-unapplied version 1.1.8-3.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1e3e4fdd1efd23d0302f6402307f35d0bef07f01

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Fix CVE-2013-7041: case-insensitive comparison used for verifying
    passwords in the pam_userdb module (closes: #731368).
  * Fix CVE-2014-2583: multiple directory traversal issues in the
    pam_timestamp module (closes: 757555)