ubuntu/+source/openvpn:applied/ubuntu/yakkety-updates

Last commit made on 2017-06-22
Get this branch:
git clone -b applied/ubuntu/yakkety-updates https://git.launchpad.net/ubuntu/+source/openvpn
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/yakkety-updates
Repository:
lp:ubuntu/+source/openvpn

Recent commits

71a6188... by Marc Deslauriers on 2017-06-22

Import patches-applied version 2.3.11-1ubuntu2.1 to applied/ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: 73b5a05968a26009d9ce978ceac946ca58d77b4a
Unapplied parent: 36e0f091ab2d7354cf5a3db3988bc023d4b5c4fc

New changelog entries:
  * SECURITY UPDATE: birthday attack when using 64-bit block cipher
    - debian/patches/CVE-2016-6329.patch: print warning if 64-bit cipher is
      selected in src/openvpn/crypto.c, src/openvpn/crypto_openssl.c,
      src/openvpn/crypto_polarssl.c, tests/t_lpback.sh.
    - CVE-2016-6329
  * SECURITY UPDATE: DoS due to Exhaustion of Packet-ID counter
    - debian/patches/CVE-2017-7479-pre.patch: merge
      packet_id_alloc_outgoing() into packet_id_write() in
      src/openvpn/crypto.c, src/openvpn/packet_id.c,
      src/openvpn/packet_id.h.
    - debian/patches/CVE-2017-7479.patch: drop packets instead of assert
      out if packet id rolls over in src/openvpn/crypto.c,
      src/openvpn/packet_id.c, src/openvpn/packet_id.h.
    - CVE-2017-7479
  * SECURITY UPDATE: Remotely-triggerable ASSERT() on malformed IPv6 packet
    - debian/patches/CVE-2017-7508.patch: remove assert in
      src/openvpn/mss.c.
    - CVE-2017-7508
  * SECURITY UPDATE: Remote-triggerable memory leaks
    - debian/patches/CVE-2017-7512.patch: fix leaks in
      src/openvpn/ssl_verify_openssl.c.
    - CVE-2017-7512
  * SECURITY UPDATE: Pre-authentication remote crash/information disclosure
    for clients
    - debian/patches/CVE-2017-7520.patch: prevent two kinds of stack buffer
      OOB reads and a crash for invalid input data in src/openvpn/ntlm.c.
    - CVE-2017-7520
  * SECURITY UPDATE: Potential double-free in --x509-alt-username and
    memory leaks
    - debian/patches/CVE-2017-7521.patch: fix double-free in
      src/openvpn/ssl_verify_openssl.c.
    - CVE-2017-7521
  * SECURITY UPDATE: DoS in establish_http_proxy_passthru()
    - debian/patches/establish_http_proxy_passthru_dos.patch: fix
      null-pointer dereference in src/openvpn/proxy.c.
    - No CVE number

36e0f09... by Marc Deslauriers on 2017-06-22

[PATCH] Fix a null-pointer dereference in

Gbp-Pq: establish_http_proxy_passthru_dos.patch.

f5b5bab... by Marc Deslauriers on 2017-06-22

[PATCH] Fix potential double-free in --x509-alt-username

Gbp-Pq: CVE-2017-7521.patch.

f9184e9... by Marc Deslauriers on 2017-06-22

[PATCH] Prevent two kinds of stack buffer OOB reads and a crash for

Gbp-Pq: CVE-2017-7520.patch.

035b234... by Marc Deslauriers on 2017-06-22

[PATCH] Fix remote-triggerable memory leaks (CVE-2017-7521)

Gbp-Pq: CVE-2017-7512.patch.

988bfb5... by Marc Deslauriers on 2017-06-22

[PATCH] Fix remotely-triggerable ASSERT() on malformed IPv6 packet.

Gbp-Pq: CVE-2017-7508.patch.

609f74a... by Marc Deslauriers on 2017-06-22

[PATCH] Drop packets instead of assert out if packet id rolls over

Gbp-Pq: CVE-2017-7479.patch.

14db24d... by Marc Deslauriers on 2017-06-22

[PATCH] cleanup: merge packet_id_alloc_outgoing() into

Gbp-Pq: CVE-2017-7479-pre.patch.

1272b24... by Marc Deslauriers on 2017-06-22

[PATCH] Discourage using 64-bit block ciphers

Gbp-Pq: CVE-2016-6329.patch.

fdaf28b... by Marc Deslauriers on 2017-06-22

Man page fixes

Gbp-Pq: manpage_fixes.patch.