ubuntu/+source/openssl:applied/ubuntu/jaunty

Last commit made on 2009-03-27
Get this branch:
git clone -b applied/ubuntu/jaunty https://git.launchpad.net/ubuntu/+source/openssl
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/jaunty
Repository:
lp:ubuntu/+source/openssl

Recent commits

e5442e0... by Jamie Strandboge on 2009-03-27

Import patches-applied version 0.9.8g-15ubuntu3 to applied/ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 666da930ecd8b00d0afc0a1cf755e24e229415fc
Unapplied parent: 1b94937b3782720f97ad0329c5fd97b1ce112430

New changelog entries:
  * SECURITY UPDATE: crash via invalid memory access when printing BMPString
    or UniversalString with invalid length
    - crypto/asn1/tasn_dec.c, crypto/asn1/asn1_err.c and crypto/asn1/asn1.h:
      return error if invalid length
    - CVE-2009-0590
    - http://www.openssl.org/news/secadv_20090325.txt
    - patch from upstream CVS:
      crypto/asn1/asn1.h:1.128.2.11->1.128.2.12
      crypto/asn1/asn1_err.c:1.54.2.4->1.54.2.5
      crypto/asn1/tasn_dec.c:1.26.2.10->1.26.2.11

1b94937... by Jamie Strandboge on 2009-03-27

Import patches-unapplied version 0.9.8g-15ubuntu3 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: f791860940867e68ef7c0f039b8da0ca6224a9b2

New changelog entries:
  * SECURITY UPDATE: crash via invalid memory access when printing BMPString
    or UniversalString with invalid length
    - crypto/asn1/tasn_dec.c, crypto/asn1/asn1_err.c and crypto/asn1/asn1.h:
      return error if invalid length
    - CVE-2009-0590
    - http://www.openssl.org/news/secadv_20090325.txt
    - patch from upstream CVS:
      crypto/asn1/asn1.h:1.128.2.11->1.128.2.12
      crypto/asn1/asn1_err.c:1.54.2.4->1.54.2.5
      crypto/asn1/tasn_dec.c:1.26.2.10->1.26.2.11

666da93... by Colin Watson on 2009-03-06

Import patches-applied version 0.9.8g-15ubuntu2 to applied/ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 97bc19ca2673181b7e26c3b1d6959470e844eae9
Unapplied parent: f791860940867e68ef7c0f039b8da0ca6224a9b2

New changelog entries:
  * Move runtime libraries to /lib, for the benefit of wpasupplicant
    (LP: #44194). Leave symlinks behind in /usr/lib (except on the Hurd)
    since we used to set an rpath there.

f791860... by Colin Watson on 2009-03-06

Import patches-unapplied version 0.9.8g-15ubuntu2 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 9be68047095b30a85bf1c6e0df31503893ef5399

New changelog entries:
  * Move runtime libraries to /lib, for the benefit of wpasupplicant
    (LP: #44194). Leave symlinks behind in /usr/lib (except on the Hurd)
    since we used to set an rpath there.

97bc19c... by Bhavani Shankar on 2009-01-08

Import patches-applied version 0.9.8g-15ubuntu1 to applied/ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 6e84b471778fe2d889895af99703f4880aa6175a
Unapplied parent: 9be68047095b30a85bf1c6e0df31503893ef5399

New changelog entries:
  * Merge from debian unstable, remaining changes: LP: #314984
    - Link using -Bsymbolic-functions
    - Add support for lpia
    - Disable SSLv2 during compile
    - Ship documentation in openssl-doc, suggested by the package.
    - Use a different priority for libssl0.9.8/restart-services
      depending on whether a desktop, or server dist-upgrade is being
      performed.
    - Display a system restart required notification bubble on libssl0.9.8
      upgrade.
    - Replace duplicate files in the doc directory with symlinks.

9be6804... by Bhavani Shankar on 2009-01-08

Import patches-unapplied version 0.9.8g-15ubuntu1 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: b4d9cee3a26111ca8e1c6ef5269b9e7a52b097a0

New changelog entries:
  * Merge from debian unstable, remaining changes: LP: #314984
    - Link using -Bsymbolic-functions
    - Add support for lpia
    - Disable SSLv2 during compile
    - Ship documentation in openssl-doc, suggested by the package.
    - Use a different priority for libssl0.9.8/restart-services
      depending on whether a desktop, or server dist-upgrade is being
      performed.
    - Display a system restart required notification bubble on libssl0.9.8
      upgrade.
    - Replace duplicate files in the doc directory with symlinks.

6e84b47... by Kurt Roeckx on 2009-01-05

Import patches-applied version 0.9.8g-15 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 308c58153cf180319eddb351a2cc57ea7b1d3378
Unapplied parent: b4d9cee3a26111ca8e1c6ef5269b9e7a52b097a0

New changelog entries:
  * Internal calls to didn't properly check for errors which
    resulted in malformed DSA and ECDSA signatures being treated as
    a good signature rather than as an error. (CVE-2008-5077)
  * ipv6_from_asc() could write 1 byte longer than the buffer in case
    the ipv6 address didn't have "::" part. (Closes: #506111)

b4d9cee... by Kurt Roeckx on 2009-01-05

Import patches-unapplied version 0.9.8g-15 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d13821f2ec94e98681a291da72460fa0bcc9c3e4

New changelog entries:
  * Internal calls to didn't properly check for errors which
    resulted in malformed DSA and ECDSA signatures being treated as
    a good signature rather than as an error. (CVE-2008-5077)
  * ipv6_from_asc() could write 1 byte longer than the buffer in case
    the ipv6 address didn't have "::" part. (Closes: #506111)

308c581... by Kurt Roeckx on 2008-10-31

Import patches-applied version 0.9.8g-14 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 57d3b029ed311c75f4900691555564846a358b2e
Unapplied parent: d13821f2ec94e98681a291da72460fa0bcc9c3e4

New changelog entries:
  * Don't give the warning about security updates when upgrading
    from etch since it doesn't have any known security problems.
  * Automaticly use engines that succesfully initialised. Patch
    from the 0.9.8h upstream version. (Closes: #502177)

d13821f... by Kurt Roeckx on 2008-10-31

Import patches-unapplied version 0.9.8g-14 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1afdf04ba23791f54bc25f20ac7f9867678fe10f

New changelog entries:
  * Don't give the warning about security updates when upgrading
    from etch since it doesn't have any known security problems.
  * Automaticly use engines that succesfully initialised. Patch
    from the 0.9.8h upstream version. (Closes: #502177)