ubuntu/+source/openssl:applied/ubuntu/disco

Last commit made on 2019-04-03
Get this branch:
git clone -b applied/ubuntu/disco https://git.launchpad.net/ubuntu/+source/openssl
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/ubuntu/disco
Repository:
lp:ubuntu/+source/openssl

Recent commits

7a6e3da... by Dimitri John Ledkov on 2019-04-03

Import patches-applied version 1.1.1b-1ubuntu2 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 696abd501c998f1fb791991ea16c07f073813a27
Unapplied parent: 74ff814d1f44e36313c3fa51d2745f0bd77e4b46

New changelog entries:
  * debian/rules: Ship openssl.cnf in libssl1.1-udeb, as required to use
    OpenSSL by other udebs, e.g. wget-udeb. LP: #1822898
  * Drop debian/patches/UBUNTU-lower-tls-security-level-for-compat.patch
    to revert TLS_SECURITY_LEVEL back to 1. LP: #1822984

74ff814... by Dimitri John Ledkov on 2019-04-03

Set systemwide default settings for libssl users

Gbp-Pq: UBUNTU-Revert-Set-systemwide-default-settings-for-libssl-users.patch.

1017d8d... by Dimitri John Ledkov on 2019-04-03

Set systemwide default settings for libssl users

Gbp-Pq: Set-systemwide-default-settings-for-libssl-users.patch.

0bdfb4c... by Dimitri John Ledkov on 2019-04-03

[PATCH] also create old hash for compatibility

Gbp-Pq: c_rehash-compat.patch.

07f3783... by Dimitri John Ledkov on 2019-04-03

pic

Gbp-Pq: pic.patch.

b1b7023... by Dimitri John Ledkov on 2019-04-03

no-symbolic

Gbp-Pq: no-symbolic.patch.

4c1d16b... by Dimitri John Ledkov on 2019-04-03

man-section

Gbp-Pq: man-section.patch.

5f7b378... by Dimitri John Ledkov on 2019-04-03

debian-targets

Gbp-Pq: debian-targets.patch.

0f32d6f... by Dimitri John Ledkov on 2019-04-03

Import patches-unapplied version 1.1.1b-1ubuntu2 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 797f7efc3a472687971ac8d279efa8ee540bb91c

New changelog entries:
  * debian/rules: Ship openssl.cnf in libssl1.1-udeb, as required to use
    OpenSSL by other udebs, e.g. wget-udeb. LP: #1822898
  * Drop debian/patches/UBUNTU-lower-tls-security-level-for-compat.patch
    to revert TLS_SECURITY_LEVEL back to 1. LP: #1822984

696abd5... by Dimitri John Ledkov on 2019-02-27

Import patches-applied version 1.1.1b-1ubuntu1 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: aa4be44164bd20c513f21bab3e061bfd4e522ab3
Unapplied parent: 6844c6d2fb7ed708f3d5b56c6f240eaaf15c9fbd

New changelog entries:
  * Merge from Debian unstable, remaining changes:
    - Replace duplicate files in the doc directory with symlinks.
    - debian/libssl1.1.postinst:
      + Display a system restart required notification on libssl1.1
        upgrade on servers.
      + Use a different priority for libssl1.1/restart-services depending
        on whether a desktop, or server dist-upgrade is being performed.
    - Revert "Enable system default config to enforce TLS1.2 as a
      minimum" & "Increase default security level from 1 to 2".
    - Further decrease security level from 1 to 0, for compatibility with
      openssl 1.0.2.
    - Drop the NEWS entry, not applicable on Ubuntu.