ubuntu/+source/okular:debian/experimental

Last commit made on 2020-03-01
Get this branch:
git clone -b debian/experimental https://git.launchpad.net/ubuntu/+source/okular
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
debian/experimental
Repository:
lp:ubuntu/+source/okular

Recent commits

2793979... by Pino Toscano <email address hidden> on 2020-03-01

Import patches-unapplied version 4:19.12.2-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 84049af2d3e2443f59a774f9e42a47bcc1adc6ab

New changelog entries:
  * Team upload.
  * New upstream release.
  * Update watch file to the new release-service location.
  * Update the build dependencies according to the upstream build system:
    - bump extra-cmake-modules to 5.33.0
    - bump Qt packages to 5.9.0
    - bump KF packages to 5.44.0
    - remove unused libx11-dev
    - explicitly add gettext
  * Drop the 'testsuite' autopkgtest, as it does not test the installed
    packages.
  * Remove unused okular-dev.acc.in file.
  * Add the configuration for the CI on salsa.
  * Update install files.
  * Unregister okular.categories as conffile, as it is no more in /etc.
  * Pass -DBUILD_TESTING=OFF to cmake to disable the build of tests, as they
    are not run at build time anyway.
  * Switch from dhmk to the dh sequencer:
    - invoke the dh sequencer using the kf5 addon
    - explicitly link in as-needed mode
    - call the right debhelper command instead of $(overridden_command)
  * Bump the debhelper compatibility to 12:
    - switch the debhelper build dependency to debhelper-compat 12
    - remove debian/compat
    - drop the dh_makeshlibs override, as -V is done by default
  * Remove extra quoting around %s in mailcap entries.
  * Remove not-installed file, no more needed now.
  * Bump Standards-Version to 4.5.0, no changes required.

84049af... by Pino Toscano <email address hidden> on 2018-05-08

Import patches-unapplied version 4:18.04.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 4e8b0d71824fd6e5273e40a81a06d0801edc46df

New changelog entries:
  * Team upload.
  * New upstream release.
  * Rename libokular5core8 to libokular5core9, according to the upstream SONAME
    bump.
  * Update the build & runtime dependencies:
    - bump all the Qt ones to >= 5.8.0
    - bump all the KF5 ones to >= 5.33.0
    - add libkf5crash-dev, libkf5purpose-dev, and libqt5texttospeech5-dev
  * Switch Vcs-* fields to salsa.debian.org.
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
  * Bump Standards-Version to 4.1.4, no changes required.
  * Since the okularcore library bumps SONAME in each stable series, instead of
    using a symbols file make sure the generated shlibs requires the last
    version.
  * Remove the jovie suggests, as it is not useful for okular.

4e8b0d7... by Pino Toscano <email address hidden> on 2018-02-22

Import patches-unapplied version 4:17.12.2-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c0c54a214a2969462c5ddd76f42f53759472d519

New changelog entries:
  * Team upload.
  * Upload to unstable.

c0c54a2... by Pino Toscano <email address hidden> on 2018-02-20

Import patches-unapplied version 4:17.12.2-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: c2aa59ac9f0d6b02e07195324601b1b262e4f678

New changelog entries:
  * Team upload.
  * New upstream release: (Closes: #887746)
    - allows one to save changed document archives (Closes: #598806)
  * Rename libokular5core7 to libokular5core8, according to the upstream SONAME
    bump.
  * Add the libmarkdown2-dev, and libzip-dev build dependencies, optionally
    needed by the new version (for CHM and Mardown backends).
  * Update install files.
  * Split the QML module from okular to a separate qml-module-org-kde-okular:
    this way the main application does not contain QML-related files, and
    dependencies anymore
    - make okular-mobile depend on this new module
    - remove all the QML dependencies from okular
  * Tighten the inter-library dependencies.
  * Switch the qml-module-org-kde-kirigami dependency in okular-mobile to
    qml-module-org-kde-kirigami2, as it is used now.

c2aa59a... by Pino Toscano <email address hidden> on 2018-01-20

Import patches-unapplied version 4:17.08.3-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 14b5c2d58b78a43b1cd6e2d842e4c53265d64112

New changelog entries:
  * Team upload.
  [ Don Armstrong ]
  * Depend on kinit for kdeinit5 launcher (Closes: #886867)
  [ Pino Toscano ]
  * Bump Standards-Version to 4.1.3, no changes required.

14b5c2d... by Pino Toscano <email address hidden> on 2018-01-03

Import patches-unapplied version 4:17.08.3-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: aa75a07fd8c119983459820fad44735e9574bfed

New changelog entries:
  * Team upload.
  * Upload to unstable.
  * Bump Standards-Version to 4.1.3, no changes required.
  * Adjust l10npkgs_firstversion_ok to the version where kde-l10n will
    drop translations.

aa75a07... by Pino Toscano <email address hidden> on 2017-12-10

Import patches-unapplied version 4:17.08.3-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: e4535b21aa1986f435da2a0eb13b4538add5c7c7

New changelog entries:
  * Team upload.
  * New upstream release.
  * Bump Standards-Version to 4.1.2, no changes required.
  * Simplify watch file, and switch it to https.
  * Remove trailing whitespaces in changelog.
  * Install the upstream man pages using dh_install files, not with
    dh_installman, as they are installed by upstream.
  * Bump the libqmobipocket-dev build dependency to >= 4:17.08~, so the KF5
    version of it is used. (Closes: #876494)
  * Remove unused libkf5dbusaddons-dev build dependency.
  * Fix Vcs-* fields.
  * Update lintian overrides.

e4535b2... by Maximiliano Curia on 2017-09-12

Import patches-unapplied version 4:17.08.1-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: c3589232889697842d178a79fdcede1c987479c7

New changelog entries:
  [ Maximiliano Curia ]
  * New upstream release (17.08.1)
  * Bump Standards-Version to 4.1.0.
  * Update upstream metadata
  * Update build-deps and deps with the info from cmake
  * Release to experimental
  [ Jonathan Riddell ]
  * update sig
  * New release
  * New release
  * Automatic Ubuntu CI Build
  * New release
  * New release
  * New release
  * New release
  * New release
  * New release
  * New release
  * Add xscreensaver to test runtime deps, I can't seem to sort out
    what the other test wants :(
  * Update tests to kf5.
  * Fix inclue path in acc file
  * Fix controls qml version. Still working on autopkg test failures.
  * Add another missing qml dep.
  * Fix acc file to reflect new so file and version as this is a kf5 port.
  * Some more copyright file cleanup.
  * Fix Unknown copyright entry.
  * Add missing files.
  * Add qml deps.
  * Fix copyright, install files.
  * Fix lintian overrides.
  * Add package for mobile.
  * Add back epoch
  * KF5 port

c358923... by Maximiliano Curia on 2016-10-19

Import patches-unapplied version 4:16.08.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d673c00a37bd82ef3d8385aea115f1b9d784438b

New changelog entries:
  [ Automatic packaging ]
  * Update symbols files.
  [ Maximiliano Curia ]
  * New upstream release (16.08.2)

d673c00... by Pino Toscano <email address hidden> on 2016-07-02

Import patches-unapplied version 4:16.04.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 74b923cdc52611944ad0546389b1610a7dd0012a

New changelog entries:
  * Team upload.
  * New upstream release.
  * Remove the kactivities support, since the KDE 4 version is unmaintained
    and not usable together with the Frameworks one:
    - drop the libkactivities-dev build dependency
  * Wrap too long line in older changelog entry.