ubuntu/+source/okular:applied/debian/experimental

Last commit made on 2020-03-01
Get this branch:
git clone -b applied/debian/experimental https://git.launchpad.net/ubuntu/+source/okular
Members of Ubuntu Server Dev import team can upload to this branch. Log in for directions.

Branch merges

Branch information

Name:
applied/debian/experimental
Repository:
lp:ubuntu/+source/okular

Recent commits

5c1e580... by Pino Toscano <email address hidden> on 2020-03-01

Import patches-applied version 4:19.12.2-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 7e856d8a3ecb11f0235c5cb3abb3c8f7d78fbc97
Unapplied parent: 2793979cf3609755813f746f6f7d79f932fd7fa7

New changelog entries:
  * Team upload.
  * New upstream release.
  * Update watch file to the new release-service location.
  * Update the build dependencies according to the upstream build system:
    - bump extra-cmake-modules to 5.33.0
    - bump Qt packages to 5.9.0
    - bump KF packages to 5.44.0
    - remove unused libx11-dev
    - explicitly add gettext
  * Drop the 'testsuite' autopkgtest, as it does not test the installed
    packages.
  * Remove unused okular-dev.acc.in file.
  * Add the configuration for the CI on salsa.
  * Update install files.
  * Unregister okular.categories as conffile, as it is no more in /etc.
  * Pass -DBUILD_TESTING=OFF to cmake to disable the build of tests, as they
    are not run at build time anyway.
  * Switch from dhmk to the dh sequencer:
    - invoke the dh sequencer using the kf5 addon
    - explicitly link in as-needed mode
    - call the right debhelper command instead of $(overridden_command)
  * Bump the debhelper compatibility to 12:
    - switch the debhelper build dependency to debhelper-compat 12
    - remove debian/compat
    - drop the dh_makeshlibs override, as -V is done by default
  * Remove extra quoting around %s in mailcap entries.
  * Remove not-installed file, no more needed now.
  * Bump Standards-Version to 4.5.0, no changes required.

2793979... by Pino Toscano <email address hidden> on 2020-03-01

Import patches-unapplied version 4:19.12.2-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 84049af2d3e2443f59a774f9e42a47bcc1adc6ab

New changelog entries:
  * Team upload.
  * New upstream release.
  * Update watch file to the new release-service location.
  * Update the build dependencies according to the upstream build system:
    - bump extra-cmake-modules to 5.33.0
    - bump Qt packages to 5.9.0
    - bump KF packages to 5.44.0
    - remove unused libx11-dev
    - explicitly add gettext
  * Drop the 'testsuite' autopkgtest, as it does not test the installed
    packages.
  * Remove unused okular-dev.acc.in file.
  * Add the configuration for the CI on salsa.
  * Update install files.
  * Unregister okular.categories as conffile, as it is no more in /etc.
  * Pass -DBUILD_TESTING=OFF to cmake to disable the build of tests, as they
    are not run at build time anyway.
  * Switch from dhmk to the dh sequencer:
    - invoke the dh sequencer using the kf5 addon
    - explicitly link in as-needed mode
    - call the right debhelper command instead of $(overridden_command)
  * Bump the debhelper compatibility to 12:
    - switch the debhelper build dependency to debhelper-compat 12
    - remove debian/compat
    - drop the dh_makeshlibs override, as -V is done by default
  * Remove extra quoting around %s in mailcap entries.
  * Remove not-installed file, no more needed now.
  * Bump Standards-Version to 4.5.0, no changes required.

7e856d8... by Pino Toscano <email address hidden> on 2018-05-08

Import patches-applied version 4:18.04.0-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 7096fae67ed887c28c91a79f7b9905a94e8c6ac5
Unapplied parent: 84049af2d3e2443f59a774f9e42a47bcc1adc6ab

New changelog entries:
  * Team upload.
  * New upstream release.
  * Rename libokular5core8 to libokular5core9, according to the upstream SONAME
    bump.
  * Update the build & runtime dependencies:
    - bump all the Qt ones to >= 5.8.0
    - bump all the KF5 ones to >= 5.33.0
    - add libkf5crash-dev, libkf5purpose-dev, and libqt5texttospeech5-dev
  * Switch Vcs-* fields to salsa.debian.org.
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
  * Bump Standards-Version to 4.1.4, no changes required.
  * Since the okularcore library bumps SONAME in each stable series, instead of
    using a symbols file make sure the generated shlibs requires the last
    version.
  * Remove the jovie suggests, as it is not useful for okular.

84049af... by Pino Toscano <email address hidden> on 2018-05-08

Import patches-unapplied version 4:18.04.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 4e8b0d71824fd6e5273e40a81a06d0801edc46df

New changelog entries:
  * Team upload.
  * New upstream release.
  * Rename libokular5core8 to libokular5core9, according to the upstream SONAME
    bump.
  * Update the build & runtime dependencies:
    - bump all the Qt ones to >= 5.8.0
    - bump all the KF5 ones to >= 5.33.0
    - add libkf5crash-dev, libkf5purpose-dev, and libqt5texttospeech5-dev
  * Switch Vcs-* fields to salsa.debian.org.
  * Bump the debhelper compatibility to 11:
    - bump the debhelper build dependency to 11~
    - bump compat to 11
  * Bump Standards-Version to 4.1.4, no changes required.
  * Since the okularcore library bumps SONAME in each stable series, instead of
    using a symbols file make sure the generated shlibs requires the last
    version.
  * Remove the jovie suggests, as it is not useful for okular.

7096fae... by Pino Toscano <email address hidden> on 2018-02-22

Import patches-applied version 4:17.12.2-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 188205495d7c84d12befd3a7bef3ee59625874a9
Unapplied parent: 4e8b0d71824fd6e5273e40a81a06d0801edc46df

New changelog entries:
  * Team upload.
  * Upload to unstable.

4e8b0d7... by Pino Toscano <email address hidden> on 2018-02-22

Import patches-unapplied version 4:17.12.2-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c0c54a214a2969462c5ddd76f42f53759472d519

New changelog entries:
  * Team upload.
  * Upload to unstable.

1882054... by Pino Toscano <email address hidden> on 2018-02-20

Import patches-applied version 4:17.12.2-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 0b1e6b7fafd11d66b8739198cb5a35cca0d3c85c
Unapplied parent: c0c54a214a2969462c5ddd76f42f53759472d519

New changelog entries:
  * Team upload.
  * New upstream release: (Closes: #887746)
    - allows one to save changed document archives (Closes: #598806)
  * Rename libokular5core7 to libokular5core8, according to the upstream SONAME
    bump.
  * Add the libmarkdown2-dev, and libzip-dev build dependencies, optionally
    needed by the new version (for CHM and Mardown backends).
  * Update install files.
  * Split the QML module from okular to a separate qml-module-org-kde-okular:
    this way the main application does not contain QML-related files, and
    dependencies anymore
    - make okular-mobile depend on this new module
    - remove all the QML dependencies from okular
  * Tighten the inter-library dependencies.
  * Switch the qml-module-org-kde-kirigami dependency in okular-mobile to
    qml-module-org-kde-kirigami2, as it is used now.

c0c54a2... by Pino Toscano <email address hidden> on 2018-02-20

Import patches-unapplied version 4:17.12.2-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: c2aa59ac9f0d6b02e07195324601b1b262e4f678

New changelog entries:
  * Team upload.
  * New upstream release: (Closes: #887746)
    - allows one to save changed document archives (Closes: #598806)
  * Rename libokular5core7 to libokular5core8, according to the upstream SONAME
    bump.
  * Add the libmarkdown2-dev, and libzip-dev build dependencies, optionally
    needed by the new version (for CHM and Mardown backends).
  * Update install files.
  * Split the QML module from okular to a separate qml-module-org-kde-okular:
    this way the main application does not contain QML-related files, and
    dependencies anymore
    - make okular-mobile depend on this new module
    - remove all the QML dependencies from okular
  * Tighten the inter-library dependencies.
  * Switch the qml-module-org-kde-kirigami dependency in okular-mobile to
    qml-module-org-kde-kirigami2, as it is used now.

0b1e6b7... by Pino Toscano <email address hidden> on 2018-01-20

Import patches-applied version 4:17.08.3-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 9c245cd92ed2c0dcee8e6fc55e2aebf2ceaad569
Unapplied parent: c2aa59ac9f0d6b02e07195324601b1b262e4f678

New changelog entries:
  * Team upload.
  [ Don Armstrong ]
  * Depend on kinit for kdeinit5 launcher (Closes: #886867)
  [ Pino Toscano ]
  * Bump Standards-Version to 4.1.3, no changes required.

c2aa59a... by Pino Toscano <email address hidden> on 2018-01-20

Import patches-unapplied version 4:17.08.3-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 14b5c2d58b78a43b1cd6e2d842e4c53265d64112

New changelog entries:
  * Team upload.
  [ Don Armstrong ]
  * Depend on kinit for kdeinit5 launcher (Closes: #886867)
  [ Pino Toscano ]
  * Bump Standards-Version to 4.1.3, no changes required.